BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 Marketplace > Vendor Comments/Review/Feedback Forum
 
Evolve Automotive
Closed Thread
 
Thread Tools Search this Thread
      04-18-2012, 07:34 AM   #23
abitrandom
Private First Class
 
Drives: 2008 m3 covertible
Join Date: Apr 2012
Location: Queens, NY

Posts: 104
iTrader: (1)

Quote:
Originally Posted by 808MGuy View Post
Where did I mention that I had a good experience with them? I don't even own LUX H8s. I have AIBs because I had the original LUX H8s that got recalled and decided to go another direction. My opinion has nothing to do with my previous experience with LUX. It has to do with what you don't seem to understand is common among the majority of companies. By your admission, you screwed up by throwing your OEM lamps away and now you want someone else to front you a part to account for that. From LUXs point of view, how do they know your part is really defective? What if they sent you another set and you end up keeping both because the original was never defective at all? Now their out 2 sets of product with only 1 paid for. How is that fair? The only way for them to verify that your product is defective is to see it and test it themselves.
Read my comments above. If it was a entire whole new set I would understand his point of view. But I clearly wrote one transformer works, the other one is defective. Therefore, I only need one.

This has been resolved in the end, I sent it out - waiting on new part. Case semi-closed.
abitrandom is offline  
0
      04-22-2012, 08:41 AM   #24
DarkstarZero
Major
 
DarkstarZero's Avatar
 
Drives: e39 M5, e36 M3, e92 M3, Z4M
Join Date: Nov 2007
Location: Washington DC

Posts: 1,179
iTrader: (4)

Send a message via AIM to DarkstarZero
Quote:
Originally Posted by kmarei View Post
Then I guess HP, Cisco, Netgear, Seagate etc are all in the same boat
I've put deposits on everything that I need to be replaced quickly
I could either ship my faulty unit to them, wait till the get it, and then they ship me one
Or pay a deposit, and they send me a new one first, then I get to ship the old one back
Standard practice, at least in the IT world
Those companies actually do free overnight advanced replacements on enterprise parts. Juniper sent me a $250,000 OC192 PIC as an advanced replacement part, no deposit required. But when it comes to consumer grade products, its always a huge hassle. Funny how it seems the cheaper the product the harder it is to get it RMA'd.

There are a few exceptions though, newegg (for electronics) and **********s (for car parts) will bend over backwards to keep any customer happy and thats why they have been so successful. Just my 2 cents.

Also, LUX, make some more 5000k's! I want to buy some
__________________
DarkstarZero is offline   United_States
0
      04-22-2012, 09:21 AM   #25
ottoblotto
///M-Flight Bavaria
 
ottoblotto's Avatar
 
Drives: E90M3
Join Date: Apr 2011
Location: Im around

Posts: 1,190
iTrader: (3)

Garage List
2010 BMW X5  [0.00]
2011.75 BMW M3 E90  [5.00]
Quote:
Originally Posted by DarkstarZero View Post
Also, LUX, make some more 5000k's! I want to buy some
This.

When I bought an Alienware desktop, the vid card failed. After some troubleshooting with a tech, I paid the deposit, and received the repl card a few days later. I put the old one in the box, got my deposit back a few days later. Done and done.
__________________
"With great power comes great responsibility." -El-Superbeasto
ottoblotto is offline   Germany
0
      04-22-2012, 03:22 PM   #26
abitrandom
Private First Class
 
Drives: 2008 m3 covertible
Join Date: Apr 2012
Location: Queens, NY

Posts: 104
iTrader: (1)

You guys seen to be missing the point a desktop is an entire product, this would make sense for the vendor to require a deposit. 1 transformer of mine did not work the other did. Your analogies hold no weight.

Lux sent me new transformer, they were quick about it i should get it tomorrow/ i like their product i was just unlucky and the inconvenience is always crappy in all cases
abitrandom is offline  
0
      04-22-2012, 04:01 PM   #27
GreeKon
It ain't gonna suck itself
 
GreeKon's Avatar
 
Drives: 2010 M3
Join Date: Jan 2012
Location: Philadelphia, PA

Posts: 715
iTrader: (1)

Quote:
Originally Posted by Cal@Sonic MS View Post
Inspect your connectors. You may have to utilize a pair of pliers to re-orient the pins as they can be a bit flimsy and retract inside the connector.

This is a common issue we've experienced with the LUX and can cause the flickering issue you are experiencing - but is an easy fix.

+1 I had the same exact issue and fixed it within 10 seconds.
GreeKon is offline  
0
      04-24-2012, 10:46 AM   #28
abitrandom
Private First Class
 
Drives: 2008 m3 covertible
Join Date: Apr 2012
Location: Queens, NY

Posts: 104
iTrader: (1)

Received part from LUX and all was clear. Problem resolved and I am happy about the final product.

Looks great on the car.
abitrandom is offline  
0
      04-24-2012, 10:57 AM   #29
tibra1
Banned
 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

Posts: 6,777
iTrader: (4)

Quote:
Originally Posted by abitrandom View Post
Received part from LUX and all was clear. Problem resolved and I am happy about the final product.

Looks great on the car.
So now you are happy?...
tibra1 is offline   No_Country
0
      04-24-2012, 11:00 AM   #30
LuxAngelEyes
BimmerPost Supporting Vendor

 
LuxAngelEyes's Avatar
 
Drives: 2006 325xi, Sparkling Graphite
Join Date: Jan 2011
Location: New Haven, CT

Posts: 3,067
iTrader: (12)

Can you please update the 1st post to show that this issue has been resolved. Thank you in advance!
LuxAngelEyes is offline   United_States
0
      04-24-2012, 11:06 AM   #31
geneatals
Ninja
 
geneatals's Avatar
 
Drives: 2011.5 E90 M3
Join Date: Dec 2007
Location: So Cal (SFV)

Posts: 3,202
iTrader: (2)

it's a security deposit, you get it back once all parts are received and damage can be verified. Any vendor needs to protect themselves from fraudulent activity (not saying your claim is fraudulent). Put yourself in their shoes, if they just start sending replacement parts out without proof of failure/malfunction they'd run them selves into the ground or it would drive their prices up.

point being: yes you are in the wrong and this is common practice. I think you're more annoyed for the fact that you threw out your stock oem halogen bulbs so you are stuck driving with a faulty AE. If you would have been able to just put the stock bulbs back in and wait for the replacement I think the 125 and wait time wouldn't have seemed so bad initially.

either way, this thread is 5 minutes of my life that I won't get back...should have asked for asecurity deposit before I started reading it....
__________________
2011.5 E90 M3 AW l Black Novillo Leather | Carbon Fiber Leather Trim | ZCP | ZP2 | M-DCT | Navigation | Moonroof | 6FL l Pics/Mods
Retired: 2008 535i l AW l Black Dakota Leather l Bamboo Anthracite l ZPP l ZSP l 6FL
geneatals is offline   Philippines
0
      04-24-2012, 12:33 PM   #32
Templar
Lieutenant Colonel
 
Templar's Avatar
 
Drives: 2011 E92 M3
Join Date: Feb 2009
Location: One of the coasts...

Posts: 1,816
iTrader: (1)

Garage List
2011 BMW M3  [5.00]
Quote:
Originally Posted by abitrandom View Post
You guys seen to be missing the point a desktop is an entire product, this would make sense for the vendor to require a deposit. 1 transformer of mine did not work the other did. Your analogies hold no weight.

Lux sent me new transformer, they were quick about it i should get it tomorrow/ i like their product i was just unlucky and the inconvenience is always crappy in all cases
If you read his whole post, he said one video card failed in his desktop, not the entire desktop...

__________________
'11 BMW E92 ///M3 - ZCP and DCT
'13 Toyota Tundra - 4x4 Platinum CrewMax, 5.7l iForce V8
Templar is offline   United_States
0
      04-24-2012, 12:49 PM   #33
JonnyM3
Lieutenant
 
JonnyM3's Avatar
 
Drives: Moderately Quick
Join Date: Nov 2009
Location: New York

Posts: 503
iTrader: (1)

Another human with a false sense of entitlement.

Never had a problem with my LUX, fortunately, but judging from their involvement of the forum if I did it seems the problem would be fixed promptly. Don't make threads like this unless you have a real issue, it can quickly tarnish a great companies reputation.
JonnyM3 is offline  
0
      04-25-2012, 11:20 AM   #34
LuxAngelEyes
BimmerPost Supporting Vendor

 
LuxAngelEyes's Avatar
 
Drives: 2006 325xi, Sparkling Graphite
Join Date: Jan 2011
Location: New Haven, CT

Posts: 3,067
iTrader: (12)

Quote:
Originally Posted by AudiS5 View Post
Another human with a false sense of entitlement.

Never had a problem with my LUX, fortunately, but judging from their involvement of the forum if I did it seems the problem would be fixed promptly. Don't make threads like this unless you have a real issue, it can quickly tarnish a great companies reputation.
That is why we have already fixed this issue with the OP, we are just waiting for him to update the original post.
LuxAngelEyes is offline   United_States
0
Closed Thread

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:53 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST