BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > Canada
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      03-11-2012, 05:34 PM   #1
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Anyone seen this warning before?

Just woke my M from hibernation in taking advantage of the amazing weather, and saw an "increased emission" warning light on my dashboard, never had this before.

I have Akro slip-on, is that why? But I didn't get this after I installed it, it only happened after I stored it for the winter, weird.

Any input is appreciated

Update: The warning sign was gone after I put about 35km on the car. Still not sure what triggered the problem, but it seems that people were right in saying "don't worry about it" =)

Thanks everyone!

Last edited by col.faith; 03-18-2012 at 03:20 PM.
col.faith is offline  
0
Reply With Quote
      03-11-2012, 06:40 PM   #2
M3-Mike
Second Lieutenant
 
M3-Mike's Avatar
 
Drives: 2008 M3 Coupe DCT
Join Date: Jan 2009
Location: Toronto

Posts: 265
iTrader: (0)

I wouldn't worry about it, I've seen this several times too and it usually goes away after a good blast down the highway.
M3-Mike is offline   Canada
0
Reply With Quote
      03-11-2012, 07:01 PM   #3
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by M3-Mike View Post
I wouldn't worry about it, I've seen this several times too and it usually goes away after a good blast down the highway.
LOL. Thanks man, I'll give it a shot.
col.faith is offline  
0
Reply With Quote
      03-12-2012, 12:33 PM   #4
GMW
Dolphin 38
 
GMW's Avatar
 
Drives: a Submarine
Join Date: Feb 2011
Location: Victoria, BC

Posts: 798
iTrader: (6)

Quote:
Originally Posted by col.faith View Post
Just woke my M from hibernation in taking advantage of the amazing weather, and saw an "increased emission" warning light on my dashboard, never had this before.

I have Akro slip-on, is that why? But I didn't get this after I installed it, it only happened after I stored it for the winter, weird.

Any input is appreciated
Could also be low fuel pressure. That's what my increased emissions CEL was related to. When the fuel level warning comes on....fuel up!
I agree...nothing to worry about
__________________
13' e92 M3 Frozen DARK Blue - Current
02' e39 540i Msport 6MT - DD
92' e34 535i AC Schnitzer - stolen/written off
11' e92 M3 - new owner
10' S1000RR - miss it every day / 09' K1300S - miss it most of all.
GMW is offline   Canada
0
Reply With Quote
      03-12-2012, 01:06 PM   #5
NYCM3ryder
Razzor
 
Drives: JB E90 M3
Join Date: Aug 2010
Location: New York City

Posts: 512
iTrader: (0)

nothing serious but if ur under warranty take it in. it could be many diff things. from throttle valve, to pump, to gas, to mis fire. the dealer will sort it out. its very common on our m3's
__________________

2011 E90, 6 speed, technology package, black 220 rims , EDC, moon roof, matt black grills, matte side grills, 15% carbon tints, carbon fiber M pedals, ACS roof wing, IND painted reflectors, mfest black gloss m3badges, Mfest side window stickers, Tuner MS 15mm spacers, Carbon fiber M foot pedals, MS air filter, RPI air scoops, euro switch mod
NYCM3ryder is offline   United_States
0
Reply With Quote
      03-12-2012, 03:23 PM   #6
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by GMW View Post
Could also be low fuel pressure. That's what my increased emissions CEL was related to. When the fuel level warning comes on....fuel up!
I agree...nothing to worry about
Mine is probably not related to fuel level since it was pretty full when it came up. But thanks for chiming in
col.faith is offline  
0
Reply With Quote
      03-12-2012, 03:32 PM   #7
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by NYCM3ryder View Post
nothing serious but if ur under warranty take it in. it could be many diff things. from throttle valve, to pump, to gas, to mis fire. the dealer will sort it out. its very common on our m3's
I thought about bring it in, but I thought the dealer would refuse to cover it since I have after market exhaust on my car, but if everything else fail, I would have no option but to swap on my stock exhaust and bring it in. I would love nothing more than to get this warning out of the way without going through all this trouble since I'd have to take my diffuser apart before removing my exhaust
col.faith is offline  
0
Reply With Quote
      03-14-2012, 05:11 PM   #8
ep99
Private First Class
 
Drives: 2013 X6M
Join Date: Aug 2009
Location: Markham

Posts: 158
iTrader: (0)

Wondering if the emission light warning had gone...

I have the same problem back in January...took it out in a really cold morning.
Booked a service appointment and have to wait for about a week...too busy they said.

But the emission light went away after 3 days...so i just cancelled the appointment.
ep99 is offline   Canada
0
Reply With Quote
      03-14-2012, 09:13 PM   #9
BMRLVR
Grease Monkey
 
BMRLVR's Avatar
 
Drives: 2011 E90 M3,1994 Euro E36 M3/4
Join Date: Apr 2006
Location: Fort McMurray, Alberta, Canada

Posts: 2,324
iTrader: (3)

Get an OBDII scan tool, read the code, write down the details and then clear it. If it stays off, don't worry about it, if it comes back, check and see if it is the same code.

If you can't get an OBDII scan tool you can also turn off the light by disconnecting the battery for about 30 seconds. When you disconnect the battery you will just reset the light and not erase the code from memory. This way if you bring it to the dealer later or scan it the code will still be there to aid in trouble shooting!
__________________
2011 E90 M3 ZCP - Individual Moonstone/Individual Amarone Extended/Individual Piano Black With Inlay:LINK!!!
1994 Euro E36 M3 Sedan - Daytona Violet/Mulberry:LINK!!!
BMRLVR is offline   Canada
0
Reply With Quote
      03-14-2012, 09:31 PM   #10
Jaypod
Brigadier General
 
Jaypod's Avatar
 
Drives: Frozen Silver M3, AM V8V
Join Date: Nov 2008
Location: Toronto

Posts: 4,934
iTrader: (7)

Quote:
Originally Posted by BMRLVR View Post
Get an OBDII scan tool, read the code, write down the details and then clear it. If it stays off, don't worry about it, if it comes back, check and see if it is the same code.

If you can't get an OBDII scan tool you can also turn off the light by disconnecting the battery for about 30 seconds. When you disconnect the battery you will just reset the light and not erase the code from memory. This way if you bring it to the dealer later or scan it the code will still be there to aid in trouble shooting!
Good advice! Noah if you need a hand scanning the code and clearing it let me know.
Jaypod is offline   No_Country
0
Reply With Quote
      03-15-2012, 09:28 AM   #11
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by ep99 View Post
Wondering if the emission light warning had gone...

I have the same problem back in January...took it out in a really cold morning.
Booked a service appointment and have to wait for about a week...too busy they said.

But the emission light went away after 3 days...so i just cancelled the appointment.
Thanks! This seems really similar to my situation. Do you recall what you did in those three days? Just drove it around? If so, for what distance? I've put about 10km on it as of this point, and the light is still on.
col.faith is offline  
0
Reply With Quote
      03-15-2012, 09:31 AM   #12
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by BMRLVR View Post
Get an OBDII scan tool, read the code, write down the details and then clear it. If it stays off, don't worry about it, if it comes back, check and see if it is the same code.

If you can't get an OBDII scan tool you can also turn off the light by disconnecting the battery for about 30 seconds. When you disconnect the battery you will just reset the light and not erase the code from memory. This way if you bring it to the dealer later or scan it the code will still be there to aid in trouble shooting!
Very sound advice indeed! Didn't know about the battery reset, appreciate it!
col.faith is offline  
0
Reply With Quote
      03-15-2012, 09:56 AM   #13
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by Jaypod View Post
Good advice! Noah if you need a hand scanning the code and clearing it let me know.
Thanks Jay! That's very comforting to hear =) You are best.
col.faith is offline  
0
Reply With Quote
      03-15-2012, 10:54 AM   #14
135IS
Captain
 
Drives: 09 LMB 135I / AW 1M
Join Date: Feb 2010
Location: t.o

Posts: 740
iTrader: (1)

Garage List
2009 135i  [3.50]
lol @ emission lights
__________________
LMB 135i: Gone
AW 1M: Current #211 of 220
135IS is offline   Canada
0
Reply With Quote
      03-23-2012, 09:23 PM   #15
M3-Mike
Second Lieutenant
 
M3-Mike's Avatar
 
Drives: 2008 M3 Coupe DCT
Join Date: Jan 2009
Location: Toronto

Posts: 265
iTrader: (0)

Message gone by now?
M3-Mike is offline   Canada
0
Reply With Quote
      03-23-2012, 10:40 PM   #16
youngvedder
Private First Class
 
Drives: 2008 e93 M3
Join Date: Jun 2011
Location: Burlington, ON

Posts: 131
iTrader: (1)

Quote:
Originally Posted by M3-Mike View Post
I wouldn't worry about it, I've seen this several times too and it usually goes away after a good blast down the highway.
same!
__________________
'08 e93 / H&R Springs/MS spacers rear 15/AFE intake/RPI Scoops/AKRA Evo/Rouge Pulleys/Apex Arc-8 265/285/Evolve-R (240e)
youngvedder is offline   Canada
0
Reply With Quote
      03-25-2012, 11:50 PM   #17
col.faith
Second Lieutenant
 
Drives: bmw e92 m3 edition AW
Join Date: Mar 2010
Location: toronto

Posts: 214
iTrader: (0)

Quote:
Originally Posted by M3-Mike View Post
Message gone by now?
Yessir! Thanks a lot, Mike.
col.faith is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:57 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST