BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
BPM
Post Reply
 
Thread Tools Search this Thread
      03-21-2017, 07:49 AM   #1
ard5040
Private First Class
19
Rep
185
Posts

Drives: '09 e90 M3
Join Date: Feb 2013
Location: Rockland, NY

iTrader: (1)

Lost Dashboard Info?

Heading to service this morning to diagnose loss of display yesterday. Started my '09 e90 with DCT yesterday. "P" appeared on display normally. Upper part of display showed all warning lights normally. Started driving and realized mileage, time, temp, and gear were not being displayed. Not sure what to expect in terms of codes. No check engine light. Anyone have any thoughts or similar experience?
Appreciate 0
      03-22-2017, 06:56 AM   #2
ard5040
Private First Class
19
Rep
185
Posts

Drives: '09 e90 M3
Join Date: Feb 2013
Location: Rockland, NY

iTrader: (1)

Subframe, I took the car to a BMW shop in NJ, ZNM Motors, they've been servicing my car(s) for 6 years. Matt, the owner believes its a quartz display lamp behind the dash, $15 dollar part, 5 min install. Said if the car had not started or started intermittently would have probably been DME. Didn't read any codes. Good luck.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:49 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST