BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
PYSPEED
Post Reply
 
Thread Tools Search this Thread
      02-04-2012, 09:58 PM   #1
Wongton
Second Lieutenant
 
Drives: M3
Join Date: Nov 2011
Location: Irvine, ca

Posts: 212
iTrader: (1)

Quick Question in regards to Engine Malfunction, reduced power

I bought an 08 E92 used with a couple mods on it:

-active autowerks ECU
-MXP exhaust

The computer just threw Engine malfunction, reduced power & increased emissions code at me.

my question is I don't have a stock ECU to swap it before bringing it to the dealer, and I don't want them to void my warranty or have it on file saying I have altered the ECU or whatever.

What do you think I should do? Ive read numerous treads about this problem but they all just brought it to dealers.

thanks guys
Wongton is offline  
0
Reply With Quote
      02-04-2012, 09:59 PM   #2
Wongton
Second Lieutenant
 
Drives: M3
Join Date: Nov 2011
Location: Irvine, ca

Posts: 212
iTrader: (1)

car was running great when I start it up. Doesn't idle weird or anything. I even let it warm up and when I get over like 30mph the damn code pops up and I end up driving at like half power
Wongton is offline  
0
Reply With Quote
      02-05-2012, 02:16 PM   #3
Wongton
Second Lieutenant
 
Drives: M3
Join Date: Nov 2011
Location: Irvine, ca

Posts: 212
iTrader: (1)

no input huh
Wongton is offline  
0
Reply With Quote
      02-05-2012, 02:53 PM   #4
GIdriver
Major
 
GIdriver's Avatar
 
Drives: 2011 SG/FR E90 M3 DCT
Join Date: Dec 2010
Location: Somewhere in Time

Posts: 1,338
iTrader: (0)

Not a lot of info in your posts (mileage when bought, mileage when this started to happen, etc.) but I suggest you contact Active for support.
__________________
Akrapovic Evolution with Carbon Fiber tips | ESS Akra Evo tune V2 | Dinan Pulley | iND Cosmetic Package (Color Matched Front Grilles/Reflectors/Side Gills) in Space Gray | LUX H8 Angel Eyes

GIdriver is offline   United_States
0
Reply With Quote
      02-05-2012, 02:58 PM   #5
persian54
Lieutenant General
 
persian54's Avatar
 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

Posts: 15,723
iTrader: (289)

Jeremey from OE can flash it back to stock (I doubt for free)

PC can as well (in Wes LA iirc)

And I'm sure AA can assist as well.
persian54 is online now   United_States
0
Reply With Quote
      02-06-2012, 11:43 AM   #6
Wongton
Second Lieutenant
 
Drives: M3
Join Date: Nov 2011
Location: Irvine, ca

Posts: 212
iTrader: (1)

Quote:
Originally Posted by persian54 View Post
Jeremey from OE can flash it back to stock (I doubt for free)

PC can as well (in Wes LA iirc)

And I'm sure AA can assist as well.
thanks for the suggestions guys. flashing it back to stock is like the last thing i want to do haha...
Wongton is offline  
0
Reply With Quote
      02-06-2012, 11:51 AM   #7
Nine
Banned
 
Drives: Not ZCP, FML.
Join Date: May 2010
Location: DC, Miami, NYC

Posts: 1,925
iTrader: (2)

You're lucky that hundred shot of NOS didn't blow the welds on the intake! You almost had me?
Nine is offline  
0
Reply With Quote
      02-06-2012, 11:54 AM   #8
italyix
Lieutenant
 
italyix's Avatar
 
Drives: '08 E90 M3
Join Date: Dec 2011
Location: Bay Area

Posts: 494
iTrader: (1)

Quote:
Originally Posted by Nine View Post
You're lucky that hundred shot of NOS didn't blow the welds on the intake! You almost had me?


All jokes aside, what are the symptoms? Meaning does it sound different, drives weird?

Mine threw that code from a misfire...turns out one of the valve springs was cracked.
italyix is offline   United_States
0
Reply With Quote
      02-06-2012, 11:58 AM   #9
persian54
Lieutenant General
 
persian54's Avatar
 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

Posts: 15,723
iTrader: (289)

Quote:
Originally Posted by Wongton View Post
thanks for the suggestions guys. flashing it back to stock is like the last thing i want to do haha...
Why is it the last thing you want to do...?
persian54 is online now   United_States
0
Reply With Quote
      02-07-2012, 03:37 AM   #10
Wongton
Second Lieutenant
 
Drives: M3
Join Date: Nov 2011
Location: Irvine, ca

Posts: 212
iTrader: (1)

its weird i turned the car on today and the cel went away. Drove throughout the day without any problems.

is it common that the computer and the sensors are easily triggered sometimes, causing the cel to come up?
Wongton is offline  
0
Reply With Quote
      02-07-2012, 04:16 PM   #11
nineonenine
Second Lieutenant
 
Drives: M3
Join Date: Jun 2011
Location: USA

Posts: 214
iTrader: (0)

is it the common idle valve issue in the 08s? mine had it.. same symptoms
nineonenine is offline  
0
Reply With Quote
      02-08-2012, 01:34 AM   #12
Wongton
Second Lieutenant
 
Drives: M3
Join Date: Nov 2011
Location: Irvine, ca

Posts: 212
iTrader: (1)

Quote:
Originally Posted by szk View Post
is it the common idle valve issue in the 08s? mine had it.. same symptoms
I'm not sure actually. the CEL went away. should i still have it looked at
Wongton is offline  
0
Reply With Quote
      02-08-2012, 10:30 AM   #13
boostedM
First Lieutenant
 
boostedM's Avatar
 
Drives: Active Stage II E92 M3
Join Date: Feb 2012
Location: Daytona Beach, FL

Posts: 331
iTrader: (1)

I threw codes before I had my cats removed. My dealer was cool about everything and upheld my warranty. It just depends on the dealer. I mean I have EXTENSIVE mods, and they said it was fine.
__________________


Instagram: @mitchellbanks
boostedM is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:11 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST