BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Post Reply
 
Thread Tools Search this Thread
      01-20-2012, 03:24 PM   #1
smihalik
Private
2

 
Drives: 2008 e92 ///M3 DCT
Join Date: Jun 2009
Location: Montreal


Posts: 78
iTrader: (1)

Clock and trip computer keep resetting.

Is this a problem anyone else has? For the last month or so, when I get in my car most mornings, my computer(trip, fuel economy, av speed) has reset and the clock displays --:--:--.

Could this have anything to do with the fact it has been really cold lately? -15c?
Appreciate 0
      01-20-2012, 03:28 PM   #2
kscarrol
Colonel
United_States
33

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA


Posts: 2,267
iTrader: (0)

Sounds like the battery is bad. Could be from the cold, age or simply not driving enough. I see your car is an '08. Is it the original battery? If so, roughly four years is getting old for a car battery...
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-20-2012, 03:36 PM   #3
smihalik
Private
2

 
Drives: 2008 e92 ///M3 DCT
Join Date: Jun 2009
Location: Montreal


Posts: 78
iTrader: (1)

Quote:
Originally Posted by kscarrol View Post
Sounds like the battery is bad. Could be from the cold, age or simply not driving enough. I see your car is an '08. Is it the original battery? If so, roughly four years is getting old for a car battery...
Battery can't be dead. It starts up like a champ in -20 weather.

Not sure if its the original. I bought it CPO about 4 months ago. I think I'll just ring up the dealer. I thought maybe it was a common problem.
Appreciate 0
      01-20-2012, 03:42 PM   #4
THE TECH
BimmerPost Supporting Vendor
United_States
156


 
THE TECH's Avatar
 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas


Posts: 13,116
iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Check the battery. Just cause it starts, doesn't mean it's in perfectly good health.
__________________
Appreciate 0
      01-20-2012, 03:54 PM   #5
kscarrol
Colonel
United_States
33

 
Drives: 2011 E90 M3
Join Date: Jun 2010
Location: New Orleans, LA


Posts: 2,267
iTrader: (0)

Quote:
Originally Posted by smihalik View Post
Battery can't be dead. It starts up like a champ in -20 weather.

Not sure if its the original. I bought it CPO about 4 months ago. I think I'll just ring up the dealer. I thought maybe it was a common problem.
Didn't say it was dead! And it is a common problem (assuming it is the battery!) Had this issue on my '08 550 and I know from my days on E60.net that many 5 series folks had this problem.

Low charge in the battery and the car will start shutting down various systems to conserve power. The exact symptoms you describe are what happened to me, clock/computer resetting. If the battery is old it may hold enough charge to start the car but not enough to keep these systems running in the background.
__________________
Current: 2011 Space Grey E90 M3, DCT, Comp. Pkg., Conv. Pkg., everything but Cold Weather Pkg!
Gone: 2008 550, Space Grey, Sports Package, Sport Auto Transmission.
Sold: 2004 545i (U.S.), Steptronic, Silver Gray.
Appreciate 0
      01-20-2012, 05:16 PM   #6
smihalik
Private
2

 
Drives: 2008 e92 ///M3 DCT
Join Date: Jun 2009
Location: Montreal


Posts: 78
iTrader: (1)

Quote:
Originally Posted by kscarrol View Post
Didn't say it was dead! And it is a common problem (assuming it is the battery!) Had this issue on my '08 550 and I know from my days on E60.net that many 5 series folks had this problem.

Low charge in the battery and the car will start shutting down various systems to conserve power. The exact symptoms you describe are what happened to me, clock/computer resetting. If the battery is old it may hold enough charge to start the car but not enough to keep these systems running in the background.
Thanks! Looks like I'm getting myself a new battery.
Appreciate 0
      01-22-2012, 02:11 AM   #7
Maseroche
Major
Bahrain
15

 
Maseroche's Avatar
 
Drives: '08 BMW M3
Join Date: Sep 2009
Location: Bahrain


Posts: 1,402
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
happened to me last year and after changing the battery, all is well.
__________________
Khalid
'08 BMW M3


Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:33 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST