BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      01-30-2012, 02:23 PM   #45
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Not sure if you had read above, but I also tried using the Self-diagnosis tool on BMW Connected app and I get an error every time that it cannot communicate with the vehicle.

Gonna do the restore now and see if that changes anything. What are you thinking the restore will do?
__________________
Appreciate 0
      01-30-2012, 02:36 PM   #46
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by THE TECH View Post
Yes, it is an AT&T version. Since the cradle will charge the phone, at some point the phone will be at 100% charge.

I will try restoring the phone to see if that makes any difference.
That's the problem... somehow either the cradle is not charging enough to keep the iPhone connected or the iPhone charging itself is defective. There's a voltage level threashold for USB iPhone connection, anything below that level will disconnect.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-30-2012, 02:38 PM   #47
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Technic View Post
That's the problem... somehow either the cradle is not charging enough to keep the iPhone connected or the iPhone charging itself is defective. There's a voltage level threashold for USB iPhone connection, anything below that level will disconnect.
Well, the cradle has already been replaced and I have the same issue so I would think we could rule the cradle itself out right?
__________________
Appreciate 0
      01-30-2012, 02:44 PM   #48
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by THE TECH View Post
Well, the cradle has already been replaced and I have the same issue so I would think we could rule the cradle itself out right?
It could be the baseplate or anything related to charging connections. Or as simple as a malfunctioning Combox, but that is unlikely.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-30-2012, 03:12 PM   #49
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Did the Restore and charged to 100%...still doesn't work.
__________________
Appreciate 0
      01-30-2012, 03:22 PM   #50
apw2607
Major
44
Rep
1,428
Posts

 
Drives: 2009 X5 35d
Join Date: Apr 2006
Location: Seattle, WA, USA

iTrader: (0)

Quote:
Originally Posted by Technic View Post
Is your iPhone from AT&T?

If so try either:

- plug your iPhone while it is 100% charged
- restore completely your iPhone via iTunes.
- another iPhone

I have seen this issue with AT&T iPhones and the Combox while using the baseplate USB port via the cradle. It is a current draw issue that forces the iPhone to connect/disconnect.

There should not be any problem with the standard USB port. If so then most probably the Combox is acting up.
I've seen this problem before also on non At&t phones. It ended up being the combox. Bmw have to raise a puma and get permission to change the thing. Its a right fiasco.
Appreciate 0
      01-30-2012, 03:27 PM   #51
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Anything else I can personally check before escalating it to the dealer?
__________________
Appreciate 0
      01-30-2012, 03:29 PM   #52
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by THE TECH View Post
Did the Restore and charged to 100%...still doesn't work.
Regardless of the USB port used? If so then it is dealer time, unfortunately.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-30-2012, 03:32 PM   #53
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Technic View Post
Regardless of the USB port used? If so then it is dealer time, unfortunately.
The USB port has worked perfectly with no issues. The cradle is the only issue.
__________________
Appreciate 0
      01-30-2012, 03:56 PM   #54
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by THE TECH View Post
The USB port has worked perfectly with no issues. The cradle is the only issue.
The only way for you to test if in fact the Combox or the cradle/baseplate/cable are malfunctioning is to swap the LVDS cables at the Combox itself.

The black socket cable goes directly to the USB port; the blue socket cable goes directly to the baseplate. The difference between the blue and the black sockets is that the Blue enables video.

Swapping the cables -the USB port will be connected to the baseplate USB port and viceversa- can tell you if any of the cables from the Combox to the ports are defective, if the cradle is defective or again the Combox blue port is defective and therefore the Combox is defective.

For example, if after swapping the cables at the Combox suddenly the cradle works fine but the USB port becomes defective then the blue connector output is defective.

The problem of swapping the cables is that the LVDS cable connector housings themselves are indexed differently. You could shave the plastic tabs and make them universal however that would void your Combox warranty if found out.

That's the reason that I have an universal interface LVDS cable for testing so I can swap this type of cable without permanent modifications.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-30-2012, 04:01 PM   #55
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Technic View Post
The only way for you to test if in fact the Combox or the cradle/baseplate/cable are malfunctioning is to swap the LVDS cables at the Combox itself.

The black socket cable goes directly to the USB port; the blue socket cable goes directly to the baseplate. The difference between the blue and the black sockets is that the Blue enables video.

Swapping the cables -the USB port will be connected to the baseplate USB port and viceversa- can tell you if any of the cables from the Combox to the ports are defective, if the cradle is defective or again the Combox blue port is defective and therefore the Combox is defective.

For example, if after swapping the cables at the Combox suddenly the cradle works fine but the USB port becomes defective then the blue connector output is defective.

The problem of swapping the cables is that the LVDS cable connector housings themselves are indexed differently. You could shave the plastic tabs and make them universal however that would void your Combox warranty if found out.

That's the reason that I have an universal interface LVDS cable for testing so I can swap this type of cable without permanent modifications.
So really, there is no way for me to check the connections without modifying the connector housings? How much is the universal cable?
__________________
Appreciate 0
      01-30-2012, 04:08 PM   #56
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by THE TECH View Post
So really, there is no way for me to check the connections without modifying the connector housings? How much is the universal cable?
The universal cable was made to order and I do not have any more of them, sorry.

Just go to the dealer, most probably they are going to perform the same test but by swapping a Combox.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-30-2012, 04:56 PM   #57
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Technic View Post
The universal cable was made to order and I do not have any more of them, sorry.

Just go to the dealer, most probably they are going to perform the same test but by swapping a Combox.
Yeah I checked the cables. They definitely won't swap without some "massaging".
__________________
Appreciate 0
      01-30-2012, 05:21 PM   #58
SamS
Brigadier General
SamS's Avatar
61
Rep
4,574
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Quote:
Originally Posted by Technic View Post
That's the reason that I have an universal interface LVDS cable for testing so I can swap this type of cable without permanent modifications.
Is this piece of hardware all that is needed to get cradle functionality out of the USB port + 30 pin cable?
Appreciate 0
      01-30-2012, 05:39 PM   #59
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by SamS View Post
Is this piece of hardware all that is needed to get cradle functionality out of the USB port + 30 pin cable?
No, I use this custom cable for testing so I do not have to permanently modify the OEM cables.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-30-2012, 05:42 PM   #60
SamS
Brigadier General
SamS's Avatar
61
Rep
4,574
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Quote:
Originally Posted by Technic View Post
No, I use this custom cable for testing so I do not have to permanently modify the OEM cables.
So, the ability to enable cradle functionality out of the USB port is just coding?
Appreciate 0
      01-30-2012, 06:00 PM   #61
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by SamS View Post
So, the ability to enable cradle functionality out of the USB port is just coding?
There are two separate USB ports -the actual USB port and the cradle USB port- with two major differences: the cradle/baseplate USB has also video hardware support and because of that then it requires more current draw than the current provided by the actual USB port. Thus the baseplate supplies its own power supply to the phone independenly from the Combox.

The coding and hardware is done if you got the 6NR from factory.

You just need to give BMW some $200 for the cradle if you want that video and heavier duty charging support.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone

Last edited by Technic; 01-31-2012 at 01:06 PM.
Appreciate 0
      01-31-2012, 11:37 AM   #62
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
No way to check the connections via DVM? You have any interest in letting me use that cable you have if I pay shipping both ways?
__________________
Appreciate 0
      01-31-2012, 01:07 PM   #63
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,182
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by THE TECH View Post
No way to check the connections via DVM? You have any interest in letting me use that cable you have if I pay shipping both ways?
Sorry, I do not lend any of my tools as I use them all the time in customer cars...
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      01-31-2012, 01:11 PM   #64
SamS
Brigadier General
SamS's Avatar
61
Rep
4,574
Posts

 
Drives: 2013 ActiveHybrid 3
Join Date: Jul 2010
Location: Dallas, TX

iTrader: (0)

Quote:
Originally Posted by Technic View Post
There are two separate USB ports -the actual USB port and the cradle USB port- with two major differences: the cradle/baseplate USB has also video hardware support and because of that then it requires more current draw than the current provided by the actual USB port. Thus the baseplate supplies its own power supply to the phone independenly from the Combox.

The coding and hardware is done if you got the 6NR from factory.

You just need to give BMW some $200 for the cradle if you want that video and heavier duty charging support.
Thank you for the explanation. I do have the cradle and 6NR. Fortunately, everything works OK for my car.
Appreciate 0
      01-31-2012, 02:10 PM   #65
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
157
Rep
13,122
Posts


 
Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Quote:
Originally Posted by Technic View Post
Sorry, I do not lend any of my tools as I use them all the time in customer cars...
Understood. Thanks anyway.
__________________
Appreciate 0
      02-29-2012, 06:25 PM   #66
drew313
Enlisted Member
drew313's Avatar
United_States
0
Rep
34
Posts

 
Drives: 12 E92 M3, 12 X5 3.5i, 09 S2k
Join Date: Aug 2008
Location: Irvine, CA

iTrader: (0)

Garage List
Did you ever get this problem resolved?

I am also having problems trying to get the cradle to work on my car. I've updated the software using the center console USB port and I'm using an iPhone 4S with latest iOS. The center console USB port works perfectly with the Apple cable. I can get Pandora and BMW Apps working just fine.

I've tried 5 different media cradles at my dealer and it looks like there are at least two hardware versions of the cradle (v2.0 and v3.0).

Cradle #1: Hardware v2.0 (4/11). Does not charge the phone and ConnectedDrive does not detect the phone. BMW Apps diagnostic says connection failed.

Cradle #2: Hardware v2.0 (5/11). Charges the phone but ConnectedDrive does not detect the phone. BMW Apps diagnostic says connection failed.

Cradle #3: Hardware v2.0 (7/11). Charges the phone and ConnectedDrive Plugin sees the phone and I get the nice iPod out screen. I can navigate through my music but there is no audio at all. No audio with the Pandora app nor BMW Web Radio. I also deleted the Bluetooth pairing but that didn't make a difference.

Cradle #4 and #5: These were ordered by the dealer so I think they would be the latest. Hardware v3.0 (8/11). Same behavior as #3.

The dealer says they've never seen this problem before but at least they were nice enough to let me try out several cradles. Could it be a compatibility issue with the 2012 models?

Last edited by drew313; 02-29-2012 at 06:32 PM.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:18 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST