BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Wash, Wax, Detail, Cosmetic Maintenance & Repairs
 
Alpine HID
Post Reply
 
Thread Tools Search this Thread
      11-08-2011, 11:16 PM   #23
Ateam
Banned
 
Drives: M3
Join Date: Sep 2011
Location: USA

Posts: 1,109
iTrader: (0)

dude you NEED to get some new pads! You actually did a ridiculously great job if this was your first one and this was done with that crap white pad the PC comes with! Go to detailedimage and get some lake country foam white's and then some blacks to put on sealants and that will really work well but amazing job!
Ateam is offline  
0
Reply With Quote
      11-09-2011, 08:53 AM   #24
Templar
Lieutenant Colonel
 
Templar's Avatar
 
Drives: 2011 E92 M3
Join Date: Feb 2009
Location: NC

Posts: 1,810
iTrader: (1)

Garage List
2011 BMW M3  [5.00]
Quote:
Originally Posted by Ateam View Post
dude you NEED to get some new pads! You actually did a ridiculously great job if this was your first one and this was done with that crap white pad the PC comes with! Go to detailedimage and get some lake country foam white's and then some blacks to put on sealants and that will really work well but amazing job!
I actually didn't use the crappy white pad on the paint, just on the glass. It worked fine on the glass. I have a ton of pads from detailedimage that I used on the paint

As for the water spots, I never get them with a garden hose from washing, mostly because I dry the car quickly after I rinse it. These spots came from the car sitting in the sun and being hit with the sprinkler system in my old apartment complex. I couldn't really do anything about it. I honestly don't think a water softening system is necessary if you wash, rinse, and QUICKLY dry the car. The water doesn't have the chance to dry on the vehicle and etch like it appeared to do to mine.
__________________
'11 BMW E92 ///M3 - ZCP and DCT
'13 Toyota Tundra - 4x4 Platinum CrewMax, 5.7l iForce V8
Templar is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:18 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST