BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
EXXEL Distributions
Post Reply
 
Thread Tools Search this Thread
      09-08-2011, 03:25 PM   #1
Eurotrash8
Captain
Eurotrash8's Avatar
Hong Kong
20
Rep
623
Posts

Drives: 2008 E92 M3
Join Date: Sep 2007
Location: Calgary, Alberta

iTrader: (4)

Suspension clicking / binding?

Couldnt find anything from the search.

I am lowered on H&R springs with EDC.

Recently I started to get a clicking noise when driving straight hitting very very light bumps but mainly when in rush hour stop and go traffic while in first gear.

The sound is a clicking when getting on and off the throttle in first gear going 10-30km ish.

Almost feels as though its a loose front end but only on the right side.

Could there be some sort of binding for improper tightening of something?

Anyone else experience something like this? I thought I remember seeing something about suspension binding from tightening something or another too tight.

Thx
__________________
Appreciate 0
      09-14-2011, 12:53 AM   #2
HP Autosport
General
United_States
1036
Rep
18,499
Posts

Drives: F80 M3
Join Date: Mar 2007
Location: Santa Barbara, Brembo, GIAC, Koni, Ohlins, Performance Friction, Quaife, Stoptech, Vorshlag

iTrader: (33)

Quote:
Originally Posted by Eurotrash8 View Post
Couldnt find anything from the search.

I am lowered on H&R springs with EDC.

Recently I started to get a clicking noise when driving straight hitting very very light bumps but mainly when in rush hour stop and go traffic while in first gear.

The sound is a clicking when getting on and off the throttle in first gear going 10-30km ish.

Almost feels as though its a loose front end but only on the right side.

Could there be some sort of binding for improper tightening of something?

Anyone else experience something like this? I thought I remember seeing something about suspension binding from tightening something or another too tight.

Thx
Have a look at the anti roll bar endlink nuts, make sure those are propertly toruqed and put some loctite on them.
Appreciate 0
      09-16-2011, 01:48 AM   #3
Eurotrash8
Captain
Eurotrash8's Avatar
Hong Kong
20
Rep
623
Posts

Drives: 2008 E92 M3
Join Date: Sep 2007
Location: Calgary, Alberta

iTrader: (4)

Quote:
Originally Posted by HP Autowerks View Post
Have a look at the anti roll bar endlink nuts, make sure those are propertly toruqed and put some loctite on them.
Ok Thanks.

Is this something that you have run into in the past?

I refuse to take it to the dealer because I know how that conversation is going to go.

"Oh you have H&R springs? Well go F*@ck yourself...no warranty!
__________________
Appreciate 0
      09-16-2011, 10:20 AM   #4
Cyrax91
YNWA
Cyrax91's Avatar
United_States
61
Rep
1,610
Posts

Drives: Dakar M3 - MCB X5M - Evo IX MR
Join Date: Oct 2008
Location: NM

iTrader: (18)

Ya I wouldnt ask the dealer either. I had this problem with my Evo and it was actually a brake line that somehow was clinking against the rear suspension bar. Weird I know, but it was after repainting the calipers so I had an idea it was something with that. Good luck with it.
__________________
e70 Monte Carlo Blue X5M - e92 Dakar Yellow M3 Competition Package - Evo IX MR
Appreciate 0
      02-05-2012, 01:18 AM   #5
erm324
Major
United_States
52
Rep
1,188
Posts

Drives: F10 M5
Join Date: Oct 2009
Location: NYC

iTrader: (1)

I am actually experiencing this same exact problem now and I am lowered on Eibach springs with EDC, did you ever figure out the problem?
Appreciate 0
      02-05-2012, 12:21 PM   #6
M3SQRD
Colonel
M3SQRD's Avatar
United_States
43
Rep
2,585
Posts

Drives: E92 M3,R56 S,F22 228iX,F82 M4
Join Date: Jun 2009
Location: EC

iTrader: (2)

Quote:
Originally Posted by HP Autowerks View Post
Have a look at the anti roll bar endlink nuts, make sure those are propertly toruqed and put some loctite on them.
+1 - this is most likely the cause.

I'd also check to see if the strut mount nuts are still tight as well as the bolts/nuts that attach the strut tower brace at both ends (strut mount and chassis/firewall).
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:30 PM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST