BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > BIMMERPOST Universal Forums > Site Related Announcements - Suggestions - Feedback - Questions
 
Bimmerworld
Post Reply
 
Thread Tools Search this Thread
      09-08-2015, 12:26 PM   #1
Mark
Administrator
Mark's Avatar
United_States
3493
Rep
4,095
Posts

Drives: 1M
Join Date: Mar 2005
Location: USA

iTrader: (1)

Garage List
BIMMERPOST 4.0 Android Bugs/Suggestions Thread

Name:  Lollipop Forest-1200-80.jpg
Views: 613
Size:  104.7 KB

BIMMERPOST 4.0 (the it just works edition) for Android is now available on the Google Play Store!

Please use this thread to post bug reports, suggestions, etc...

Thank you!!
__________________
Appreciate 0
      09-08-2015, 04:03 PM   #2
warp10
Major
warp10's Avatar
52
Rep
1,011
Posts

Drives: 2011 M3 Jet Black:ZCP, ZCV, ZP
Join Date: May 2011
Location: Atlanta, Ga

iTrader: (4)

Garage List
2011 M3  [5.00]
2011 28i X3  [0.00]
Can't log in. Password can be entered but not username
Appreciate 1
      09-08-2015, 04:38 PM   #3
StevenY.
///M
StevenY.'s Avatar
United_States
98
Rep
2,084
Posts

Drives: 10' SG e92 335i
Join Date: Aug 2012
Location: NYC

iTrader: (1)

Just updated, stayed logged in after updating and works fine for the few minutes I used it. Thing that sucks is that "my forums" was cleared just like previous versions.
__________________
Appreciate 1
      09-08-2015, 04:57 PM   #4
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by warp10
Can't log in. Password can be entered but not username
Let me try to fix it for you. Could you tell me what happens when you try to click on username area or take a screenshot of what happens so I can better understand. Good thing about android is that I can have an update out to you in just a few hours
__________________
This is my signature yay
Appreciate 0
      09-08-2015, 04:58 PM   #5
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by StevenY.
Just updated, stayed logged in after updating and works fine for the few minutes I used it. Thing that sucks is that "my forums" was cleared just like previous versions.
Great to hear. Let me know if you run into problems. We changed the architecture of the app a lot. With the next update we will have it so that the my forums won't clear anymore
__________________
This is my signature yay
Appreciate 0
      09-08-2015, 06:11 PM   #6
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
For those who have the new version, ate push notifications working ?
__________________
This is my signature yay
Appreciate 0
      09-08-2015, 07:32 PM   #7
StevenY.
///M
StevenY.'s Avatar
United_States
98
Rep
2,084
Posts

Drives: 10' SG e92 335i
Join Date: Aug 2012
Location: NYC

iTrader: (1)

Quote:
Originally Posted by apptest
For those who have the new version, ate push notifications working ?
Don't recall seeing the notification when you quoted my post. Also just found out that the back button no longer works.
__________________
Appreciate 1
      09-08-2015, 07:33 PM   #8
HELLOimJ
Addicted to Speed.
HELLOimJ's Avatar
United_States
221
Rep
1,502
Posts

Drives: 13 328xi, 15 m4
Join Date: Aug 2011
Location: 'Murica

iTrader: (4)

I can't log in same issue as above
Appreciate 1
      09-08-2015, 07:41 PM   #9
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by StevenY.
Quote:
Originally Posted by apptest
For those who have the new version, ate push notifications working ?
Don't recall seeing the notification when you quoted my post. Also just found out that the back button no longer works.
Yea back button won't work on this version. Didn't have time to work on that as I wanted to get the critical parts out the door. Will work on push next then after that back button
__________________
This is my signature yay
Appreciate 0
      09-08-2015, 07:42 PM   #10
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by jawwadh
I can't log in same issue as above
Thanks. I think I found the bug on android 5.x. Working on a fix now which should be out later today
__________________
This is my signature yay
Appreciate 0
      09-08-2015, 08:41 PM   #11
warp10
Major
warp10's Avatar
52
Rep
1,011
Posts

Drives: 2011 M3 Jet Black:ZCP, ZCV, ZP
Join Date: May 2011
Location: Atlanta, Ga

iTrader: (4)

Garage List
2011 M3  [5.00]
2011 28i X3  [0.00]
Quote:
Originally Posted by apptest View Post
Let me try to fix it for you. Could you tell me what happens when you try to click on username area or take a screenshot of what happens so I can better understand. Good thing about android is that I can have an update out to you in just a few hours
I click on user name and the keyboard pops up but username doesn't go away as I type like password field does.
Appreciate 1
      09-08-2015, 08:43 PM   #12
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by warp10
Quote:
Originally Posted by apptest View Post
Let me try to fix it for you. Could you tell me what happens when you try to click on username area or take a screenshot of what happens so I can better understand. Good thing about android is that I can have an update out to you in just a few hours
I click on user name and the keyboard pops up but username doesn't go away as I type like password field does.
Thanks. The fix is just submitted a few mins ago. It should be in the Google play market shortly

Thanks !
__________________
This is my signature yay
Appreciate 0
      09-09-2015, 12:30 AM   #13
warp10
Major
warp10's Avatar
52
Rep
1,011
Posts

Drives: 2011 M3 Jet Black:ZCP, ZCV, ZP
Join Date: May 2011
Location: Atlanta, Ga

iTrader: (4)

Garage List
2011 M3  [5.00]
2011 28i X3  [0.00]
works now thanks
__________________

2011 E92 M3 Coupe Jet Black ZCP: Piper Cross Filter, AA Race X-Pipe, BW Race Exhaust, Evolve Stage 2 Tune w/ Servo and DCT, CF Spoiler, and GT4 Front Splitter, APR GT-250, Stoptech ST-60, MCS 2 Ways, Apex ARC-8, Sparco Ergo Seats, Alekshop: Cage, Subframe and Diff mounts, Oil Cooler, CSF Radiator and Power Steering Cooler
Appreciate 0
      09-09-2015, 05:30 PM   #14
Conti.
Lieutenant
Conti.'s Avatar
United_States
25
Rep
460
Posts

Drives: 09' LMB e90 335i
Join Date: Aug 2013
Location: CT

iTrader: (0)

Garage List
2009 BMW 335i  [4.67]
The "share this thread" feature would be nice if it worked. Never has worked since I got my galaxy s5 back when it came out.
Appreciate 0
      09-09-2015, 11:50 PM   #15
evanescent03
Major
evanescent03's Avatar
240
Rep
1,190
Posts

Drives: aw F80
Join Date: Dec 2010
Location: USA

iTrader: (2)

screen shots from my crash reports
__________________
Appreciate 1
      09-10-2015, 09:33 AM   #16
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by evanescent03
screen shots from my crash reports
Thanks ! That was helpful. Working on this bug now for the next release hopefully over this weekend on possibly later this week
__________________
This is my signature yay
Appreciate 1
      09-11-2015, 12:31 PM   #17
stevexyz
Private First Class
United_States
26
Rep
162
Posts

Drives: 2016 M4 Convertible
Join Date: May 2015
Location: Bay Area, California

iTrader: (0)

Garage List
Thanks for the new version of the app. I noticed an interesting combination of improvements and regressions. Here are my thoughts so far.

Improvements:
  • Prior to 4.0, the user info above the main menu (News, Forums, etc.) always read "logged out", even when I was logged in. Now, it appears to work correctly.
  • Prior to 4.0, I was not able to press the "Appreciate" button. Now, it appears to work correctly.
  • Prior to 4.0, when long pressing a thread, it would take to the top of the PAGE with the first unread post. Now, it takes me to the page AND scrolls to the first unread post -- a huge improvement!
  • Prior to 4.0, pressing emoticons while composing a message had no effect. Now, it appears to insert the code correctly.
  • The "refresh" buttons are gone and now uses "pull down to refresh" instead.

Regressions:
  • When visiting areas such as My Forums, Subscriptions, etc., they don't appear to update automatically. I have to pull down to get the thread view to refresh. Prior to 4.0, they updated automatically when selected.
  • Since 4.0, the "single click goes to last read post" option does not appear to work. Single tap always takes me to page 1, even if the option is selected.
  • I know you're already aware, but for completeness -- the system Back button does not work.
If we can address the regressions and keep the improvements, we'll be in great shape!
__________________
2016 M4 Convertible: Tanzanite Blue, 6MT delivered 9/2/2015
Appreciate 1
      09-11-2015, 08:17 PM   #18
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by stevexyz
Thanks for the new version of the app. I noticed an interesting combination of improvements and regressions. Here are my thoughts so far.

Improvements:
  • Prior to 4.0, the user info above the main menu (News, Forums, etc.) always read "logged out", even when I was logged in. Now, it appears to work correctly.
  • Prior to 4.0, I was not able to press the "Appreciate" button. Now, it appears to work correctly.
  • Prior to 4.0, when long pressing a thread, it would take to the top of the PAGE with the first unread post. Now, it takes me to the page AND scrolls to the first unread post -- a huge improvement!
  • Prior to 4.0, pressing emoticons while composing a message had no effect. Now, it appears to insert the code correctly.
  • The "refresh" buttons are gone and now uses "pull down to refresh" instead.

Regressions:
  • When visiting areas such as My Forums, Subscriptions, etc., they don't appear to update automatically. I have to pull down to get the thread view to refresh. Prior to 4.0, they updated automatically when selected.
  • Since 4.0, the "single click goes to last read post" option does not appear to work. Single tap always takes me to page 1, even if the option is selected.
  • I know you're already aware, but for completeness -- the system Back button does not work.
If we can address the regressions and keep the improvements, we'll be in great shape!
I have to say. Very accurate list!

The reason for the seemingly nonsensical mix of advances and regressions is that we decided to rewrite the base code all over to match the iOS version of the app. So something's went forward to match ios while other things seem to have gone back as they were not part of ios (such as back button).

But we are right now working on the next release to bring those other things forward (for example back button and push notifications are all ready for the next version)

We are also going to start working on some of the other regressions you mentioned. For example the single click not going to last read post, which I think only happens when launching from the subscriptions area (but works when launching from forums area)

As always please feel free to post up any other bugs you find it if you have suggestions. The beauty of android is that I can adress them quickly and get them out to the App Store fast. For example I will get this next version into the store either tonight or tommorow night
__________________
This is my signature yay
Appreciate 1
      09-12-2015, 01:10 PM   #19
stevexyz
Private First Class
United_States
26
Rep
162
Posts

Drives: 2016 M4 Convertible
Join Date: May 2015
Location: Bay Area, California

iTrader: (0)

Garage List
Hey apptest it appears your PM mailbox is full.
__________________
2016 M4 Convertible: Tanzanite Blue, 6MT delivered 9/2/2015
Appreciate 0
      09-12-2015, 01:10 PM   #20
apptest
apptesting all night
apptest's Avatar
Wales
559
Rep
16
Posts

Drives: BMW M3
Join Date: Aug 2010
Location: New Jersey

iTrader: (0)

Garage List
2002 BMW M3  [0.00]
Quote:
Originally Posted by stevexyz
Hey apptest it appears your PM mailbox is full.
Thanks ! Fixed
__________________
This is my signature yay
Appreciate 0
      09-13-2015, 12:34 PM   #21
stevexyz
Private First Class
United_States
26
Rep
162
Posts

Drives: 2016 M4 Convertible
Join Date: May 2015
Location: Bay Area, California

iTrader: (0)

Garage List
Tried version 4.1 since yesterday. Big improvement!

I noticed the following regressions seem fixed:
  • Back button works now!
  • Single click goes to first unread post option works!
  • Refreshing the main views for Subscriptions, etc., seems to work better now. Still not entirely clear when it refreshes and when it doesn't.
Push notifications also seem to work, at least for News and PMs!

Here are some suggestions for improvement:
  • Tapping the notification for a PM should start the activity for the specific PM. Currently it just opens the main app window (News).
  • When creating a post or PM, tapping the body area once brings up the keyboard. However if I tap the title first, it does not bring up the keyboard. I have to tap the title a second time to get the keyboard to appear.
  • Great to see that Mentions work! Not sure if that was there before. It is a little difficult to use because the mention window obscures the text I'm typing. It is usable, just could be improved a little.
  • My own username (in the upper left corner when the top level app drawer is visible) still sometimes reverts to "Logged Out" even when I'm not logged out. Not sure what triggers this.
  • The login mechanism could be improved. AFAICT the way to log in is to hit Enter from the password field. A button or something would make this clearer.
But overall, this is a huge improvement from the pre-4.0 application!
__________________
2016 M4 Convertible: Tanzanite Blue, 6MT delivered 9/2/2015
Appreciate 0
      09-13-2015, 06:34 PM   #22
claykin
Colonel
United_States
54
Rep
2,054
Posts

Drives: 2014 335i M-Sport
Join Date: Nov 2009
Location: Florida

iTrader: (0)

just installed 4.2. When clicking on an image, it opens but the zoom +/- is no longer an option. Pinch zoom doesn't work either.
__________________
2014 335i MSport AW
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:10 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST