BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      08-09-2011, 01:06 PM   #1
Scrappy
1
Private First Class
 
Drives: E92 M3
Join Date: Oct 2010
Location: Jacksonville, FL

Posts: 166
iTrader: (0)

Loss of treble??

Ok guys as I am driving I suddenly lost my treble or maybe my speakers but the bass is still there? It not only does it with the radio but CD and phone as well? It is intermittent. I am thinking maybe the amp is going but not sure what do you guys think? It is all stock EPS.
Scrappy is offline  
Appreciate 0
Reply With Quote
      08-10-2011, 01:29 PM   #2
DavidZ
2
Second Lieutenant
 
DavidZ's Avatar
 
Drives: '11.5 E90 M3
Join Date: Apr 2011
Location: Maryland USA

Posts: 228
iTrader: (0)

I'd listen to each speaker to see if there's any treble. If none have any, it'd be very strange if your blew all 7 tweeters. Could be the amp or headunit. Time for dealer.
__________________
'11.5 M3 sedan | Jerez Black Metallic | 6MT | M Performance Exhaust | no DCT no EDC no NAV no nonsense
DavidZ is offline  
Appreciate 0
Reply With Quote
      08-10-2011, 02:02 PM   #3
elp_jc
49
Brigadier General
 
Drives: .
Join Date: May 2008
Location: .

Posts: 4,910
iTrader: (0)

Sounds like a head unit issue to me. That happens sometimes with radio, due to reception, but if it's happening with a CD, USB, etc., it has to be the head unit. Amplifier, as its name implies, only amplifies the signals. Finally, remember EPS has a separate equalizer; did you check it? Could have been reset by a gremlin . Good luck.
elp_jc is offline   United_States
Appreciate 0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:44 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST