BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      07-29-2011, 09:07 AM   #1
nockie
Enlisted Member
United_States
1
Rep
38
Posts

 
Drives: 2013 F10 550i
Join Date: Jun 2011
Location: Palm Beach Gardens, Florida

iTrader: (0)

BMW Apps Does Not Work in M3?

I took my car in the past week for the 1200 mile service. Since I bought the car, the BMW Apps never worked. I would plug in my iPhone 4 into the cradle and the BMW Apps would not work. In addition, the cradle would continually charge the phone for a few seconds and then stop charging and then charge again.

The dealership kept my car for 6 days. They spoke to BMW engineers. They claim that they replaced the cradle and the piece that connects the cradle to the car. Yesterday the called me up and told me that the BMW apps was working.

When I went to pick up my car, the same issue happened. BMW Apps would work for a few seconds and then stop working (and the cradle would stop charging the phone). A salesman's phone at the dealership didn't work either. I was not happy.

My dad has a 2012 750i with BMW Apps and I took my cradle and my phone and plugged it into his car this morning. It worked flawlessly. I called about the dealership and my SA told me that the "750i has different software" and there is a problem having the M3 work with BMW Apps.

My car is correctly equipped with BMW Apps and Smartphone integration. My question to all of you, can you confirm you are using BMW Apps with an iPhone 4 connected to an iPhone 4 cradle in your M3? If you are, then the dealership has no idea what they are doing. What should I do? Thanks.
Appreciate 0
      07-29-2011, 09:13 AM   #2
nockie
Enlisted Member
United_States
1
Rep
38
Posts

 
Drives: 2013 F10 550i
Join Date: Jun 2011
Location: Palm Beach Gardens, Florida

iTrader: (0)

Also, is anyone aware of any new software updates for Connected Drive? I doubt it's a software issue though because of the constant charging cycles. It's almost like there is a wire loose that connects the power to the charger.
Appreciate 0
      07-29-2011, 09:19 AM   #3
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
What happens when the cradle is not used? As in running BMW Apps from the USB port?
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      07-29-2011, 09:20 AM   #4
diablito
motorist
diablito's Avatar
Peru
8
Rep
272
Posts

 
Drives: E90M, E93M
Join Date: Nov 2008
Location: pompano beach

iTrader: (0)

Garage List
2011 BMW M3  [5.00]
I think in order for the BMW connected application to work you need to get the Y cable or the phone tray. it does not work with the white apple cable and is not an application that works though the combox like Pandora or the others.

sorry I miss read your post, you already have a tray. may want to try the Y cable??
__________________
Appreciate 0
      07-29-2011, 09:33 AM   #5
nockie
Enlisted Member
United_States
1
Rep
38
Posts

 
Drives: 2013 F10 550i
Join Date: Jun 2011
Location: Palm Beach Gardens, Florida

iTrader: (0)

Quote:
Originally Posted by Technic View Post
What happens when the cradle is not used? As in running BMW Apps from the USB port?
Amazing. After you posted this I went into my car with my white iPhone cable and it works through USB. I called up the SA and told her and she said that there is no wire issues with the cradle because they tested all the grounds going into it.
Appreciate 0
      07-29-2011, 09:34 AM   #6
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by diablito View Post
I think in order for the BMW connected application to work you need to get the Y cable or the phone tray. it does not work with the white apple cable and is not an application that works though the combox like Pandora or the others.

sorry I miss read your post, you already have a tray. may want to try the Y cable??
The OP is talking about BMW Apps.

BMW Apps = Combox
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      07-29-2011, 09:35 AM   #7
MineralWeiss
USAF Retired
United_States
2
Rep
258
Posts

 
Drives: 2011 BMW M3
Join Date: Jun 2011
Location: Oklahoma City

iTrader: (0)

I have an M3 with BMW Apps and I'm using the iPhone 4 adapter with a part number of 84212218390 and it works fine. Make sure you have the correct adapter! I mistakenly ordered one first with a part number of 84212199389 and it did not work! The correct adapter runs about $250 retail and the one that does not work runs roughly $150.
Appreciate 0
      07-29-2011, 08:58 PM   #8
diablito
motorist
diablito's Avatar
Peru
8
Rep
272
Posts

 
Drives: E90M, E93M
Join Date: Nov 2008
Location: pompano beach

iTrader: (0)

Garage List
2011 BMW M3  [5.00]
Quote:
Originally Posted by Technic View Post
The OP is talking about BMW Apps.

BMW Apps = Combox
I though BMW apps meant the applications you get to use when you download the BMW connected application and I thought combox was the system which allowed you to transfer data via Bluetooth to the system with out using a cable and that is why any BMW that comes with combox does not include a Y cable any longer

__________________
Appreciate 0
      07-30-2011, 08:34 AM   #9
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by diablito View Post
I though BMW apps meant the applications you get to use when you download the BMW connected application and I thought combox was the system which allowed you to transfer data via Bluetooth to the system with out using a cable and that is why any BMW that comes with combox does not include a Y cable any longer

The Combox uses the Apple USB cable for the iPhone/iPod, that's the reason of not requiring the "old" OEM iPod cable anymore.

BMW Apps use the USB cable.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      07-30-2011, 11:56 AM   #10
dibxna
Lieutenant
dibxna's Avatar
United_States
15
Rep
580
Posts

 
Drives: 2015 MW F82 M4
Join Date: Oct 2010
Location: arizona

iTrader: (0)

Quote:
Originally Posted by nockie View Post
Amazing. After you posted this I went into my car with my white iPhone cable and it works through USB. I called up the SA and told her and she said that there is no wire issues with the cradle because they tested all the grounds going into it.
maybe call SA and tell her that there very clearly is problems with it as you clearly found a solution. at very least request they buy you an additional cable
__________________
*15' F82 M4 :: Mineral White w/ Speed Cloth! :: DCT :: fully optioned minus CCB*
*09' E90 M3 :: Le Mans Blue w/ silver novillo :: DCT*
*66' 427 Big Block Corvette :: Maroon :: Straight Piped*
*56' ford f-100 truck :: NSX blue :: lowered :: custom interior :: custom audio :: colorado custom wheels*
Appreciate 0
      07-31-2011, 10:01 AM   #11
bohdistava
e46 convert
bohdistava's Avatar
United_States
0
Rep
38
Posts

 
Drives: 2011 m3 conv
Join Date: Mar 2008
Location: earth

iTrader: (0)

got the same problem

i leaning towards software issue, tried my phone and cradle in other cars works fine. i guess not enough people using this option (media cradle+apps)in the newest m3 that we have not heard about the problem and white cable works fine but no video
Appreciate 0
      08-24-2011, 10:30 PM   #12
DarkstarZero
Major
DarkstarZero's Avatar
United_States
41
Rep
1,207
Posts

 
Drives: e39 M5, e36 M3, e92 M3, Z4M
Join Date: Nov 2007
Location: Washington DC

iTrader: (4)

Send a message via AIM to DarkstarZero
I have the same problem too! Very frustrating. I have a verizon iphone 4, i launch pandora or bmw connected and it works for maybe a minute, then it disconnects and reconnects after another minute and this just repeats over and over. Maybe the cradle just doesn't work right with the m3? I'm mad! Option + cradle = $500 and it doesn't work!
__________________
Appreciate 0
      08-25-2011, 04:09 AM   #13
Tonifyd
Lieutenant
Tonifyd's Avatar
11
Rep
459
Posts

 
Drives: 2011.75 JB E90M3 6MT
Join Date: Mar 2011
Location: Hong Kong

iTrader: (0)

I have the cradle, and BMW apps. I use mine mostly for mp3s and video on the iphone.
Make sure you have the media cradle, and not the music cradle.
Tell them to give you a new cradle. When you do so, make sure you take out your old one, so they won't just say they replaced it, even though they haven't even touched it.
Take it to a different car on display and try it there.
Which app exactly are you trying to use?
Pandora, MP3s, and charging should work without the cradle.
The only apps that require the cradle are iphone video, web radio, facebook and twitter.
Web radio, and I think facebook and twitter, you need the connected drive app loaded on your iphone.
__________________
2011.75 E90 ///M3 6MT | JB | Blk | CF | ZCP | ZCV | ZCW | ZP2 | 403 | 6NR | 752 [Sold T.T]
'95 Integra GS-R [Stolen-RIP] | '05 Legacy GT Stg 2[Traded] | '08 STi Stg 2+[Sold]
Appreciate 0
      08-25-2011, 05:56 AM   #14
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Tonifyd View Post
I have the cradle, and BMW apps. I use mine mostly for mp3s and video on the iphone.
Make sure you have the media cradle, and not the music cradle.
Tell them to give you a new cradle. When you do so, make sure you take out your old one, so they won't just say they replaced it, even though they haven't even touched it.
Take it to a different car on display and try it there.
Which app exactly are you trying to use?
Pandora, MP3s, and charging should work without the cradle.
The only apps that require the cradle are iphone video, web radio, facebook and twitter.
Web radio, and I think facebook and twitter, you need the connected drive app loaded on your iphone.
Agreed, the OP's cradle is not for BMW Apps.

On the other hand, iPod Out (video) is the only BMW Apps feature dependent of the cradle. Web Radio, Pandora, Calendar, Facebook and Twitter are accessible without the cradle.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      08-25-2011, 05:58 AM   #15
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by DarkstarZero View Post
I have the same problem too! Very frustrating. I have a verizon iphone 4, i launch pandora or bmw connected and it works for maybe a minute, then it disconnects and reconnects after another minute and this just repeats over and over. Maybe the cradle just doesn't work right with the m3? I'm mad! Option + cradle = $500 and it doesn't work!
You may have a wrong/defective cradle as well. Do the same test as the OP -connect the iPhone directly to the USB port- and check that BMW Apps at least works from the port.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      08-25-2011, 06:39 AM   #16
DarkstarZero
Major
DarkstarZero's Avatar
United_States
41
Rep
1,207
Posts

 
Drives: e39 M5, e36 M3, e92 M3, Z4M
Join Date: Nov 2007
Location: Washington DC

iTrader: (4)

Send a message via AIM to DarkstarZero
Quote:
Originally Posted by Technic View Post
Agreed, the OP's cradle is not for BMW Apps.

On the other hand, iPod Out (video) is the only BMW Apps feature dependent of the cradle. Web Radio, Pandora, Calendar, Facebook and Twitter are accessible without the cradle.
I do have the correct cradle, it is the $255 6NR Media Cradle. As I said, it does work, but only for a minute. I'll try out just using the normal cable when I get home.
__________________
Appreciate 0
      08-25-2011, 07:11 AM   #17
Technic
Lieutenant General
Technic's Avatar
United_States
171
Rep
11,181
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by DarkstarZero View Post
I do have the correct cradle, it is the $255 6NR Media Cradle. As I said, it does work, but only for a minute. I'll try out just using the normal cable when I get home.
If the cradle works in another car with 6NR and your BMW Apps works 100% from your USB port directly then your baseplate is defective.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      08-25-2011, 07:23 AM   #18
M4 Cab
New Member
1
Rep
20
Posts

 
Drives: 2015 M4
Join Date: Aug 2011
Location: Marietta, GA

iTrader: (0)

Garage List
2015 BMW M4  [0.00]
I have really enjoyed Pandora & the apps. The only issue I have had is when I have hooked up a Classic IPOD 30 gb at the same time. Even 8gb flash drives work better. It just freezes up the USB connection. Anyone else with similar issues? I bought my IPhone 4 adapter for $200 from an Atlanta BMW dealer.
Appreciate 0
      09-01-2011, 08:53 PM   #19
dave6408
New Member
dave6408's Avatar
United_States
0
Rep
16
Posts

 
Drives: 2011 E90 M
Join Date: Jul 2009
Location: Nashville

iTrader: (0)

Having same problem. Picked up E90 M3 monday at the Performance Center. My IPhone 4 cradle arrived today from my SA in California. It snaps in snugly. The Verizon phone snaps in snugly. The charge symbol comes on and then I see recognition of my phone and songs on the console screen. But that lasts about 10 seconds. Then it turns off and recycles about every 10 seconds. It seems like it's more than a connection problem. Can go to the cable but after dropping 150 on it, it would be nice to have it work. Have you had them exchange cradles to see if simply defective?

Last edited by dave6408; 09-01-2011 at 09:05 PM.
Appreciate 0
      09-01-2011, 09:19 PM   #20
jphughan
Brigadier General
jphughan's Avatar
United_States
39
Rep
3,467
Posts

 
Drives: 2011.75 M3 E92 6MT
Join Date: Mar 2011
Location: Austin, TX

iTrader: (0)

Quote:
Originally Posted by Technic View Post
The OP is talking about BMW Apps.

BMW Apps = Combox
Not true. Combox was available before BMW Apps and has become standard as of 9/10 production. BMW Apps is a separate feature and is optional.

Quote:
Originally Posted by bohdistava View Post
i leaning towards software issue, tried my phone and cradle in other cars works fine. i guess not enough people using this option (media cradle+apps)in the newest m3 that we have not heard about the problem and white cable works fine but no video
I have an M3 and my Media cradle works fine (Pandora and charging all work reliably for long periods of time) EXCEPT that video playback and iPod Out don't work. They worked when I initially got the car and I went a couple months without ever trying it again, only to find it broken -- but my phone and my cradle work in other 6NR cars. I assumed that the rear view camera I installed might have broken it somehow, and the dealership tells me that must be it too because they claim that they validated the baseplate, but now I'm not so sure.

I had V41 software and they updated me to V42, no change in behavior though. Keep me posted as I'm now definitely interested in this.
__________________
11 M3 E92 Le Mans | Black Nov w/ Alum | 6MT | Premium 2 | Convenience | 19" | EDC | Prem Audio | Moonroof | BMW Apps | Yoko AD08 R | Vorshlag Adjustable Camber Plates | StopTech ST-60 380mm BBK | Castrol SRF Fluid | ModMyNav.com rear camera | OEM Euro Sunglasses Holder

Last edited by jphughan; 09-01-2011 at 09:35 PM.
Appreciate 0
      09-01-2011, 09:35 PM   #21
Totti
Troll
Totti's Avatar
Italy
22
Rep
1,192
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2009
Location: Melbourne, Australia

iTrader: (0)

Where is apps? In connected drive all i see is Internet? I am using the snap in adaptor.

Also my cover art doesn't display when using the cradle but does when I use the USB + Line in AUX port centre console?
__________________
BMW E92 M3 Coupe | Jerez Black | Fox Red Extended / Carbon Black Trim| Fully Loaded | Moonroof | 6MT | Gintani Sport
Quote:
Originally Posted by ES_TRADER
Use the stick like u would a manual. If that doesn't work, put it in D mode and put both hands at 10 and 2. If that doesn't work, just sit on your right hand.
Appreciate 0
      09-01-2011, 09:44 PM   #22
Totti
Troll
Totti's Avatar
Italy
22
Rep
1,192
Posts

 
Drives: 2011 E92 M3
Join Date: Aug 2009
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by jphughan View Post
If you have USB+Line In, you don't have Combox, which is what allows album art. That was introduced as new standard equipment as of 9/10 production. BMW Apps became available as a new OPTION starting 3/11 production.
I picked my car up 4 days ago I ticked every option incl. extended connectivity + internet...

As stated I do get album art when using the BMW cable, just not on the snap in.
__________________
BMW E92 M3 Coupe | Jerez Black | Fox Red Extended / Carbon Black Trim| Fully Loaded | Moonroof | 6MT | Gintani Sport
Quote:
Originally Posted by ES_TRADER
Use the stick like u would a manual. If that doesn't work, put it in D mode and put both hands at 10 and 2. If that doesn't work, just sit on your right hand.
Appreciate 0
Post Reply

Bookmarks

Tags
bmw apps

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:36 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST