BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
PYSPEED
Post Reply
 
Thread Tools Search this Thread
      07-24-2011, 12:45 PM   #1
mmaler
New Member
0
Rep
5
Posts

 
Drives: 2008 M3 Coupe
Join Date: Jul 2011
Location: Branford, CT

iTrader: (0)

08' M3 Coupe Audio Sounds Terrible (Just Purchased)

Hey guys,

This is my first post here. I just purchased an 08 M3 Coupe. Not sure if this is common or I am missing something but the audio system sounds horrific. It has zero bass and is just really flat (even when all the settings are max'ed out). Am I missing something here?

Any help / insight would be greatly appreciated.

M
Appreciate 0
      07-24-2011, 12:46 PM   #2
Simma
First Lieutenant
Simma's Avatar
Canada
5
Rep
323
Posts

 
Drives: E92 M3
Join Date: Apr 2011
Location: Toronto

iTrader: (0)

there is something wrong with your audio system. I get really nice clean bass out of my system.
Appreciate 0
      07-24-2011, 12:47 PM   #3
FVM3
Major General
FVM3's Avatar
115
Rep
5,739
Posts

 
Drives: e92 m3, f30 328i
Join Date: Sep 2010
Location: Los Angeles

iTrader: (2)

bass is subjective but the base one should at least has some bass
Appreciate 0
      07-24-2011, 12:49 PM   #4
mmaler
New Member
0
Rep
5
Posts

 
Drives: 2008 M3 Coupe
Join Date: Jul 2011
Location: Branford, CT

iTrader: (0)

I swear my iPad speaker sounds better than the system in the car. I figured something had to be wrong. Sigh.....
Appreciate 0
      07-24-2011, 01:12 PM   #5
FVM3
Major General
FVM3's Avatar
115
Rep
5,739
Posts

 
Drives: e92 m3, f30 328i
Join Date: Sep 2010
Location: Los Angeles

iTrader: (2)

maybe blown speakers?
Appreciate 0
      07-24-2011, 01:25 PM   #6
Legion5
Major
Legion5's Avatar
43
Rep
1,381
Posts

 
Drives: e92
Join Date: Dec 2007
Location: USA

iTrader: (12)

BMW really doesn't put much money into the audio system, even the $2000 ehanced audio is about the quality of mid range aftermarket audio system from Walmart. Most people have very low standards for what constiutes good audio though so they think it sounds good and BMW gets away with sub par audio.
__________________

Clean cars are happy cars!
CANON PHOTOGRAPHER
Appreciate 0
      07-24-2011, 02:31 PM   #7
808MGuy
Colonel
808MGuy's Avatar
49
Rep
2,287
Posts

 
Drives: 2009 E90 M3
Join Date: Jun 2008
Location: Oahu, Hawaii

iTrader: (3)

On the flip side, people think because they are buying an expensive car it should have some magical sound system that can be heard down the road. OEM sound systems are always an afterthought. Never expect to get aftermarket quality out of an OEM system. Especially if you've had aftermarket systems in the past.
__________________
09 E90 M3 - Interlagos Blue / Black Novillo / Sycamore Anthracite / Eibach / HRE

Appreciate 0
      07-24-2011, 04:22 PM   #8
elp_jc
Brigadier General
United_States
80
Rep
4,910
Posts

 
Drives: .
Join Date: May 2008
Location: .

iTrader: (0)

The optional audio is a very decent audio system. It's a must if you're an audiophile and don't want to modify your car (like me ). Now you have no option but to do the latter. Many threads on that. Good luck.
Appreciate 0
      07-24-2011, 07:39 PM   #9
SeeYaLater
Private
SeeYaLater's Avatar
United_States
1
Rep
82
Posts

 
Drives: E90 M3 & E36 M3
Join Date: Jun 2011
Location: South Florida

iTrader: (1)

If you're an audiophile and are happy with the stock system, you must have a Bose system at home......
Appreciate 0
      07-24-2011, 07:46 PM   #10
SIIK2NR
Captain
SIIK2NR's Avatar
South Korea
16
Rep
604
Posts

 
Drives: AW E92 M3
Join Date: Mar 2007
Location: San Dog

iTrader: (0)

Could be an overheated amplifier. Also could be bad connection to the amplifier.
__________________
Current: 2006 Lotus Elise SC
Previous:
2008 AW E92 M3 6MT - Sold
2004 AP2 S2000 - Sold
Appreciate 0
      07-24-2011, 09:30 PM   #11
elp_jc
Brigadier General
United_States
80
Rep
4,910
Posts

 
Drives: .
Join Date: May 2008
Location: .

iTrader: (0)

Quote:
Originally Posted by SeeYaLater View Post
If you're an audiophile and are happy with the stock system, you must have a Bose system at home......
Guess you missed the portion in bold below . And unless you listen to rap, it's a decent system for a car.

Quote:
Originally Posted by elp_jc View Post
The optional audio is a very decent audio system. It's a must if you're an audiophile and don't want to modify your car (like me )
Appreciate 0
      07-25-2011, 12:49 PM   #12
mmaler
New Member
0
Rep
5
Posts

 
Drives: 2008 M3 Coupe
Join Date: Jul 2011
Location: Branford, CT

iTrader: (0)

Did a little bit more research. The car has the premium sound system. Looks like the amp isn't operating at all. Checked the wires, etc but still nothing. Called BMW but they can't get me in until next week. Hate having to wait a week since we are heading out on a mini-vacation this weekend and taking the car. GRRRR!
__________________
2008 M3 Couple, 6-Speed, Interlagos Blue
2011 X5 351i Premium, Alpine White
Appreciate 0
      07-25-2011, 01:07 PM   #13
808MGuy
Colonel
808MGuy's Avatar
49
Rep
2,287
Posts

 
Drives: 2009 E90 M3
Join Date: Jun 2008
Location: Oahu, Hawaii

iTrader: (3)

Quote:
Originally Posted by mmaler View Post
Did a little bit more research. The car has the premium sound system. Looks like the amp isn't operating at all. Checked the wires, etc but still nothing. Called BMW but they can't get me in until next week. Hate having to wait a week since we are heading out on a mini-vacation this weekend and taking the car. GRRRR!
You mean just the channels for the underseat woofers or the whole thing? If the whole amp wasn't operating, you wouldn't get bad sound. You would get no sound at all.
__________________
09 E90 M3 - Interlagos Blue / Black Novillo / Sycamore Anthracite / Eibach / HRE

Appreciate 0
      07-25-2011, 02:37 PM   #14
mmaler
New Member
0
Rep
5
Posts

 
Drives: 2008 M3 Coupe
Join Date: Jul 2011
Location: Branford, CT

iTrader: (0)

I get sound out of all the speakers but none of the woofers are on.
__________________
2008 M3 Couple, 6-Speed, Interlagos Blue
2011 X5 351i Premium, Alpine White
Appreciate 0
      07-26-2011, 01:10 AM   #15
elp_jc
Brigadier General
United_States
80
Rep
4,910
Posts

 
Drives: .
Join Date: May 2008
Location: .

iTrader: (0)

Quote:
Originally Posted by mmaler View Post
I get sound out of all the speakers but none of the woofers are on.
Are you aware you have BOTH bass/mid/treble controls AND an EQUALIZER? Check that you don't have the bass turned all the way down on one of them . Even if subs were blown, you'd hear something... unless disconnected. Good luck.

And it's easy to know if you have the EAS: you should be able to see the speakers thru the grilles, have tweeters on the rear panel, plus speakers on the rear deck. But the easiest test is the see-thru grilles .
Appreciate 0
      07-26-2011, 09:08 AM   #16
mmaler
New Member
0
Rep
5
Posts

 
Drives: 2008 M3 Coupe
Join Date: Jul 2011
Location: Branford, CT

iTrader: (0)

Very aware of that. For some reason the subs are either disconnected or the channel in the amp is blown. And yes, it is the EAS. Scheduled an appointment for service to see whats up but they can't take the car until next week then I am sure it will take another week before everything is said and done. Guess I am just going to put an old school boom box in the back seat in the mean time.


Quote:
Originally Posted by elp_jc View Post
Are you aware you have BOTH bass/mid/treble controls AND an EQUALIZER? Check that you don't have the bass turned all the way down on one of them . Even if subs were blown, you'd hear something... unless disconnected. Good luck.

And it's easy to know if you have the EAS: you should be able to see the speakers thru the grilles, have tweeters on the rear panel, plus speakers on the rear deck. But the easiest test is the see-thru grilles .
__________________
2008 M3 Couple, 6-Speed, Interlagos Blue
2011 X5 351i Premium, Alpine White
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:49 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST