BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Lux Angel Eyes
Post Reply
 
Thread Tools Search this Thread
      07-16-2011, 06:16 PM   #1
sameh
Major
United_States
28

 
sameh's Avatar
 
Drives: 2011 E92 M3 DCT JetBlk
Join Date: Aug 2010
Location: Texas


Posts: 1,471
iTrader: (0)

Right rear signal light!!!!

I\'ve been getting notifications on idrive saying \"right rear signal light malfunction\". First time it happened I stopped, turned right signal on then got out of the car and it was working. Didn\'t think much of it but kept getting every other day then daily. But now right rear signal light would only work once every five or six times. My dealer (closest dealer) is 75 miles, anyone had this happen? Any DIY for that? Thanks
__________________
2011 E92 BatMobile JtBlk/Blk/Blk CF
Appreciate 0
      07-16-2011, 06:20 PM   #2
ThunderMoose
Captain
13

 
Drives: 2009 C2S and 2003 E46 M3
Join Date: Aug 2010
Location: League City, TX


Posts: 965
iTrader: (0)

Quote:
Originally Posted by sameh View Post
I\'ve been getting notifications on idrive saying \"right rear signal light malfunction\". First time it happened I stopped, turned right signal on then got out of the car and it was working. Didn\'t think much of it but kept getting every other day then daily. But now right rear signal light would only work once every five or six times. My dealer (closest dealer) is 75 miles, anyone had this happen? Any DIY for that? Thanks
I had it in my wife's X5. I changed the light bulb and the problem went away. Got the bulb from nearby auto parts store.
Appreciate 0
      07-16-2011, 07:34 PM   #3
IPvFletch
Enlisted Member
0

 
Drives: Charger SRT8
Join Date: Jul 2011
Location: ATX


Posts: 31
iTrader: (0)

BMW and Chevy are NOTORIOUS for their wiring issues. I'm not sure where the fault lies, but I CONSTANTLY see rides from these mfrs where a light or two is out, front of back.. Remember the old E36, didn't it have like 12 bulbs in each taillight???
Appreciate 0
      07-16-2011, 11:30 PM   #4
fuzzybam
Private First Class
United_States
1

 
Drives: One with wheels
Join Date: Jul 2011
Location: USA


Posts: 197
iTrader: (0)

I always see brand new VWs, Audis, and Chevys with headlight and taillight problems. Never really see BMWs with that problem... Anyway, just buy a bulb and replace both sides while you're in there.
Appreciate 0
      07-16-2011, 11:58 PM   #5
elp_jc
Brigadier General
United_States
79

 
Drives: .
Join Date: May 2008
Location: .


Posts: 4,910
iTrader: (0)

I got the right front DRL malfunction, and it was working perfectly. Two days later, it crapped out. My only answer is the system is psychic . Next time will just buy a darn bulb when I get the 'warning' .
Appreciate 0
      07-17-2011, 01:17 AM   #6
BobsM3Coupe
Captain
United_States
17

 
Drives: M3 Coupe
Join Date: Nov 2009
Location: California


Posts: 862
iTrader: (4)

Quote:
Originally Posted by ThunderMoose View Post
I had it in my wife's X5. I changed the light bulb and the problem went away. Got the bulb from nearby auto parts store.
The 2011's have LED's so bulb replacement isn't possible. Let the dealer figure out the problem with the turn indicator.
Appreciate 0
      07-17-2011, 02:01 AM   #7
-=Hot|Ice=-
Been There, Done That.
United_States
183

 
-=Hot|Ice=-'s Avatar
 
Drives: 2013 BMW M3
Join Date: Jan 2008
Location: Maryland


Posts: 4,727
iTrader: (0)

Replaced 4 drl lights and 5 brake lamps on my 08 in 3 years.
__________________
Quote:
Originally Posted by Jaypod View Post
You sound like my buddies who have AMG's - Slam the gas, slam the brakes...
Appreciate 0
      07-17-2011, 04:04 AM   #8
sameh
Major
United_States
28

 
sameh's Avatar
 
Drives: 2011 E92 M3 DCT JetBlk
Join Date: Aug 2010
Location: Texas


Posts: 1,471
iTrader: (0)

Quote:
Originally Posted by BobsM3Coupe View Post
Quote:
Originally Posted by ThunderMoose View Post
I had it in my wife's X5. I changed the light bulb and the problem went away. Got the bulb from nearby auto parts store.
The 2011's have LED's so bulb replacement isn't possible. Let the dealer figure out the problem with the turn indicator.
That's what I thought. I can feel a bulb but it seems more inward to be a signal bulb. I'll attempt changing the one I can feel and see if it fixes the problem but I'm a little skeptical.
__________________
2011 E92 BatMobile JtBlk/Blk/Blk CF
Appreciate 0
      07-17-2011, 06:05 AM   #9
GOVCO
Lieutenant
5

 
Drives: 09 E90 AW M3 DCT [Slight Mods]
Join Date: Jun 2011
Location: MD


Posts: 435
iTrader: (0)

Quote:
Originally Posted by sameh View Post
I\'ve been getting notifications on idrive saying \"right rear signal light malfunction\". First time it happened I stopped, turned right signal on then got out of the car and it was working. Didn\'t think much of it but kept getting every other day then daily. But now right rear signal light would only work once every five or six times. My dealer (closest dealer) is 75 miles, anyone had this happen? Any DIY for that? Thanks
I just had this happen to my 09'. Took it to the dealership yesterday because they said they have to replace the entire unit. I was like really. The guy I take it to also has an M3; so didn't think he was BS'n me. To my surprise, their mechanic said BMW NA makes them replace not only the defective unit, but the other as well. Something about corossion around the seals or something. So, my issue was with the rear passenger side tail light receiving the malfunction notification. They are also replacing the rear driver side tail unit. What a waste. Under warranty so I could care less, but still. Wow!
Appreciate 0
      07-17-2011, 08:06 AM   #10
MilehighM3
Colonel
21

 
MilehighM3's Avatar
 
Drives: E90 M3
Join Date: May 2011
Location: Colorado Springs


Posts: 2,162
iTrader: (9)

Ya there's a bulletin on a certain production window of cars. Both lights have to get replaced, similar to the 1 series situation if anyone else has been down that road. Should be warranty though, so just call ahead and make sure they have the parts in stock before making the trip.
Appreciate 0
      07-18-2011, 01:56 AM   #11
BobsM3Coupe
Captain
United_States
17

 
Drives: M3 Coupe
Join Date: Nov 2009
Location: California


Posts: 862
iTrader: (4)

Quote:
Originally Posted by sameh View Post
That's what I thought. I can feel a bulb but it seems more inward to be a signal bulb. I'll attempt changing the one I can feel and see if it fixes the problem but I'm a little skeptical.
The only bulb in the LCI coupes lights is the reverse light.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:11 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST