BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GT Haus
Post Reply
 
Thread Tools Search this Thread
      06-06-2011, 05:51 PM   #1
Chancepowell
New Member
2

 
Drives: E90 M3
Join Date: Jun 2011
Location: SoCal


Posts: 17
iTrader: (0)

poor radio reception in 2008 e90 M3

I don't usually listen to the radio but I can't believe how difficult it is to keep a station clear. I live in the LA area, is there something that can be done to improve this?

- GO easy, my first post

CV8
Appreciate 0
      06-06-2011, 05:59 PM   #2
Technic
Lieutenant General
United_States
197

 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida


Posts: 11,148
iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by Chancepowell View Post
I don't usually listen to the radio but I can't believe how difficult it is to keep a station clear. I live in the LA area, is there something that can be done to improve this?

- GO easy, my first post

CV8
Any rear window metallic tint? If so, then that could be your problem.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      06-06-2011, 06:42 PM   #3
ducman
Second Lieutenant
United_States
8

 
Drives: E92 M3
Join Date: Jun 2010
Location: OC


Posts: 257
iTrader: (5)

What about a 2011 E92? I get static all the time driving to work. When I get home, I park the car one level underground and all I hear is static. But once I open the driver side door, it's crystal clear. Won't work if I roll down the window or open the passenger side door. I got Premier's diamond cut ir nano tints which doesn't have any metallic. Thoughts?
Appreciate 0
      06-06-2011, 07:07 PM   #4
Technic
Lieutenant General
United_States
197

 
Technic's Avatar
 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida


Posts: 11,148
iTrader: (18)

Garage List
2004 M3  [0.00]
Sometimes installers can damage the antenna contacts in the rear window (the antenna is "printed" in the inside rear window surface) when they install the tint.
__________________
-2015 F30 320i, Imperial/Oyster, 8AT: August 2014 ED
-2012 E92 M3 Jerez Black/Rust Brown, M-DCT: Gone
-2008 E90 M3 Melbourne Red/Bamboo, 6MT: Gone
-2007 MK5 GTI United Grey/Grey, DSG: Gone
-2004 E46 M3 Carbon Black/Cinnamon, 6MT: Gone
Appreciate 0
      06-21-2011, 09:56 AM   #5
alpina527
Banned
United Kingdom
36

 
Drives: 2008 E92 M3 DCT JZB/FR
Join Date: Jan 2010
Location: London, England


Posts: 638
iTrader: (1)

Have you got any accessories plugged in to your power adapter? If so, try un plugging it
Appreciate 0
      06-21-2011, 11:59 AM   #6
elp_jc
Brigadier General
United_States
134

 
Drives: .
Join Date: May 2008
Location: .


Posts: 4,910
iTrader: (0)

AM reception on my '08 is crap, with static that resembles a blown speaker, then the sound suddenly changes, probably switching from regular to HD? Don't know. But FM is better. I rarely listen to the radio, so that doesn't bother me that much. And reception is not great where I live anyway, so it's just weak radio performance. I wouldn't even consider having a dealer replace my unit, as a new one would be the same. Everything else works perfectly.
Appreciate 0
      07-30-2011, 08:37 PM   #7
ducman
Second Lieutenant
United_States
8

 
Drives: E92 M3
Join Date: Jun 2010
Location: OC


Posts: 257
iTrader: (5)

I figured out my static issue. It's from the AiB v3 angle eyes I have. I was reading this thread (http://www.e90post.com/forums/showth...9#post10130949) and decided to turn the angles eyes on and off and sure enough the static was there then it was gone.
Appreciate 0
      08-01-2011, 04:15 PM   #8
LuxAngelEyes
BimmerPost Supporting Vendor
United_States
80


 
LuxAngelEyes's Avatar
 
Drives: 2006 325xi, Sparkling Graphite
Join Date: Jan 2011
Location: New Haven, CT


Posts: 3,141
iTrader: (12)

Quote:
Originally Posted by ducman View Post
I figured out my static issue. It's from the AiB v3 angle eyes I have. I was reading this thread (http://www.e90post.com/forums/showth...9#post10130949) and decided to turn the angles eyes on and off and sure enough the static was there then it was gone.
The LUX H8 V3 angel eyes have absolutely no radio interference
__________________

Special Announcement coming on Black Friday!!!
LUX H8 Amber | LUX E90 v5.2 & LUX E90 LCI Halogen | LUX Backup Lights GROUP BUY
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:39 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST