BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > BIMMERPOST Universal Forums > General Automotive (non-BMW) Talk + Photos/Videos
 
BPM Sport
Post Reply
 
Thread Tools Search this Thread
      06-03-2011, 10:21 AM   #1
Simma
First Lieutenant
Canada
5

 
Simma's Avatar
 
Drives: E92 M3
Join Date: Apr 2011
Location: Toronto


Posts: 322
iTrader: (0)

Need Some General Information - 2002 Civic Si Coupe

Before everyone starts complaining, I'd like to appologize ahead of time since what I'm going to say has nothing to do with this forum lol.

My beater started acting up this morning. It is a 2002 Civic SI Coupe. I beat this around the city everywhere since its a civic and cheap on gas and I can careless about the Kilometres. It was a dealer maintained car when I bought it last year and I have all service records. The car is at 202,000KM (Approx 125,600 Miles)

The issue:
Car is not accelerating past 130km/h!!!! What does this mean? Clutch seems to be fine... I understand that this can be caused by many reasons but from a general standpoint, what usually causes this?
Appreciate 0
      06-03-2011, 10:27 AM   #2
M3Bahn
Lieutenant
58

 
M3Bahn's Avatar
 
Drives: M3
Join Date: Mar 2011
Location: ATL


Posts: 487
iTrader: (0)

VTB!
__________________
The journey is the reward.
Appreciate 0
      06-03-2011, 10:29 AM   #3
e1000
that's what SHE said!
11

 
Drives: 2011 E92 M3 ZCP
Join Date: Jun 2010
Location: OC


Posts: 1,076
iTrader: (1)

you need ZCP to go over 130km/h
__________________
Appreciate 0
      06-03-2011, 10:50 AM   #4
Simma
First Lieutenant
Canada
5

 
Simma's Avatar
 
Drives: E92 M3
Join Date: Apr 2011
Location: Toronto


Posts: 322
iTrader: (0)

lol it's not like I care to go over 130km/h because I really don't but it still bothers me that even if I wanted too, I can't and obviously somethings wrong. I just want the car fixed before more issues come up.
Appreciate 0
      06-03-2011, 08:34 PM   #5
b0bab0i
Captain
9

 
Drives: 03 TiAG z4 3.0i w/ hardtop
Join Date: Feb 2008
Location: SoCal


Posts: 971
iTrader: (0)

Take it to a shop and get it inspected?
Appreciate 0
      06-03-2011, 09:12 PM   #6
blue2fire
Brigadier General
Cayman Islands
71

 
blue2fire's Avatar
 
Drives: BMW 135i
Join Date: Jan 2009
Location: Location, Location, Location


Posts: 4,289
iTrader: (8)

Dood. That is horrible car.
__________________

BMW CCA
Member #420568
Quote:
Originally Posted by Gordon Murray View Post
Being a fan of Honda engines, I requested that they consider building for the F1 a 4.5 liter V10 or V12. I asked, I tried to persuade them, but in the end could not convince them to do it, and the McLaren F1 ended up with a BMW engine.
Appreciate 0
      06-03-2011, 10:19 PM   #7
WishBone33
First Lieutenant
Japan
5

 
Drives: SGM 135i
Join Date: Apr 2008
Location: Jacksonville, NC


Posts: 362
iTrader: (0)

how fast do u expect a mini mini van to go?
Appreciate 0
      06-04-2011, 02:28 AM   #8
alpine46
New Member
0

 
Drives: alpine e46
Join Date: Jul 2010
Location: Bay Area


Posts: 10
iTrader: (0)

Quote:
Originally Posted by Simma View Post
Before everyone starts complaining, I'd like to appologize ahead of time since what I'm going to say has nothing to do with this forum lol.

My beater started acting up this morning. It is a 2002 Civic SI Coupe. I beat this around the city everywhere since its a civic and cheap on gas and I can careless about the Kilometres. It was a dealer maintained car when I bought it last year and I have all service records. The car is at 202,000KM (Approx 125,600 Miles)

The issue:
Car is not accelerating past 130km/h!!!! What does this mean? Clutch seems to be fine... I understand that this can be caused by many reasons but from a general standpoint, what usually causes this?

First, 2002 did not have any si coupe production model. they're the hatch

and you'll have more luck with the ep3hatch forums instead
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:24 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST