BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Wheels + Tires Sponsored by The Tire Rack
  TireRack

KEEP M3POST ALIVE BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER LINK!
Post Reply
 
Thread Tools Search this Thread
      02-27-2011, 10:18 PM   #1
das144
Second Lieutenant
29

 
Drives: 997.2
Join Date: Aug 2010
Location: ...


Posts: 200
iTrader: (0)

scratches on ADV1 wheels

Has anyone else with ADV1's noticed this?
Im seeing very fine scratches on the wheels. Not on the outler lip- its not a curb rash. Pic below.

My car has no scaratches on the paint, just the wheels.
I;ve never noticed this on any stock wheels. Just the ADV1s. Maybe becuase they are a darker color?
The scratches can be removed with a compoud/paint cleaner-I tried- but who the hell wants to compound and buff out their wheels regularly. Im wondering if others have experienced this. Maybe ADV1 clear coat on the wheels is weak?
I've only driven maybe 1000 miles with these wheels.
If its not the quality of the clear coat the only other thing I can assume is its becuase they are wide and stick out and are suseptable to every rock flying off the road.
Attached Images
 
Appreciate 0
      02-27-2011, 10:38 PM   #2
pumper206
80 Deep, We All Eat!!!
Taiwan
29

 
pumper206's Avatar
 
Drives: 2009 AW E92 M3
Join Date: Feb 2009
Location: Seattle,Wa


Posts: 622
iTrader: (5)

What finish is that?? And, what are you using to wash your wheels?? Maybe you scratched the finish while cleaning? I dunno. Good to know tho.
Appreciate 0
      02-27-2011, 10:55 PM   #3
das144
Second Lieutenant
29

 
Drives: 997.2
Join Date: Aug 2010
Location: ...


Posts: 200
iTrader: (0)

Quote:
Originally Posted by pumper206 View Post
What finish is that?? And, what are you using to wash your wheels?? Maybe you scratched the finish while cleaning? I dunno. Good to know tho.
finish is brushed gunmetal
Not a shot I scratched them cleaning- im always changing microfibers and anything that could scratch a wheel (if something was stuck to a microfiber)would have really hurt the paint- but no scractches on the paint.

Its like the dirt in the air blowing thru the wheels if doing it.
Appreciate 0
      02-28-2011, 02:53 AM   #4
IMMY1
Private First Class
4

 
Drives: BMW M3
Join Date: Sep 2009
Location: UNITED KINGDOM


Posts: 117
iTrader: (1)

Hi mate I had the same problem on my brushed aluminiumADV10 s fine hair line scratches, it appears to be the top coat expanding to heat and cracking it will get worse , only way for me to was to fully remove and powder coat my alloy , if u send me your email I will post pic before and after , thanks
Appreciate 0
      02-28-2011, 03:16 AM   #5
esquire
Colonel
United_States
73

 
esquire's Avatar
 
Drives: 2011.5 Dakar Yellow M3 Coupe
Join Date: Feb 2007
Location: Orange County, California


Posts: 2,801
iTrader: (0)

hmm. that sounds like a problem you should discuss with the manufacturer. a reputable company like ADV might be willing to fix the problem for you.
__________________

[ESS VT2-625] [Akrapovic Evolution Exhaust] [KW Clubsports] [OSS Angel Eyes] [Revinora r-CRT Lip]
[Vorsteiner Boot] [Challenge Race Diffuser] [See the Build Thread HERE]
Appreciate 0
      02-28-2011, 11:31 AM   #6
das144
Second Lieutenant
29

 
Drives: 997.2
Join Date: Aug 2010
Location: ...


Posts: 200
iTrader: (0)

Quote:
Originally Posted by esquire View Post
hmm. that sounds like a problem you should discuss with the manufacturer. a reputable company like ADV might be willing to fix the problem for you.
I spoke to ADV1 this morning. So far they have been great to deal with. Im hoping they will take care of the issue as it appears to be a problem with the clear coat. It just isnt holding up to basic driving.
I will keep everyone posted on the outcome.
Appreciate 0
      02-28-2011, 11:39 AM   #7
Kyoshi71
Colonel
50

 
Kyoshi71's Avatar
 
Drives: 2010 M3 Coupe
Join Date: Jul 2006
Location: New York


Posts: 2,528
iTrader: (0)

Quote:
Originally Posted by esquire View Post
hmm. that sounds like a problem you should discuss with the manufacturer. a reputable company like ADV might be willing to fix the problem for you.
I'm not sure how reputable the company actually is. It's a Jordan Swerdloff joint.

Either way, all of us will just stand here impatiently and wait to see what happens.....
Attached Images
 
__________________
"But resist we much; we must; and we will much; about that be committed."
~Rev. Al Sharpton


2010 E92 M3|Silverstone II|M-DCT|NCSW|2MT|ZCW|ZPP|ZTP|302|507|Gas Guzzler Tax
Appreciate 0
      02-28-2011, 11:56 AM   #8
das144
Second Lieutenant
29

 
Drives: 997.2
Join Date: Aug 2010
Location: ...


Posts: 200
iTrader: (0)

Quote:
Originally Posted by Kyoshi71 View Post
I'm not sure how reputable the company actually is. It's a Jordan Swerdloff joint.

Either way, all of us will just stand here impatiently and wait to see what happens.....
Nice

I have heard the same about ADV1, but I gave them a shot. I'll give them a chance to make this right.

The truth is if they dont handle I'd have my attorney send them a letter and we'll be in court. Im sure it wont come to that and they will handle it. From my experience to date they seem to be on the ball....
Appreciate 0
      02-28-2011, 02:04 PM   #9
ADV.1 Matt
Lieutenant Colonel
76

 
ADV.1 Matt's Avatar
 
Drives: N/A
Join Date: Feb 2011
Location: Miami, FL


Posts: 1,512
iTrader: (0)

Das144,

Sorry to hear about your issue. Can you PM me some of your info, where you purchased the set from, and who you spoke with here at ADV.1 so I can follow up and make sure we take care of this properly on our end.

Thanks!
Appreciate 0
      02-28-2011, 02:25 PM   #10
das144
Second Lieutenant
29

 
Drives: 997.2
Join Date: Aug 2010
Location: ...


Posts: 200
iTrader: (0)

Just heard from ADV1- Great customer service! I will take the car into the shop later this week, wrap up the wheels and ADV will set up a call for FedEx to come pick them up. They'll be refinished within 2 weeks and then shipped back out. Sounds like a simple case of a bad batch on the clear. Only occured on a couple sets.

Props to ADV1 for making this right!!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:44 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST