BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      01-11-2010, 01:56 PM   #1
JerezBlacke92
0
Jabowocky
 
JerezBlacke92's Avatar
 
Drives: 2008 Jerez Black
Join Date: Jul 2008
Location: Virginia

Posts: 65
iTrader: (0)

Bad thermo at 16k?

I got a check engine light on and took it into the dealer. They just called and said it looks like it needs a new thermostat. The car has (only) 16k miles on it. Anyone else see that problem? Seems kind of early to me.
JerezBlacke92 is offline   United_States
Appreciate 0
Reply With Quote
      01-11-2010, 04:24 PM   #2
bogdan
5
First Lieutenant
 
bogdan's Avatar
 
Drives: Z06
Join Date: Jan 2009
Location: Rockville, MD

Posts: 370
iTrader: (0)

Quote:
Originally Posted by JerezBlacke92 View Post
I got a check engine light on and took it into the dealer. They just called and said it looks like it needs a new thermostat. The car has (only) 16k miles on it. Anyone else see that problem? Seems kind of early to me.

I can't recall seeing this issue before. There's no timeframe for thermostat replacement, failure of materials can happen at any point.
__________________
E90 M3-gone|E92 335i-gone
Quote:
Originally Posted by Mjolnir View Post
My dog swallowed my FOB. Luckily it was Comfort Access so I could still drive the car. Of course I had to take him with me everywhere and every time he rolled over the windows went down.
bogdan is offline  
Appreciate 0
Reply With Quote
      01-11-2010, 11:47 PM   #3
bunnn
22
Colonel
 
bunnn's Avatar
 
Drives: like a grandma
Join Date: May 2009
Location: Toronto

Posts: 2,260
iTrader: (12)

In Canada(not sure about the states) ..there was a recall on the internal thermostats of 2009 E92 M3s...wonder if you got a similar issue ...it wasn't that they had a problem, but some did so all 09's were checked.
__________________
Cheers
Ben
bunnn is offline  
Appreciate 0
Reply With Quote
      01-12-2010, 10:20 PM   #4
Sleeper519
7
Captain
 
Sleeper519's Avatar
 
Drives: 08 E92 M3 DCT
Join Date: Nov 2009
Location: Atlanta, GA

Posts: 766
iTrader: (0)

My 08 E92 got a new thermostat at the 1200 mi service. Dealer said it was bad and replaced it, no prob. I thought that was kinda early too, but better now than later...
__________________

2008 M3 Coupe / DCT // StopTech BBK 380/355 / Pagid RS29 / Motul / Apex Arc-8 / BFG R1S / Ground Control / MS filter / Performance spoiler / BPM tune // Road Atlanta 1:39.80 / VIR Full 2:10.87 / Barber 1:42.20
Sleeper519 is offline   United_States
Appreciate 0
Reply With Quote
      01-13-2010, 02:41 PM   #5
elp_jc
49
Brigadier General
 
Drives: .
Join Date: May 2008
Location: .

Posts: 4,910
iTrader: (0)

Was engine overheating, or temp gauge was reading higher than normal? Just curious about any symptoms, other than the CEL, of course .
elp_jc is offline   United_States
Appreciate 0
Reply With Quote
      01-13-2010, 05:53 PM   #6
signes
43
Brigadier General
 
signes's Avatar
 
Drives: E90 M3
Join Date: Sep 2008
Location: Spinnin at 8k

Posts: 4,213
iTrader: (3)

I have a CEL intermittently for a few weeks and the dealer says they can't replicate it. I'll have the thermostat checked next time I am in. I am around 15k miles and all stock.
__________________
08 E90 | Jet Black / Black | 6MT
Mods: RAC RG63 w/ Pirelli Corsa 255F/285R | Akrapovic Evo Exhaust | OEM Blacklines
Winter Setup: OEM 18s w/ Nokian Hakkapeliita R 245/40-18
signes is offline   United_States
Appreciate 0
Reply With Quote
      01-23-2010, 11:31 AM   #7
JerezBlacke92
0
Jabowocky
 
JerezBlacke92's Avatar
 
Drives: 2008 Jerez Black
Join Date: Jul 2008
Location: Virginia

Posts: 65
iTrader: (0)

Quote:
Originally Posted by elp_jc View Post
Was engine overheating, or temp gauge was reading higher than normal? Just curious about any symptoms, other than the CEL, of course .
I just got a "Check Engine Soon" indicator.
JerezBlacke92 is offline   United_States
Appreciate 0
Reply With Quote
      01-30-2010, 11:48 PM   #8
signes
43
Brigadier General
 
signes's Avatar
 
Drives: E90 M3
Join Date: Sep 2008
Location: Spinnin at 8k

Posts: 4,213
iTrader: (3)

A quick update on my CEL. They released a software update to address an issue where the oil and coolant sensors will conflict in some way throwing an erroneous CEL. Got my whole car reprogrammed over night and now no issues. Might consider asking about it if you continue with problems that sensor replacements don't address. The fault I got was 2AFD.
__________________
08 E90 | Jet Black / Black | 6MT
Mods: RAC RG63 w/ Pirelli Corsa 255F/285R | Akrapovic Evo Exhaust | OEM Blacklines
Winter Setup: OEM 18s w/ Nokian Hakkapeliita R 245/40-18
signes is offline   United_States
Appreciate 0
Reply With Quote
      02-21-2011, 04:48 PM   #9
erio
7
Captain
 
erio's Avatar
 
Drives: e92 JB M3, 2012 GTR
Join Date: Oct 2008
Location: GA

Posts: 791
iTrader: (0)

I'm getting mine replaced after CEL came on for "increased emisions." Had o2 sensor replaced a month ago for "increased emisons." Hope this doesn't become a ongoing saga of CELs. I have about 19000 miles.
erio is offline   United_States
Appreciate 0
Reply With Quote
      02-21-2011, 07:41 PM   #10
Richbot
20
Colonel
 
Drives: Jerez Black E90
Join Date: Sep 2007
Location: STL

Posts: 2,059
iTrader: (2)

Just BMW up to its old tricks. BMW cooling systems have been subject to failure due to materials choice, weather, sunspot activity and other random phenomena for decades.
__________________
Richbot is offline  
Appreciate 0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:05 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST