BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      02-02-2011, 11:14 PM   #1
M3maniac20
Captain
M3maniac20's Avatar
United_States
13
Rep
672
Posts

Drives: 2013 BMW 335is Coupe
Join Date: Aug 2010
Location: Austin, Texas

iTrader: (0)

Homelink Question...

Anyone else have an issue with the Homelink?

I cannot get the system to pair with my garage door. On my last car I was able to program by holding the transmitter to the Homelink system. But on the M that won't work, neither will doing it from the garage door itself.

I don't know if I'm doing it wrong or not, but I'm just going to see if the BMW techs can do it when I take it in for the 1200 mile service.

Anyone have any advice?
__________________
2011.5 M3 Coupe ZCP
Appreciate 0
      02-02-2011, 11:37 PM   #2
kcdude24
First Lieutenant
3
Rep
325
Posts

Drives: 2011 M3
Join Date: Feb 2010
Location: Kansas City

iTrader: (2)

If you have a rolling code then you need to follow the steps to pair the remote and then to the unit...check the manual. I remember clearing the codes on mine by holding the 1 and 3 buttons for 30 seconds until it flashed. Then followed the procedure to recognize the remote. Then pushed the program button on the door opener unit and then pushed the homelink button to complete the programming....I always forget the step for the remote and it won't work unless you do both.
Appreciate 0
      02-02-2011, 11:37 PM   #3
elp_jc
Brigadier General
United_States
83
Rep
4,910
Posts

Drives: .
Join Date: May 2008
Location: .

iTrader: (0)

For some reason you have to put the remote right at the mirror. And I mean TOUCHING it . Oh, and make sure to use the main remote, not those mini ones; don't understand why, but the system doesn't like those. Forgot to say erase all codes first. Good luck.
Appreciate 0
      02-02-2011, 11:40 PM   #4
eedj1
New Member
United_States
0
Rep
12
Posts

Drives: '08 E90 M3 DCT
Join Date: Feb 2011
Location: Charlotte, NC

iTrader: (0)

I had the same issue with my Homelink. I reset it, then paired it with the transmitter. Next pressed the learn button on the garage door opener. Last I continued to press the Homelink button until the garage door opener responded.

Garage door opener - Genie
Homerlink 08' E90 M3 DCT
Appreciate 0
      02-02-2011, 11:58 PM   #5
M3maniac20
Captain
M3maniac20's Avatar
United_States
13
Rep
672
Posts

Drives: 2013 BMW 335is Coupe
Join Date: Aug 2010
Location: Austin, Texas

iTrader: (0)

Thanks guys! The garage door was just replaced this summer after a lightning storm totally fried the unit.

So do you have to do both-pairing with the transmitter and then through the head unit itself? Or just one of those?

Is it safe to say that all new ones [garage doors] are rolling code?
__________________
2011.5 M3 Coupe ZCP
Appreciate 0
      02-03-2011, 12:08 AM   #6
AlterZgo
Captain
59
Rep
602
Posts

Drives: 2015 BMW M3 6MT, 2010 535i 6MT
Join Date: Sep 2010
Location: Orange County, CA

iTrader: (0)

Yes - virtually all newer garage doors have rolling codes.

On my 2011 335is, I:
1. Cleared codes (even though there were none, still did this to make sure)
2. Paired remote garage door opener to button on the mirror. (This was a total bitch - it took like 20+ tries and over 30 minutes before it finally worked.)
3. Pushed the code button on the garage door opener unit itself.
4. Synced the rolling code to the button on the mirror.
Appreciate 0
      02-03-2011, 11:03 AM   #7
Georgeair
Captain
10
Rep
757
Posts

Drives: '08 Melbourne E92 M3
Join Date: Apr 2009
Location: McKinney, TX

iTrader: (2)

I too found the hard way it had to be RIGHT next to the transmitter.

Also, in case you're as stoopid as me, the car actually has to be ON, not just in accessory mode. That one took me a bit.....
__________________
Objects in mirror are slower than they appear.
Appreciate 0
      02-03-2011, 11:11 AM   #8
Vrrooom3
Private
United_States
4
Rep
79
Posts

Drives: 2009 M3
Join Date: Jan 2011
Location: Maryland

iTrader: (0)

Maybe it's a defective unit?

My sister has a 08 E92 and mine is a 09 M. I programmed my car to the garage door and when I followed the exact same directions on her car, it didn't work. It picked up the code from the garage remote and the garage receiver lights even flashed when it was programmed like it did with my M, but her homelink doesn't work.
Appreciate 0
      02-03-2011, 12:15 PM   #9
MusclezMarinara
Banned
United_States
85
Rep
5,022
Posts

Drives: VALNCYA
Join Date: Jan 2009
Location: Jersey

iTrader: (23)

Garage List
Its a difficult task to perfect but just read the manual carefully
Appreciate 0
      02-03-2011, 05:57 PM   #10
M3maniac20
Captain
M3maniac20's Avatar
United_States
13
Rep
672
Posts

Drives: 2013 BMW 335is Coupe
Join Date: Aug 2010
Location: Austin, Texas

iTrader: (0)

Thanks for the info! Finally got it to work.

Had to TOUCH the transmitter to the mirror--interesting how the manual says 4-12 inches away....I think that would have taken years of trying.
After I did that I had to push the "learn" button on the unit and then everything worked.

Thanks again for the help!
__________________
2011.5 M3 Coupe ZCP
Appreciate 0
      02-03-2011, 06:01 PM   #11
aznclickster
Second Lieutenant
aznclickster's Avatar
2
Rep
241
Posts

Drives: E92 ///M
Join Date: Aug 2010
Location: Houston, TX

iTrader: (0)

Garage List
2011.5 E92 M3  [0.00]
it was a pita to setup, but glad you got it working!
__________________
Appreciate 0
      02-03-2011, 06:25 PM   #12
persian54
Lieutenant General
persian54's Avatar
United_States
309
Rep
15,818
Posts

Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

iTrader: (292)

for me, it was a PITA at first but then I've gotten the hang of it

did it in about 2 min on the M

the z4 took over an hour

the c350 took 1 min lol
Appreciate 0
      07-03-2011, 08:59 PM   #13
tukluc
Private First Class
tukluc's Avatar
India
1
Rep
179
Posts

Drives: 2011 E90 M3
Join Date: Sep 2010
Location: Kirkland, WA

iTrader: (1)

Thanks for the post!

Hardest time doing this until I found this and actually touched the mirror with the remote. Can't believe the manual said stay 4" to 12" away from it.
Appreciate 0
      07-03-2011, 09:52 PM   #14
mdosu
Banned
No_Country
127
Rep
8,517
Posts

Drives: Double Vanos'd Civic-M3
Join Date: Oct 2009
Location: San Francisco

iTrader: (6)

Quote:
Originally Posted by Georgeair View Post
I too found the hard way it had to be RIGHT next to the transmitter.

Also, in case you're as stoopid as me, the car actually has to be ON, not just in accessory mode. That one took me a bit.....
now i feel STOOPID!!!! i'm going to try it now. I'll also try holding it next to the mirror
Appreciate 0
      07-03-2011, 10:47 PM   #15
PKL
Colonel
PKL's Avatar
37
Rep
2,468
Posts

Drives: 2011 335i
Join Date: Oct 2008
Location: Santa Monica

iTrader: (0)

I've tried twice and gave up twice will try again holding the clicker RIGHT next to the mirror
__________________
2011 E90 335i M-Sport 6MT
Appreciate 0
      07-04-2011, 01:27 AM   #16
spdy330
Major General
spdy330's Avatar
United_States
103
Rep
6,108
Posts

Drives: 05 Tundra, 11 M3, 08 Odyssey
Join Date: Dec 2009
Location: Chino, CA

iTrader: (162)

Garage List
Send a message via AIM to spdy330 Send a message via Yahoo to spdy330
Probably rolling code.
Attached Images
  
__________________
If you will be purchasing ANY AT&T services online or in store could you mention that you were referred by me? My Employee Referral ID is eo4489. This would be a great help and it costs you nothing, thank you!
Appreciate 0
      07-04-2011, 01:51 AM   #17
geneatals
Ninja
geneatals's Avatar
Philippines
47
Rep
3,210
Posts

Drives: 2011.5 E90 M3
Join Date: Dec 2007
Location: So Cal (SFV)

iTrader: (2)

took me a few tries..

for me, I had to press the "learn" button on the garage door opener base, then program the homelink button via the instructions provided. Once the light started to flash quickly (meaning the button is programmed) I had to again press the learn button on the garage door opener base and repeat the process of programming the same homelink button on the rear view mirror, only after I did this 2x consecutively did the homelink button get programmed...
__________________
2011.5 E90 M3 AW l Black Novillo Leather | Carbon Fiber Leather Trim | ZCP | ZP2 | M-DCT | Navigation | Moonroof | 6FL l Pics/Mods
Retired: 2008 535i l AW l Black Dakota Leather l Bamboo Anthracite l ZPP l ZSP l 6FL
Appreciate 0
      07-04-2011, 08:31 AM   #18
Notscott
Enlisted Member
United_States
0
Rep
32
Posts

Drives: 2008 E92
Join Date: Sep 2009
Location: South Florida

iTrader: (0)

I never could make mine work following the instructions in the manual. I followed the instructions in this video and it worked the very first time:

http://youtu.be/sbRUjmLA9ig

It's a Mercedes video but the operation is identical for BMW.
Appreciate 0
      07-04-2011, 10:42 AM   #19
immiketoo
Colonel
immiketoo's Avatar
80
Rep
2,873
Posts

Drives: Smoothly
Join Date: Apr 2009
Location: Chicago Burbs

iTrader: (0)

I just did this last week and the trick for me was to wait on the last step until the LED blinks rapidly(Just like the instructions say). The first time I did it, it blinked but slowly. You have to hold it for about five seconds, and then the rapid blink is the indicator that its worked. That and your door will go down.
__________________

Quote:
Originally Posted by double eagle View Post
Thickness feels good to me and my hands aren't that big.
Appreciate 0
      07-04-2011, 12:52 PM   #20
rye m3
Lieutenant
rye m3's Avatar
Switzerland
10
Rep
489
Posts

Drives: 2011.75 E92 M3
Join Date: Apr 2011
Location: New York

iTrader: (2)

Note number 5 in the instructions- you need to sync with the garage opener THREE times! I couldn't believe it, but when I did it multiple times it simply worked. I noticed that none of you guys caught that fine print either! Silly system.
__________________
E92 M3 MR on Red/Black ZCP Sound
Carbon

2007 997S - sold
2003 E46 M3 Steel Grey on Red- sold
1997 E36 M3 Arctic Silver on Black- sold
Appreciate 0
      07-04-2011, 02:34 PM   #21
tukluc
Private First Class
tukluc's Avatar
India
1
Rep
179
Posts

Drives: 2011 E90 M3
Join Date: Sep 2010
Location: Kirkland, WA

iTrader: (1)

Quote:
Originally Posted by rye m3 View Post
Note number 5 in the instructions- you need to sync with the garage opener THREE times! I couldn't believe it, but when I did it multiple times it simply worked. I noticed that none of you guys caught that fine print either! Silly system.
Speaking of fine print....it says to push the button 3x....not sync with the garage opener 3x.
Appreciate 0
      07-04-2011, 06:51 PM   #22
rye m3
Lieutenant
rye m3's Avatar
Switzerland
10
Rep
489
Posts

Drives: 2011.75 E92 M3
Join Date: Apr 2011
Location: New York

iTrader: (2)

Quote:
Originally Posted by tukluc View Post
Speaking of fine print....it says to push the button 3x....not sync with the garage opener 3x.
Damn, so it does! Maybe that's why it takes me 45 minutes every time as well. I'm so relieved when I finally get the thing working.
__________________
E92 M3 MR on Red/Black ZCP Sound
Carbon

2007 997S - sold
2003 E46 M3 Steel Grey on Red- sold
1997 E36 M3 Arctic Silver on Black- sold
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:35 PM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST