BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      08-15-2010, 11:41 PM   #1
Jimmer
Private First Class
Jimmer's Avatar
Canada
2
Rep
160
Posts

 
Drives: 2014 M235i with MPE
Join Date: Jan 2009
Location: Calgary, Canada

iTrader: (0)

cutting out when accelerating

Hey guys,

Experienced something on the track today I've never had before....

I'm betting this is heat related but opinions would be nice. My car was fairly hot (in Canada so gauge was reading over 125) as giving lots of rides back-to-back. Normally my sessions are 20min with a good 30min cool-down but today I went pretty hard for over an hour just pulling in to switch passengers (I always did do a cool-down lap). Towards the end of the day when I wanted to accelerate around 6000rpm my car would cut-out. It was like I was hitting the rev-limiter. After a few seconds it would come back. No light on dash.
Another instructor who's car runs hot due to mods said his does this when it's getting too hot before the warning lights come into play.

Anyone else had this?

Thanks!
__________________
Certified High Performance Driving Instructor - BMW of North America, Porsche Club of America / Chief In-Vehicle Instructor - Fleet Safety International
Gone but not forgotten: 2008 E92 M3; Eisenmann Race Exhaust / Dinan 3.62 Limited Slip Differential / Dinan Software / Dinan High-Flow Intake / Dinan Camber Plates / Dinan Lowering Springs / Dinan Sway-Bars
Appreciate 0
      08-16-2010, 03:16 AM   #2
swiss_cornholio
First Lieutenant
swiss_cornholio's Avatar
Switzerland
5
Rep
379
Posts

 
Drives: E92 DTC M3 (AW/PS)
Join Date: Mar 2007
Location: Zurich, Switzerland

iTrader: (0)

I don't know if this is an engine protection feature. I would be worried about the high temperature though. When I drive on the Nurburgring, even 5 consecutive laps on a hot summer day, the oil temp never gets above 115 C. Any mods?
Appreciate 0
      08-16-2010, 05:47 AM   #3
per
Lieutenant
Sweden
15
Rep
501
Posts

 
Drives: M3 E92
Join Date: Jul 2007
Location: Sweden Gothenburg

iTrader: (0)

Had something similar, was diagnosed as a O2 sensor problem.
An upgrade was done and the problem was solved
__________________
M3 E92 ESS VT-625
Appreciate 0
      08-17-2010, 12:55 AM   #4
Jimmer
Private First Class
Jimmer's Avatar
Canada
2
Rep
160
Posts

 
Drives: 2014 M235i with MPE
Join Date: Jan 2009
Location: Calgary, Canada

iTrader: (0)

Just had my Mass Air Sensor replaced a few weeks ago.

Anyway, thanks for the advice. It's going in on Wednesday to get checked out before my warranty expires!!
__________________
Certified High Performance Driving Instructor - BMW of North America, Porsche Club of America / Chief In-Vehicle Instructor - Fleet Safety International
Gone but not forgotten: 2008 E92 M3; Eisenmann Race Exhaust / Dinan 3.62 Limited Slip Differential / Dinan Software / Dinan High-Flow Intake / Dinan Camber Plates / Dinan Lowering Springs / Dinan Sway-Bars
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:13 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST