BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
GT Haus
View Poll Results: What is your Drivelogic startup behavior?
I have the latest DCT software and my car always goes to S mode on startup. 48 53.33%
I have the latest DCT software and my car always goes D mode on startup. 18 20.00%
I have the latest DCT software and my car does not consistently go to either mode on startup. 14 15.56%
I don't have the latest software. 10 11.11%
Voters: 90. You may not vote on this poll

Post Reply
 
Thread Tools Search this Thread
      08-06-2010, 10:45 AM   #1
mkoesel
Moderator
 
Drives: IB/PS M-DCT E93 M3
Join Date: Jun 2006
Location: Canton, MI

Posts: 12,999
iTrader: (1)

DCT default Drivelogic mode on startup

From the time I got my car in 2008 up to before I got the latest software, my car always went to S mode (S3 in particular) when I put it into gear the first time after a startup. This behavior has been discussed in many threads over the years, mostly in the context of the wish for it to be user configurable.

However, since I got the newest DCT software, it no longer consistently goes to S (S3). Now it sometimes goes into D mode instead.

If you have a car with the latest DCT Software, please report your DCT Drivelogic startup behavior.
__________________
2008 Interlagos Blue E93 M3 - M-DCT
2011 Salsa Red Jetta TDI Sportwagen - DSG
mkoesel is offline   United_States
0
Reply With Quote
      08-06-2010, 10:46 AM   #2
outie
Lieutenant
 
Drives: 2011 M3 ZCP
Join Date: Feb 2009
Location: CA

Posts: 517
iTrader: (0)

My '11 ZCP has similar behavior and I replicated it by:

1) Start car, go to R, complete (or almost) stop, then shift, it goes to S3.
2) Start car, go to R, still rolling, then shift, it goes to Dx where x=last D mode.

The 1st time I experienced 2) I thought I wasn't awake yet, so I had been observing it since then and tried to replicate. Finally got the above conclusion.
outie is offline  
0
Reply With Quote
      08-06-2010, 10:53 AM   #3
mkoesel
Moderator
 
Drives: IB/PS M-DCT E93 M3
Join Date: Jun 2006
Location: Canton, MI

Posts: 12,999
iTrader: (1)

Outie, what about if you don't go to R, such as pulling forward out of parking spot? Mine seems to hit S consistently in that case, or so I recall it.
__________________
2008 Interlagos Blue E93 M3 - M-DCT
2011 Salsa Red Jetta TDI Sportwagen - DSG
mkoesel is offline   United_States
0
Reply With Quote
      08-06-2010, 10:59 AM   #4
outie
Lieutenant
 
Drives: 2011 M3 ZCP
Join Date: Feb 2009
Location: CA

Posts: 517
iTrader: (0)

I don't normally pull forward after start, but on the occasions that I do, I have not experienced the R -> D behavior described above, but the normal S3 like yours. It appears it only occurs after R.
outie is offline  
0
Reply With Quote
      08-06-2010, 11:29 AM   #5
Bluesummer
Lieutenant General
 
Bluesummer's Avatar
 
Drives: slower than Ayrton Senna
Join Date: Dec 2006
Location: Nürburgring, be there once, your heart, your soul will stay there.

Posts: 15,368
iTrader: (13)

Garage List
2011 E82 135  [0.00]
2011 M3  [0.00]
2007 335  [0.00]
Send a message via MSN to Bluesummer
I don't rally care... What bugs me is that on the 09+ we lost the individual key programing and I have to push an extra button (EDC) every time i start up the car besides putting the DCT into S4.
__________________

R.I.P. Steve Noh
Bluesummer is offline   Taiwan
0
Reply With Quote
      08-06-2010, 12:55 PM   #6
M3luvr
Private First Class
 
M3luvr's Avatar
 
Drives: 09 M3 E90 DCT Silverstone
Join Date: Jun 2009
Location: South San Francisco

Posts: 145
iTrader: (0)

Garage List
2009 E90 M3 DCT  [0.00]
Mine has been inconsistent too after the latest update.
__________________
09 E90 MDCT Silverstone, Black Extended, Prem/Tech/Cold, Carbon Leather, 19's, Enhanced Sound, IPod, PDC, 3M clear bra, 3M tint 35% front, 20% rear, painted reflectors
M3luvr is offline   United_States
0
Reply With Quote
      08-06-2010, 01:00 PM   #7
Prowess Symphony
Major General
 
Prowess Symphony's Avatar
 
Drives: ///Mistress
Join Date: Nov 2008
Location: WV

Posts: 5,589
iTrader: (11)

Garage List
Mine always goes to S3 after start up. But sometimes after putting it into reverse, it randomly goes to either S3 or D3.
Prowess Symphony is online now   United_States
0
Reply With Quote
      08-06-2010, 04:15 PM   #8
swamp2
Major General
 
swamp2's Avatar
 
Drives: E92 M3
Join Date: Sep 2006
Location: San Diego, CA USA

Posts: 9,586
iTrader: (1)

Could an important factor be the time the car is left off between use or perhaps if the car is fully powered down or just has the engine shut off? Just brainstorming.
__________________
E92 M3 | Space Gray on Fox Red | M-DCT | CF Roof | RAC RG63 Wheels | Brembo 380mm BBK |
| Vorsteiner Ti Exhaust | Matte Black Grilles/Side Gills/Rear Emblem/Mirrors |
| Alekshop Back up Camera | GP Thunders | BMW Aluminum Pedals | Elite Angels |
| XPEL Full Front Wrap | Hardwired V1 | Interior Xenon Light Kit |
swamp2 is offline   United_States
0
Reply With Quote
      08-06-2010, 04:41 PM   #9
e1000
that's what SHE said!
 
Drives: 2011 E92 M3 ZCP
Join Date: Jun 2010
Location: OC

Posts: 1,066
iTrader: (1)

JUST got my 2011 and from what I can tell, sometimes it goes back to D, sometimes it goes back to S. One thing that I did notice that's different is that my car seems to retain it's drivelogic mode (1-5) from whatever I set it to last.
e1000 is offline  
0
Reply With Quote
      08-06-2010, 04:59 PM   #10
Crazy Bimmer
The Jesal
 
Crazy Bimmer's Avatar
 
Drives: E90 M3
Join Date: Nov 2005
Location: Chicago IL

Posts: 5,808
iTrader: (16)

Garage List
2009 BMW M3  [0.00]
Send a message via AIM to Crazy Bimmer
Depends, when was the latest software released?

My March/09 build always goes into S3
__________________
2009 E90 M3
Crazy Bimmer is online now   United_States
0
Reply With Quote
      08-06-2010, 06:06 PM   #11
Raustin
Cmd Chief
 
Raustin's Avatar
 
Drives: 2009 M3 DCT Sedan
Join Date: Dec 2009
Location: Altus AFB OK

Posts: 118
iTrader: (0)

My 09 returns to the last setting I had when I parked her?
Raustin is offline   United_States
0
Reply With Quote
      08-08-2010, 09:48 AM   #12
Radiation Joe
Veni Vidi Vici
 
Radiation Joe's Avatar
 
Drives: '11 JB/BBe-6sp-e90
Join Date: Jul 2008
Location: Macungie PA

Posts: 2,748
iTrader: (0)

Garage List
2011 e90 M3-Sold  [4.25]
2003 RS6 - Sold  [0.00]
2009 e90 M3 - Gone  [0.00]
2003 M3 SOLD  [0.00]
old 2002  [5.00]
Sorry. I can't vote in DCT polls, any more. Interesting topic. After the latest software update (May), my car became inconsistent as to which mode it would go into after starting. I thought it was just me getting old. I'm going to drive the white car tomorrow for the last time. If I remember, I'll try out the technique described above.
Radiation Joe is offline   United_States
0
Reply With Quote
      08-08-2010, 12:10 PM   #13
zamm3k
Bla!
 
zamm3k's Avatar
 
Drives: JB E90 M3
Join Date: Apr 2008
Location: Miami, FL

Posts: 831
iTrader: (4)

I have an 11'. April Build. It's default settings are D3, S3. Once I start driving and change them, whenever I change back (without having turned the car off), it goes back to the way I had set it. Mine seems pretty consistent about this.
__________________
:.-. KW .-. RPi .-. SUPERSPRINT .-. MACHT SCHNELL .-. VOSSEN .-. VREDESTEIN .-.:

zamm3k is offline   United_States
0
Reply With Quote
      08-08-2010, 04:14 PM   #14
alpina527
Banned
 
Drives: 2008 E92 M3 DCT JZB/FR
Join Date: Jan 2010
Location: London, England

Posts: 638
iTrader: (1)

My 08 always defaults to D2 every time I start it.
alpina527 is offline   United Kingdom
0
Reply With Quote
      08-08-2010, 07:43 PM   #15
BobsM3Coupe
Captain
 
Drives: M3 Coupe
Join Date: Nov 2009
Location: California

Posts: 862
iTrader: (4)

Quote:
Originally Posted by zamm3k View Post
I have an 11'. April Build. It's default settings are D3, S3. Once I start driving and change them, whenever I change back (without having turned the car off), it goes back to the way I had set it. Mine seems pretty consistent about this.
My late October 2009 built car does the same.
BobsM3Coupe is offline   United_States
0
Reply With Quote
      08-11-2010, 09:39 AM   #16
mkoesel
Moderator
 
Drives: IB/PS M-DCT E93 M3
Join Date: Jun 2006
Location: Canton, MI

Posts: 12,999
iTrader: (1)

Looks like only a select few of us are experiencing the intermitten D/S startup mode issue, and I believe outie has correctly identified the behavior.

I am at a loss as to what could cause this other than a software bug. But it seems strange that only some would be effected.
__________________
2008 Interlagos Blue E93 M3 - M-DCT
2011 Salsa Red Jetta TDI Sportwagen - DSG
mkoesel is offline   United_States
0
Reply With Quote
      08-13-2010, 11:07 AM   #17
IL8Apex
Private First Class
 
IL8Apex's Avatar
 
Drives: 2009 E92 M3 DCT, 1999 E36 M3
Join Date: Jul 2010
Location: San Diego

Posts: 108
iTrader: (3)

Mine behaves the same as outie. Only after first selecting reverse to back out of my garage, then it goes into D or S randomly.
__________________
2009 E92 M3 / DCT / AW / Black Extended / Akrapovic / Dinan Stage I + Camber Plates / BBS CH-R / Valentine One by Alekshop
IL8Apex is offline  
0
Reply With Quote
      08-13-2010, 12:20 PM   #18
mkoesel
Moderator
 
Drives: IB/PS M-DCT E93 M3
Join Date: Jun 2006
Location: Canton, MI

Posts: 12,999
iTrader: (1)

I noticed yesterday that I can get mine to go to S3 even if I am still rolling backward. It seems like if you are braking hard enough, it will go to S3 even if you don't do a full stop.

I think that the DCT software must have gotten an update after the one that fixed the lag. That's probably why a lot of folks are not seeing this update. My software was updated back in June, IIRC. I know a lot of people had theirs updated way before that.
__________________
2008 Interlagos Blue E93 M3 - M-DCT
2011 Salsa Red Jetta TDI Sportwagen - DSG
mkoesel is offline   United_States
0
Reply With Quote
      09-24-2010, 06:42 PM   #19
Michaeljh2000
Second Lieutenant
 
Michaeljh2000's Avatar
 
Drives: 2009 M3, 69 Vette, GSXR 1000
Join Date: Dec 2007
Location: NoVA

Posts: 211
iTrader: (0)

Quote:
Originally Posted by outie View Post
My '11 ZCP has similar behavior and I replicated it by:

1) Start car, go to R, complete (or almost) stop, then shift, it goes to S3.
2) Start car, go to R, still rolling, then shift, it goes to Dx where x=last D mode.

The 1st time I experienced 2) I thought I wasn't awake yet, so I had been observing it since then and tried to replicate. Finally got the above conclusion.
Man, thanks for this info. Also mkoesel for pointing me here. I just got the 2.39.1 update a few days update and am experiencing the same thing. I'm going to try an replicate your results. If its consistent as you say, I'm sure BMW will say its f*cking feature.

Anyway, the lag is gone but its annoying to have to look down to see which mode I'm in before driving away.
Michaeljh2000 is offline   United_States
0
Reply With Quote
      10-09-2010, 10:15 AM   #20
Throtex
Enlisted Member
 
Drives: 2009 E92 M3
Join Date: Mar 2009
Location: Fairfax, VA

Posts: 40
iTrader: (0)

I just had mine updated by SIB 28 01 10 ... it feels like a brand new car. Hopefully it's a permanent fix.

That said, I had to go back and reprogram a few of my settings -- remember that a few things can be set for default by clicking the iDrive knob to the right from the M Drive settings menu.

Re: Drivelogic mode, my car used to start in S3 no matter what (which was great since that's what I use on the street). But after the update, I'm seeing what others are reporting here. If I shift into D/S from R, it goes into D3. If I shift into D/S directly from P, it goes into S3. It's a bit annoying since I don't use the D modes at all, but whatever.
Throtex is offline  
0
Reply With Quote
      10-09-2010, 10:27 AM   #21
ChrisK
Brigadier General
 
ChrisK's Avatar
 
Drives: E92 M3
Join Date: Jun 2007
Location: IL

Posts: 4,816
iTrader: (4)

This is weird. My car stays in whatever I had DCT in last. D4 or S3
__________________

2011 E92 M3: AW/BLK • DCT
Europäische Lieferung am 6. August 2010
ChrisK is offline   United_States
0
Reply With Quote
      10-09-2010, 10:58 AM   #22
BigHat
Lieutenant
 
BigHat's Avatar
 
Drives: '11 M3 E93
Join Date: Jan 2010
Location: NoVa

Posts: 513
iTrader: (0)

It always goes to S3 in the S mode regardless of the last setting. D modes, on the other hand, remain in the last D mode used. April built "11
BigHat is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:50 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST