BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > BIMMERPOST Universal Forums > Off-Topic Discussions Board
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      07-31-2010, 11:48 AM   #1
.:bHd:.
Major
.:bHd:.'s Avatar
Armenia
70
Rep
1,149
Posts

 
Drives: E92 335i MT
Join Date: Feb 2008
Location: So Cal

iTrader: (0)

Uhh think my mac got a virus

Every time i turn on my computer safari opens and goes to a porn site. Has this happened to anyone? I have the latest mac osx updated and everything. It's kinda funny but worrying at the same time lol
__________________

Appreciate 0
      07-31-2010, 11:50 AM   #2
MisterSkiMask
Lieutenant Colonel
36
Rep
1,940
Posts

 
Drives: I Can not say
Join Date: Nov 2005
Location: you must not know

iTrader: (0)

I'm not your wife, I don't need your excuses.
Appreciate 0
      07-31-2010, 11:59 AM   #3
BoBinder
Private
Canada
0
Rep
60
Posts

 
Drives: E92
Join Date: Jul 2010
Location: T.Dot.OH

iTrader: (0)

Quote:
Originally Posted by MisterSkiMask View Post
I'm not your wife, I don't need your excuses.
__________________
Appreciate 0
      07-31-2010, 12:16 PM   #4
BTM
Banned
United_States
171
Rep
10,314
Posts

 
Drives: A///MERICAN!!!
Join Date: Mar 2010
Location: A///MERICA!!!

iTrader: (11)

Garage List
That's how my computer works...no viruses here
Appreciate 0
      07-31-2010, 12:51 PM   #5
Nedim
Captain
Nedim's Avatar
United_States
18
Rep
712
Posts

 
Drives: 2007 BMW 335i
Join Date: Mar 2010
Location: Des Moines, IA

iTrader: (4)

Quote:
Originally Posted by BTM View Post
That's how my computer works...no viruses here
Appreciate 0
      07-31-2010, 12:54 PM   #6
radix
you know he kills little girls like you
radix's Avatar
No_Country
56
Rep
896
Posts

 
Drives: -
Join Date: Feb 2008
Location: -

iTrader: (0)

Quote:
Originally Posted by .:bHd:. View Post
Every time i turn on my computer safari opens and goes to a porn site. Has this happened to anyone? I have the latest mac osx updated and everything. It's kinda funny but worrying at the same time lol
It's possible you downloaded a trojan. Reset Safari and see if it still happens. Additionally, make sure you're not autostarting Safari:

http://support.apple.com/kb/HT2602
Appreciate 0
      07-31-2010, 01:11 PM   #7
xtac
Alpine White Knight
xtac's Avatar
United_States
34
Rep
682
Posts

 
Drives: AW 335i M sport
Join Date: Jan 2009
Location: Long Island

iTrader: (2)

http://www.dnschanger.com/
__________________
Appreciate 0
      07-31-2010, 01:14 PM   #8
radix
you know he kills little girls like you
radix's Avatar
No_Country
56
Rep
896
Posts

 
Drives: -
Join Date: Feb 2008
Location: -

iTrader: (0)

Quote:
Originally Posted by xtac View Post
Could be. That's one of the things I was thinking of. Two quick ways to rule it out:

1. System Preferences->Network->Advanced->DNS

or open a terminal and:

Code:
$ scutil
> open
> get State:/Network/Global/IPv4
> d.show
<dictionary> {
  PrimaryInterface : en1
  PrimaryService : C471E2F9-1A03-4608-A7C6-CE3AB0EE5895
  Router : 10.0.0.1
}
> get State:/Network/Service/C471E2F9-1A03-4608-A7C6-CE3AB0EE5895/DNS
> d.show
<dictionary> {
  ServerAddresses : <array> {
    0 : 10.0.0.1
  }
  DomainName : oompa.loompa.com.
}

Last edited by radix; 07-31-2010 at 01:29 PM.
Appreciate 0
      07-31-2010, 01:58 PM   #9
burningchicken
Lieutenant
burningchicken's Avatar
8
Rep
430
Posts

 
Drives: 2007 e90 335i
Join Date: Jan 2010
Location: noVA, Virginia Tech

iTrader: (5)

maybe your friend just set it as your homepage o.O
Appreciate 0
      07-31-2010, 02:20 PM   #10
lopealle
Resident Black Guy
lopealle's Avatar
Zimbabwe
63
Rep
2,245
Posts

 
Drives: Lion
Join Date: May 2009
Location: Federal Way, WA

iTrader: (2)

Garage List
2006 M5  [5.00]
i wish my internet homepage could be set to porno. your suck lucky
Appreciate 0
      07-31-2010, 03:05 PM   #11
.:bHd:.
Major
.:bHd:.'s Avatar
Armenia
70
Rep
1,149
Posts

 
Drives: E92 335i MT
Join Date: Feb 2008
Location: So Cal

iTrader: (0)

it's not the home page. My homepage is still the same. This only happens when I turn on the computer. Safari automatically opens and goes to that site. Which looks familiar :x
__________________

Appreciate 0
      07-31-2010, 07:38 PM   #12
immiketoo
Colonel
immiketoo's Avatar
71
Rep
2,873
Posts

 
Drives: Smoothly
Join Date: Apr 2009
Location: Chicago Burbs

iTrader: (0)

Quote:
Originally Posted by .:bHd:. View Post
it's not the home page. My homepage is still the same. This only happens when I turn on the computer. Safari automatically opens and goes to that site. Which looks familiar :x
The part in red made me chuckle. I'd chalk it up to improved efficiency
__________________

Quote:
Originally Posted by double eagle View Post
Thickness feels good to me and my hands aren't that big.
Appreciate 0
      08-01-2010, 07:51 PM   #13
.:bHd:.
Major
.:bHd:.'s Avatar
Armenia
70
Rep
1,149
Posts

 
Drives: E92 335i MT
Join Date: Feb 2008
Location: So Cal

iTrader: (0)

alright I tried everything you guys said and it still happens. No trojans found by the way. I googled it turns out it happens to a lot of people. So ya this sucks
__________________

Appreciate 0
      08-01-2010, 09:02 PM   #14
lopealle
Resident Black Guy
lopealle's Avatar
Zimbabwe
63
Rep
2,245
Posts

 
Drives: Lion
Join Date: May 2009
Location: Federal Way, WA

iTrader: (2)

Garage List
2006 M5  [5.00]
you should consider yourself lucky. you got one of the better computers that knows its user.
Appreciate 0
      08-01-2010, 09:24 PM   #15
ABQ325i
Private First Class
ABQ325i's Avatar
United_States
2
Rep
158
Posts

 
Drives: 08 E60 535i + 06 E90 330i
Join Date: Apr 2010
Location: Albuquerque

iTrader: (4)

Garage List
2008 535i  [0.00]
2006 330i  [0.00]
I always knew Macs were designed with the user in mind. After a while it intuitively learns your browsing habits and now automatically goes there for you.
Appreciate 0
      08-01-2010, 09:28 PM   #16
radix
you know he kills little girls like you
radix's Avatar
No_Country
56
Rep
896
Posts

 
Drives: -
Join Date: Feb 2008
Location: -

iTrader: (0)

Quote:
Originally Posted by .:bHd:. View Post
alright I tried everything you guys said and it still happens. No trojans found by the way. I googled it turns out it happens to a lot of people. So ya this sucks
Did you follow the link I posted above to insure that safari was not autostarting? If that didn't help, open a terminal and type the following in bold at the prompt:

Code:
$ crontab -l
crontab: no crontab for xxxxxxxx
$ ls -l .bash{rc,_profile}*
ls: .bash_profile*: No such file or directory
ls: .bashrc*: No such file or directory
$ cat .profile

# MacPorts Installer addition on 2010-06-28_at_20:50:27: adding an appropriate PATH variable for use with MacPorts.
export PATH=/opt/local/bin:/opt/local/sbin:$PATH
# Finished adapting your PATH environment variable for use with MacPorts.

$ ps -ef | grep -i [s]afari
  501 40421   176   0   0:01.11 ??         0:05.39 /Applications/Safari.app/Contents/MacOS/Safari -psn_0_22152479

# Take note of the third column in red above

$ ps -p 176
  PID TTY           TIME CMD
  176 ??         0:10.23 /sbin/launchd
post the results. I know this is all complicated, but it'll help figure out what might be starting Safari. Please also sanitize your command prompt, I don't want to know your name.

Last edited by radix; 08-01-2010 at 09:43 PM.
Appreciate 0
      08-01-2010, 10:18 PM   #17
.:bHd:.
Major
.:bHd:.'s Avatar
Armenia
70
Rep
1,149
Posts

 
Drives: E92 335i MT
Join Date: Feb 2008
Location: So Cal

iTrader: (0)

Quote:
Originally Posted by radix View Post
Did you follow the link I posted above to insure that safari was not autostarting? If that didn't help, open a terminal and type the following in bold at the prompt:

Code:
$ crontab -l
crontab: no crontab for xxxxxxxx
$ ls -l .bash{rc,_profile}*
ls: .bash_profile*: No such file or directory
ls: .bashrc*: No such file or directory
$ cat .profile

# MacPorts Installer addition on 2010-06-28_at_20:50:27: adding an appropriate PATH variable for use with MacPorts.
export PATH=/opt/local/bin:/opt/local/sbin:$PATH
# Finished adapting your PATH environment variable for use with MacPorts.

$ ps -ef | grep -i [s]afari
  501 40421   176   0   0:01.11 ??         0:05.39 /Applications/Safari.app/Contents/MacOS/Safari -psn_0_22152479

# Take note of the third column in red above

$ ps -p 176
  PID TTY           TIME CMD
  176 ??         0:10.23 /sbin/launchd
post the results. I know this is all complicated, but it'll help figure out what might be starting Safari. Please also sanitize your command prompt, I don't want to know your name.
i tried and half of those commands didnt really do anything.. or im just not that good with terminal lol is there an easier way? With onyx maybe?
__________________

Appreciate 0
      08-02-2010, 12:35 PM   #18
OC 335i
General
OC 335i's Avatar
United_States
253
Rep
18,119
Posts

 
Drives: AW 335D E90
Join Date: Oct 2006
Location: Irvine/Aliso Viejo, CA

iTrader: (9)

Garage List
2007 335i  [0.00]
Send a message via AIM to OC 335i Send a message via MSN to OC 335i
u must watch a lot of porn to get a virus on your mac.

Don't you know better? You can stream shit man.
__________________

Current: 2010 Alpine White 335D LCI l 19" BBS LMs l KW V2 Coilovers l BMW Performance Grilles l MSport Front/Rear l Karbonwerke Trunk l F1 Pinnacle Tint 35% Former: E92 Space Grey 335i Latest pics
Appreciate 0
      08-02-2010, 02:17 PM   #19
.:bHd:.
Major
.:bHd:.'s Avatar
Armenia
70
Rep
1,149
Posts

 
Drives: E92 335i MT
Join Date: Feb 2008
Location: So Cal

iTrader: (0)

Quote:
Originally Posted by OC 335i View Post
u must watch a lot of porn to get a virus on your mac.

Don't you know better? You can stream shit man.
bro i was streaming lmaoo Turns out its a common bug on safari.. it's just that with my shit luck it had to be a porn site.. it couldn't be e90post or something else
__________________

Appreciate 0
      08-02-2010, 02:43 PM   #20
OC 335i
General
OC 335i's Avatar
United_States
253
Rep
18,119
Posts

 
Drives: AW 335D E90
Join Date: Oct 2006
Location: Irvine/Aliso Viejo, CA

iTrader: (9)

Garage List
2007 335i  [0.00]
Send a message via AIM to OC 335i Send a message via MSN to OC 335i
lol where were u streaming?
__________________

Current: 2010 Alpine White 335D LCI l 19" BBS LMs l KW V2 Coilovers l BMW Performance Grilles l MSport Front/Rear l Karbonwerke Trunk l F1 Pinnacle Tint 35% Former: E92 Space Grey 335i Latest pics
Appreciate 0
      08-02-2010, 03:06 PM   #21
.:bHd:.
Major
.:bHd:.'s Avatar
Armenia
70
Rep
1,149
Posts

 
Drives: E92 335i MT
Join Date: Feb 2008
Location: So Cal

iTrader: (0)

youjizz
__________________

Appreciate 0
      08-02-2010, 03:34 PM   #22
OC 335i
General
OC 335i's Avatar
United_States
253
Rep
18,119
Posts

 
Drives: AW 335D E90
Join Date: Oct 2006
Location: Irvine/Aliso Viejo, CA

iTrader: (9)

Garage List
2007 335i  [0.00]
Send a message via AIM to OC 335i Send a message via MSN to OC 335i
damn. try turning Private browsing on, it might eliminate anything from being saved to your browser. It does not prevent cookies though, which has to be done manually.

Disclaimer: This is purely IT advice.
__________________

Current: 2010 Alpine White 335D LCI l 19" BBS LMs l KW V2 Coilovers l BMW Performance Grilles l MSport Front/Rear l Karbonwerke Trunk l F1 Pinnacle Tint 35% Former: E92 Space Grey 335i Latest pics
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:11 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST