BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Racewerkz Engineering
Post Reply
 
Thread Tools Search this Thread
      02-18-2010, 10:09 PM   #1
808E90
808E90
 
808E90's Avatar
 
Drives: E90 ///M
Join Date: Aug 2008
Location: Aloha State

Posts: 4,019
iTrader: (21)

VANOS Problems ... Anyone else?

I was on my way to work last saturday and only got a block down the road when I got the famous ... Engine Malfunction, Reduce power and all the good stuff

I got the car are towed in on tuesday and the first call I got from my SA was "This is just an update but as of right now we are still running test" I started thinking that it may be the Idle Valve but I got another update call today. Looks like its a VANOS problem. Anyone else run into this problem?
808E90 is offline   United_States
0
Reply With Quote
      02-18-2010, 11:40 PM   #2
xxe92xx
Banned
 
Drives: 08 M3
Join Date: Oct 2008
Location: Milwaukee, WI

Posts: 783
iTrader: (2)

Quote:
Originally Posted by 808E90 View Post
I was on my way to work last saturday and only got a block down the road when I got the famous ... Engine Malfunction, Reduce power and all the good stuff

I got the car are towed in on tuesday and the first call I got from my SA was "This is just an update but as of right now we are still running test" I started thinking that it may be the Idle Valve but I got another update call today. Looks like its a VANOS problem. Anyone else run into this problem?
hmmm well ill guess its the idle valve...highly doubt its vanos, what else did the SA say?
xxe92xx is offline  
0
Reply With Quote
      02-19-2010, 12:13 AM   #3
rsmamg
Flying First Class
 
Drives: M
Join Date: Sep 2008
Location: CA

Posts: 584
iTrader: (0)

i recently had my idle actuator replaced. 08 e92
rsmamg is offline   United_States
0
Reply With Quote
      02-19-2010, 12:29 AM   #4
808E90
808E90
 
808E90's Avatar
 
Drives: E90 ///M
Join Date: Aug 2008
Location: Aloha State

Posts: 4,019
iTrader: (21)

Quote:
Originally Posted by xxe92xx View Post
hmmm well ill guess its the idle valve...highly doubt its vanos, what else did the SA say?
On tuesday he first said that the tech had no idea what was wrong with the car ... Then I got a call from my SA today telling me that they did a bunch of testing and the tech/computer is showing signs of a VANOS Solenoid Malfunction.

The car only has 2900 miles on it and only has a axle back exhaust.
808E90 is offline   United_States
0
Reply With Quote
      02-19-2010, 01:06 AM   #5
xxe92xx
Banned
 
Drives: 08 M3
Join Date: Oct 2008
Location: Milwaukee, WI

Posts: 783
iTrader: (2)

Quote:
Originally Posted by 808E90 View Post
On tuesday he first said that the tech had no idea what was wrong with the car ... Then I got a call from my SA today telling me that they did a bunch of testing and the tech/computer is showing signs of a VANOS Solenoid Malfunction.

The car only has 2900 miles on it and only has a axle back exhaust.
so the car was driveable, but the engine malfunction was displayed...did u stop the car and start it up again? if i were you and if the car is drivable i would take it to a different dealership (if theres another one close in your area) and get a second opinion...there could be a chance its nothing, but if it is a "VANOS Solenoid Malfunction" then the warranty will cover it...but i dont trust the dealership so make sure you record the mileage and get the paperwork

best of luck
xxe92xx is offline  
0
Reply With Quote
      02-19-2010, 01:47 AM   #6
808E90
808E90
 
808E90's Avatar
 
Drives: E90 ///M
Join Date: Aug 2008
Location: Aloha State

Posts: 4,019
iTrader: (21)

Quote:
Originally Posted by xxe92xx View Post
so the car was driveable, but the engine malfunction was displayed...did u stop the car and start it up again? if i were you and if the car is drivable i would take it to a different dealership (if theres another one close in your area) and get a second opinion...there could be a chance its nothing, but if it is a "VANOS Solenoid Malfunction" then the warranty will cover it...but i dont trust the dealership so make sure you record the mileage and get the paperwork

best of luck
The car was driveable but it wouldn't really hold its idle and that was why I thought it was the Idle Valve. I turned the car on and off a few times but nothing changed.
BMW of Honolulu is the only dealer we have here on the island lol!! I really have no choice ... The SA I now have is a friend of a friend and he has been really nice and helpful. Just kinda sucks that this happens when I didn't even have the car for a year let alone pass 5000 miles
808E90 is offline   United_States
0
Reply With Quote
      02-19-2010, 02:09 AM   #7
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,648
iTrader: (7)

Garage List
2008 BMW M3  [5.00]
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Haven't heard of any vanos issues with the E9x M3, but a lot of earlier M's had a vanos noise problem. I had a customer last week with an E39 M5 who had the vanos controler on bank 1 malfunction causing the car to misfire like crazy.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote
      02-19-2010, 02:47 AM   #8
powertrip
Scared money don't make money.
 
powertrip's Avatar
 
Drives: 2009 E92 M3 DCT
Join Date: Apr 2009
Location: Irvine, CA

Posts: 1,458
iTrader: (3)

Garage List
2009 E92 M3  [0.00]
There was one guy out in Arizona that had a VANOS issue on his e92. Pretty sure he was having the same issues you are. If I remember right BMW ended up replacing quite a bit of parts in the VANOS system.
__________________
2009 E92 M3/DCT/Alpine White/Fox Red/Carbon Leather
OE Tuned 402 whp & 303 wtq/Gintani X-pipe/MXP Axle Back/Rogue Pulley/AFE Stage 2/Cosmetics By IND & EAS
HUGE THANKS: Gintani, OE Tuning, and EAS
powertrip is offline  
0
Reply With Quote
      02-19-2010, 03:16 AM   #9
saeedg48
Brigadier General
 
Drives: 12 CLS63 + 14 M6 C
Join Date: Nov 2008
Location: Unknown

Posts: 3,499
iTrader: (1)

It sounds like an idle valve to me..
__________________


2008 M3 Sedan + TestPipes + Tune [sold]

2012 CLS63 AMG + P30 Performance Package
2014 M6 Coupe + AMS Downpipes + KW V3
saeedg48 is offline   Iran
0
Reply With Quote
      02-19-2010, 11:25 AM   #10
elp_jc
Brigadier General
 
Drives: .
Join Date: May 2008
Location: .

Posts: 4,910
iTrader: (0)

Another vote for the idle valve. I remember reading another case just like yours, with the same wrong assumption, and it was the idle valve. That doesn't mean they're wrong, but it's highly likely IMO. Problem with today's techs is they only know what the computer tells them, and we all here know it's not clear with the idle valve. You have EXACTLY all the symptoms of the idle valve, so I'd force them to do it. Tell them you had the idle malfunction before to force the issue if necessary. It's also known not to trigger codes every time. Good luck, and keep us posted.
elp_jc is offline   United_States
0
Reply With Quote
      02-19-2010, 02:07 PM   #11
808E90
808E90
 
808E90's Avatar
 
Drives: E90 ///M
Join Date: Aug 2008
Location: Aloha State

Posts: 4,019
iTrader: (21)

Quote:
Originally Posted by Mike@Powerchip View Post
Haven't heard of any vanos issues with the E9x M3, but a lot of earlier M's had a vanos noise problem. I had a customer last week with an E39 M5 who had the vanos controler on bank 1 malfunction causing the car to misfire like crazy.
Yup ... My car had a bad misfire

Quote:
Originally Posted by powertrip View Post
There was one guy out in Arizona that had a VANOS issue on his e92. Pretty sure he was having the same issues you are. If I remember right BMW ended up replacing quite a bit of parts in the VANOS system.
Oh great ...

Quote:
Originally Posted by saeedg48 View Post
It sounds like an idle valve to me..
I know ... I'm thinking the same thing too.

Quote:
Originally Posted by elp_jc View Post
Another vote for the idle valve. I remember reading another case just like yours, with the same wrong assumption, and it was the idle valve. That doesn't mean they're wrong, but it's highly likely IMO. Problem with today's techs is they only know what the computer tells them, and we all here know it's not clear with the idle valve. You have EXACTLY all the symptoms of the idle valve, so I'd force them to do it. Tell them you had the idle malfunction before to force the issue if necessary. It's also known not to trigger codes every time. Good luck, and keep us posted.
When I asked my SA about the testing that they were doing ... He said the computer was asking them to check the oil pressure He told me that the computer was shooting a few codes and they were taking each step ... one test at a time. He also said there was no codes in regards to the Idle Valve. I'll be going to the dealer to pick up a loaner today so I'll see if I can talk to the tech.

Thanks guys ... and yes I will post an update.
808E90 is offline   United_States
0
Reply With Quote
      03-09-2010, 07:12 AM   #12
tem0618
Private First Class
 
Drives: E92 M3
Join Date: Jul 2006
Location: Philippines

Posts: 153
iTrader: (4)

Special Tools needed

Good day...

I need some special tools for the vanos system of my e92 m3

Tool part no. 119970

can anyone point me to thr\e right direction how to acquire this tool.

thanks
__________________

CF hood, CF Trunk, Supersprint Exhaust (x-pipes/mufflers) Active Autowerke pulley, Active Autowerke SSK, Brembo BBK, DPE S-10
tem0618 is offline  
0
Reply With Quote
      03-09-2010, 10:03 AM   #13
Nawaaz
Brigadier General
 
Drives: .
Join Date: Apr 2009
Location: .

Posts: 4,643
iTrader: (0)

Quote:
Originally Posted by tem0618 View Post
Good day...

I need some special tools for the vanos system of my e92 m3

Tool part no. 119970

can anyone point me to thr\e right direction how to acquire this tool.

thanks
Threads merged so that it may help the overall topic.
Nawaaz is offline   United_States
0
Reply With Quote
      03-09-2010, 12:33 PM   #14
niterider
Proove It!
 
Drives: Gintani Supercharged
Join Date: Dec 2008
Location: City of Angels

Posts: 633
iTrader: (0)

Quote:
Originally Posted by 808E90 View Post

When I asked my SA about the testing that they were doing ... He said the computer was asking them to check the oil pressure He told me that the computer was shooting a few codes and they were taking each step ... one test at a time. He also said there was no codes in regards to the Idle Valve. I'll be going to the dealer to pick up a loaner today so I'll see if I can talk to the tech.

Thanks guys ... and yes I will post an update.
Just FYI, most SAs dont know what they are talking about. Their is like the 10% out their that actually worked on cars at sometime in their life. But most of them are just salesman. For all u know he hasnt even spoke to the tech yet. Im sure they will address ur problem. It does sound like an Idle air valve problem but u never know, anything is possible with a BMW, doesnt mean they are bad cars just that they have so many computers, modules, sensor etc. They will go bad sometimes, but good luck and again dont worry ur car will be fixed and im pretty sure an axle back exhaust had nothing to do with it.
__________________
niterider is offline  
0
Reply With Quote
      03-09-2010, 12:34 PM   #15
elp_jc
Brigadier General
 
Drives: .
Join Date: May 2008
Location: .

Posts: 4,910
iTrader: (0)

Quote:
Originally Posted by tem0618 View Post
I need some special tools for the vanos system of my e92 m3
Whatya doin??
elp_jc is offline   United_States
0
Reply With Quote
      03-09-2010, 12:35 PM   #16
niterider
Proove It!
 
Drives: Gintani Supercharged
Join Date: Dec 2008
Location: City of Angels

Posts: 633
iTrader: (0)

Quote:
Originally Posted by tem0618 View Post
Good day...

I need some special tools for the vanos system of my e92 m3

Tool part no. 119970

can anyone point me to thr\e right direction how to acquire this tool.

thanks
as far as special tools, u need to contact BMW parst dept. They can normally order them for u. Their is a few private companies out there that make replica special tools that work, but they normally take a few years to make the newer tools.
__________________
niterider is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:31 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST