BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Evolve Automotive
Post Reply
 
Thread Tools Search this Thread
      02-17-2010, 01:23 PM   #1
MShao825
Go Terps!
MShao825's Avatar
20
Rep
1,377
Posts

 
Drives: 2009 SSII/FR E92 M3
Join Date: Dec 2006
Location: Jersey City, NJ Gaithersburg, MD

iTrader: (2)

Thumbs up Fabspeed X-Pipe with HFC's Review

This past Monday, I celebrated my Presidentís Day off by visiting Fabspeed in Ambler, PA to take part in the Tri-State Powerchip GB. I was so impressed with Fabspeedís top notch shop that I felt it warranted a thread dedicated just to them. You can see my Powerchip review here: http://www.m3post.com/forums/showthread.php?t=352617

My 1st impression of Fabspeed was that their customer service was warm and welcoming. Their shop has a big screen HDTV and ping pong table. Too bad I couldnít show off my 8-time AAU Junior Olympic/Junior National champion table tennis skills to anyone though as everyone was pretty tied up. As for the install, I wasnít in their shop while the install was done, but it didnít take them long at all. When it was installed and my car was flashed for my Powerchip tune, I was finally able to experience the anticipated new sound and added power.

The moment I started the car, the very 1st thing I noticed was that at idle, my car was the exact same loudness as it was with just my Eisenmann Race exhaust installed. There was no difference whatsoever, which was an unexpected, but pleasant, surprise. I told Alex at Fabspeed that it sounds the exact same, to which he replied with a sly grin ďjust rev it a bit.Ē The moment I did, all I could do was giggle like a little schoolgirl, which was embarrassing, but something Iím sure Fabspeed gets ALL the time. On my drive home, I noticed that at idle and at cruising speeds, my car isnít much louder than with just the Eisenmann Race, if at all. However, at WOT, the car just screams and screams and screams It definitely went from more of an American muscle sound with just the Eisenmann Race to a more exotic sound with the Fabspeed goodies installed. My buddy said it sounds like a pure racecar, and even related it to a Nascar car. My other buddy just drove it around the parking lot outside our office and revved it to about 7500 RPM, and came back and dropped off my keys back to me and told me ďit sounds EXCELLENT!Ē

I certainly had concerns with the new setup being too loud, as Iím sure many of you do as well. I was warned countless times that an Eisenmann Sport would be better, and that the Eisenmann Race would prove to be unbearable. However, the way I look at it is that the car is no louder than it used to be at idle and cruising speeds, and does not drone any more than it used to. When I step on it is when itís truly loud, but isnít that when we want our cars to scream anyway? With that being said, I have absolutely no regrets keeping my Eisenmann Race with the Fabspeed X-Pipe with HFCís.

If youíre on the fence for one reason or another about getting the Fabspeed setup, let me tell you that you wonít be disappointed. In addition to the sound, the car has so much more low end torque and just feels more powerful throughout the entire rev range, which everyone already knows about. If youíre looking for a sound or performance upgrade, it doesnít get any better than this.

Thanks again to the guys at Fabspeed for their hospitality and professionalism. It was a pleasure meeting Jay, Alex, and Jeremy, and I look forward to stopping by in the future
__________________
Appreciate 0
      02-17-2010, 06:41 PM   #2
BimmerRob08
Major
BimmerRob08's Avatar
United_States
22
Rep
1,257
Posts

 
Drives: 2008 M3, Space Gray
Join Date: Mar 2008
Location: KIKR (ABQ), NM

iTrader: (0)

Nice feed back. Glad you are enjoying the Fabspeed. I ended up getting the Encore x-pipe with HFC and Remus Sport and love it equally. I thought about going with the Remus Race but the Sport sounds real nice with an x-pipe. Most definatly you are right about the torque and power at low rpm's and through the entire rpm rage. Mine screams like mad ape at WOT. Got the CEL once, dealer turned it off, good to go for now. Post some sound clips when you can. Like to hear it.
Appreciate 0
      02-17-2010, 06:53 PM   #3
DevJ
Colonel
DevJ's Avatar
35
Rep
2,712
Posts

 
Drives: '14 Cayman S/IS350/RRS
Join Date: Nov 2007
Location: Tulsa, OK

iTrader: (1)

Thank you for the review! I also have the eisenmann race and have been wondering about how it would be with HFCs and an xpipe. Any videos? enjoy the new mods!
__________________
E92 M3. SOLD
New: '14 Cayman S PDK
Incoming: GT-R Black Edition
Appreciate 0
      02-17-2010, 06:55 PM   #4
KiokenM3
Lieutenant Colonel
KiokenM3's Avatar
25
Rep
1,507
Posts

 
Drives: LIFTED JEEP JK!
Join Date: Dec 2008
Location: LA

iTrader: (4)

what about the hp?
Appreciate 0
      02-17-2010, 07:43 PM   #5
DoNDoN
Colonel
DoNDoN's Avatar
Thailand
28
Rep
2,038
Posts

 
Drives: 2008 E92 M3 AW
Join Date: Jun 2008
Location: NoVA

iTrader: (1)

Quote:
Originally Posted by DevJ View Post
Thank you for the review! I also have the eisenmann race and have been wondering about how it would be with HFCs and an xpipe. Any videos? enjoy the new mods!
Here is what mine sounded like after going to Fabspeed.

__________________
Appreciate 0
      02-17-2010, 08:29 PM   #6
M3Alpine
Major
M3Alpine's Avatar
20
Rep
1,471
Posts

 
Drives: e92 M3 AW/FR
Join Date: Feb 2006
Location: Central NJ

iTrader: (11)

Dam dondon car looks and sounds excellent ! OP glad to hear everything went well
__________________
2002 AW/IR : Sold
2004 AW/BLK : Sold
2009 AW/FR : Sold
Appreciate 0
      02-17-2010, 10:41 PM   #7
DevJ
Colonel
DevJ's Avatar
35
Rep
2,712
Posts

 
Drives: '14 Cayman S/IS350/RRS
Join Date: Nov 2007
Location: Tulsa, OK

iTrader: (1)

Quote:
Originally Posted by DoNDoN View Post
Here is what mine sounded like after going to Fabspeed.
Thanks, I have had it favorited on my YouTube for awhile now Always like to hear more sound clips! No one close by has this set up, but it sounds so good
__________________
E92 M3. SOLD
New: '14 Cayman S PDK
Incoming: GT-R Black Edition
Appreciate 0
      02-20-2010, 02:17 PM   #8
tomvcarter
First Lieutenant
tomvcarter's Avatar
United Kingdom
17
Rep
348
Posts

 
Drives: bmw E92 M3
Join Date: Jan 2009
Location: LONDON, UK

iTrader: (0)

Send a message via MSN to tomvcarter
Im thinking of adding an x-pipe to my Eisenmann Race, is Fabspeed the best option?
Appreciate 0
      02-20-2010, 02:29 PM   #9
LV-E92M3
Lieutenant
LV-E92M3's Avatar
Afghanistan
6
Rep
505
Posts

 
Drives: Donkey
Join Date: Apr 2009
Location: كابول‎

iTrader: (1)

Quote:
Originally Posted by tomvcarter View Post
Im thinking of adding an x-pipe to my Eisenmann Race, is Fabspeed the best option?
It doesn't pop up the engin cheek light and makes pretty good power.
Appreciate 0
      02-20-2010, 06:09 PM   #10
MCarRacr07
Private First Class
1
Rep
131
Posts

 
Drives: F80 M3 in transit
Join Date: Sep 2009
Location: NY

iTrader: (0)

CEL Light

I have the Fabspeed set-up (HFC & X-Pipe) and it sounds GREAT...and that is just going into stock cans....However!...after about 100 miles the CEL was thrown.....we read the code(Secondary O2 cat sensors)....re-set it and I dorve away.....about another 100 miles later give or take the CEL light was thrown again....check the code...same code....called Fabspeed and they sent us extenders for the sensors.....they have been installed and so far so good
I can only imagine the sound of an Eisenmann Race w/this set-up as I had Headers/HFC's/X-Pipe & Eisenmann Race on my E39M5 and it was AMAZING!!
To the guys at Fabspeed...will you be coming to NY anytime soon for tunes?
Regards
S
Appreciate 0
      02-21-2010, 05:12 AM   #11
yoko
New Member
0
Rep
5
Posts

 
Drives: 2107 Alpine White
Join Date: Nov 2008
Location: Russia SAMARA

iTrader: (0)

Sound! cool!
hp?
Appreciate 0
      02-26-2010, 12:47 PM   #12
dogears
My master volume goes to 11
dogears's Avatar
8
Rep
424
Posts

 
Drives: 2009 Space Gray M3 Sedan M-DCT
Join Date: Dec 2008
Location: Cherry Hill, NJ

iTrader: (0)

CEL will eventually always come on, IMO.

It took about 2500 miles for me, but it happened. I wound up using my tune to keep the light off.

Car running really good still!
__________________
2009 Space Gray Carbon Leather E90 with DCT, Tech package, and EPS. Mods: Fabspeed 200 cell cats, Xpipe w/resonators and no secondary cats, BPM tune, Euro DCT software, Eisenmann Sport Mufflers, Vorsteiner Rear Diffuser II, SWS8 subs, JL Audio XD400 bridged 2X200W, built in radar
Appreciate 0
      02-26-2010, 01:01 PM   #13
Robwe46m3
Banned
Canada
6
Rep
194
Posts

 
Drives: 2010 E92 Ruby Blk M3 Individua
Join Date: Jul 2009
Location: 2010 Olymipiads

iTrader: (0)

Dont know why people keep giving money to Fabspeed for this product! it is advertised as "NO CEL". You DO get CEL and Fabspeed does not remedy this or discount the product in any way.
Appreciate 0
      02-26-2010, 01:36 PM   #14
J08M3
Major General
J08M3's Avatar
United_States
102
Rep
6,012
Posts

 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

iTrader: (8)

CEL goes away on its own. Mine did. Fabspeed did however send me the O2 extenders, but you have to take the damn system down in order to install them.... which kinda blows. More work than I want to put back into it. If it comes on again, I'll just keep driving till it goes off again. I guess that's what happens when you run a cat that's right on the edge.
__________________
Appreciate 0
      02-26-2010, 03:23 PM   #15
LV-E92M3
Lieutenant
LV-E92M3's Avatar
Afghanistan
6
Rep
505
Posts

 
Drives: Donkey
Join Date: Apr 2009
Location: كابول‎

iTrader: (1)

Quote:
Originally Posted by J08M3 View Post
CEL goes away on its own. Mine did. Fabspeed did however send me the O2 extenders, but you have to take the damn system down in order to install them.... which kinda blows. More work than I want to put back into it. If it comes on again, I'll just keep driving till it goes off again. I guess that's what happens when you run a cat that's right on the edge.
how many miles have you drove?
damn.. I drove mine for 300 miles and never had a light on
Appreciate 0
      02-26-2010, 03:48 PM   #16
Fen335i
Captain
Fen335i's Avatar
25
Rep
803
Posts

 
Drives: e92 M3 / X5d / Z4 M Roadster
Join Date: Jun 2008
Location: Pacific Northwest

iTrader: (0)

does anyone have a DIY on installing the 02 extenders and xpipe/HFC's? Are the 02 extenders proven to work as advertised?
Appreciate 0
      02-26-2010, 05:02 PM   #17
Ben335
Captain
Ben335's Avatar
12
Rep
891
Posts

 
Drives: 09 M3 Finally here
Join Date: Jul 2008
Location: Virginia

iTrader: (2)

Quote:
Originally Posted by Fen335i View Post
does anyone have a DIY on installing the 02 extenders and xpipe/HFC's? Are the 02 extenders proven to work as advertised?
They still will trigger CELs, it only works to delay it.
__________________
09 SG E90, Black on Carbon Leather, Tech, Premium, Cold, iPod, Premium Sound, 19s, OEM Alarm, PDC, Moonroof, Sirius
Eisenmann Sport / Eibach Springs / 35% F1 Pinnacle Tint / Macht Schnell Air Filter / LUX Angel Eyes / Black Grill / AA Pulley / Powerchip Stage II Tune / Fabspeed X-Pipe & HFC / RAC Monolites RG63
Appreciate 0
      02-26-2010, 07:48 PM   #18
J08M3
Major General
J08M3's Avatar
United_States
102
Rep
6,012
Posts

 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

iTrader: (8)

Quote:
Originally Posted by LV-E92M3 View Post
how many miles have you drove?
damn.. I drove mine for 300 miles and never had a light on
almost 4,000 before first one, then 600 for second one. It clears itself though, nothing to worry about, just gotta make sure it's not there when it's time for inspection.
__________________
Appreciate 0
      02-26-2010, 08:16 PM   #19
pumper206
80 Deep, We All Eat!!!
pumper206's Avatar
Taiwan
12
Rep
622
Posts

 
Drives: 2009 AW E92 M3
Join Date: Feb 2009
Location: Seattle,Wa

iTrader: (5)

I have fabspeed x-pipes w/o resonators and have driven my car for approx. 6-7,000 miles with it and NO CEL... I wonder why? Didn't even use the O2 extenders you guys are talking about. Could it have something to do with installation? I mean it's not just plug and play. You actually have to cut the stock x-pipe out and replace it with the fabspeed one. I would be interested to know if the exact position of the x-pipe(positioning) has something to do with the CEL coming on. I've had 0 CEL issues thus far and I'm at approx. 11,000 miles right now.
Appreciate 0
      02-26-2010, 08:27 PM   #20
Ben335
Captain
Ben335's Avatar
12
Rep
891
Posts

 
Drives: 09 M3 Finally here
Join Date: Jul 2008
Location: Virginia

iTrader: (2)

Quote:
Originally Posted by pumper206 View Post
I have fabspeed x-pipes w/o resonators and have driven my car for approx. 6-7,000 miles with it and NO CEL... I wonder why? Didn't even use the O2 extenders you guys are talking about. Could it have something to do with installation? I mean it's not just plug and play. You actually have to cut the stock x-pipe out and replace it with the fabspeed one. I would be interested to know if the exact position of the x-pipe(positioning) has something to do with the CEL coming on. I've had 0 CEL issues thus far and I'm at approx. 11,000 miles right now.
Replacing only the Xpipe will never cause a CEL. Only if you change or remove the main set of Catalytic converters will you have issues with CEL. The O2 sensors that monitor things sit before and after the main cats coming right off the headers. That is why you have no issues with CELs as you have only done your Xpipe.

The Fabspeed HFC and Xpipe WILL Definitely throw CELS. It is just a matter of time as to when you actually get them. It depends on a lot of factors, like driving style, throttle position, etc..... Honestly, it is kind of annoying that Fabspeed still claims that it does not cause CELs and they disappeared off this board both as a sponsor and responding to anyone getting CELs. The only way around it is to tune it out or be willing to clear the code anytime it comes up.
__________________
09 SG E90, Black on Carbon Leather, Tech, Premium, Cold, iPod, Premium Sound, 19s, OEM Alarm, PDC, Moonroof, Sirius
Eisenmann Sport / Eibach Springs / 35% F1 Pinnacle Tint / Macht Schnell Air Filter / LUX Angel Eyes / Black Grill / AA Pulley / Powerchip Stage II Tune / Fabspeed X-Pipe & HFC / RAC Monolites RG63
Appreciate 0
      02-27-2010, 02:30 AM   #21
Fen335i
Captain
Fen335i's Avatar
25
Rep
803
Posts

 
Drives: e92 M3 / X5d / Z4 M Roadster
Join Date: Jun 2008
Location: Pacific Northwest

iTrader: (0)

Quote:
Originally Posted by Ben335 View Post
Replacing only the Xpipe will never cause a CEL. Only if you change or remove the main set of Catalytic converters will you have issues with CEL. The O2 sensors that monitor things sit before and after the main cats coming right off the headers. That is why you have no issues with CELs as you have only done your Xpipe.

The Fabspeed HFC and Xpipe WILL Definitely throw CELS. It is just a matter of time as to when you actually get them. It depends on a lot of factors, like driving style, throttle position, etc..... Honestly, it is kind of annoying that Fabspeed still claims that it does not cause CELs and they disappeared off this board both as a sponsor and responding to anyone getting CELs. The only way around it is to tune it out or be willing to clear the code anytime it comes up.
Good info...thanks. Assuming you can clear the CEL whenever it pops up from time to time w/the HFC's...is there any risk of damage to the engine? My assumption is no...it's just the smog it's reading that's causing the CEL I'm thinking of just doing this anyway, but want to be sure there's no long term damage to the motor to worry about.....I wouldn't be doing an ECU tune (that would effectively remove the CEL permanently) for some time down the road.
Appreciate 0
      02-27-2010, 04:27 AM   #22
pumper206
80 Deep, We All Eat!!!
pumper206's Avatar
Taiwan
12
Rep
622
Posts

 
Drives: 2009 AW E92 M3
Join Date: Feb 2009
Location: Seattle,Wa

iTrader: (5)

Quote:
Originally Posted by Ben335 View Post
Replacing only the Xpipe will never cause a CEL. Only if you change or remove the main set of Catalytic converters will you have issues with CEL. The O2 sensors that monitor things sit before and after the main cats coming right off the headers. That is why you have no issues with CELs as you have only done your Xpipe.

The Fabspeed HFC and Xpipe WILL Definitely throw CELS. It is just a matter of time as to when you actually get them. It depends on a lot of factors, like driving style, throttle position, etc..... Honestly, it is kind of annoying that Fabspeed still claims that it does not cause CELs and they disappeared off this board both as a sponsor and responding to anyone getting CELs. The only way around it is to tune it out or be willing to clear the code anytime it comes up.
Oooooo. That's why. Thanks.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:13 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST