BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Post Reply
 
Thread Tools Search this Thread
      10-26-2009, 06:25 PM   #1
wea
Private
6
Rep
74
Posts

 
Drives: 2012 Porsche Cayman R
Join Date: Jan 2009
Location: Austin, TX

iTrader: (2)

EDC Malfunction - Eibach Pro Kit on e90 M3

Well I got the dreaded EDC Malfunction this morning. I disconnected the negative battery terminal; then cleaned, inspected and verified all the EDC connections on the front dampers. Then I reconnected the negative battery terminal and the malfunction persisted. I even repeated all the steps just to be sure. I then called Eibach to see if they had any additional troubleshooting steps. Unfortunately they did not, nor had they heard of any EDC problems with their M3 Pro Kit. I also called my local performance shop, Soulspeed, that did my alignment. (I did the spring install myself on Aug 9th.) Soulspeed agreed that I had followed the correct steps and I should contact the dealer.

Now I'm left with calling the dealer and I'm a little concerned that if a damper failed they will point the finger at Eibach and that will not go too well. I'm hoping it is just a sensor failure.

I have seen a lot of EDC Malfunction posts but none that are too specific on the resolution from BMW. So if anyone has any insight it would appreciated it.

Worst case, I will have to tell the wife a new set of Motons are the only cure.
__________________
Favorite Quote on Supercars: "They are designed to melt ice caps, kill the poor, poison the water table, destroy the ozone layer, decimate indigenous wildlife, recapture the Falkland islands, and turn the entire third world into a huge uninhabitable desert... but only after they nicked all the oil." Jeremy Clarkson from Top Gear 05x02 @ 48:55.
Appreciate 0
      10-26-2009, 06:36 PM   #2
Technic
Lieutenant General
Technic's Avatar
United_States
172
Rep
11,190
Posts

 
Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Garage List
2004 M3  [0.00]
Quote:
Originally Posted by wea View Post
Well I got the dreaded EDC Malfunction this morning. I disconnected the negative battery terminal; then cleaned, inspected and verified all the EDC connections on the front dampers. Then I reconnected the negative battery terminal and the malfunction persisted. I even repeated all the steps just to be sure. I then called Eibach to see if they had any additional troubleshooting steps. Unfortunately they did not, nor had they heard of any EDC problems with their M3 Pro Kit. I also called my local performance shop, Soulspeed, that did my alignment. (I did the spring install myself on Aug 9th.) Soulspeed agreed that I had followed the correct steps and I should contact the dealer.

Now I'm left with calling the dealer and I'm a little concerned that if a damper failed they will point the finger at Eibach and that will not go too well. I'm hoping it is just a sensor failure.

I have seen a lot of EDC Malfunction posts but none that are too specific on the resolution from BMW. So if anyone has any insight it would appreciated it.

Worst case, I will have to tell the wife a new set of Motons are the only cure.
So no faults between Aug 9 and just today? What else has been done to the suspension?
Appreciate 0
      10-26-2009, 06:36 PM   #3
gthirtyfizle
Colonel
gthirtyfizle's Avatar
82
Rep
2,807
Posts

 
Drives: E92 M3 AW
Join Date: Jul 2008
Location: NYC

iTrader: (4)

Ur worst case sounds like the best option to me lol. If I were u i would make belive they r forever ruined and just go ahead and get the motons lol.

HOWEVER, If u dont feel like shelling out the 5+K the I suggest just looking over the install. Pretty confident something is loose.
Appreciate 0
      10-26-2009, 07:01 PM   #4
FStop7
I like cars
FStop7's Avatar
Vatican City State
96
Rep
5,059
Posts

 
Drives: M6
Join Date: Oct 2008
Location: Newbury Park, CA

iTrader: (3)

I really doubt you have a shock failure, especially so soon. Either one of the connectors is bad (maybe they broke it when they were installing the springs) or it's still a little loose.

Even if one of your shocks is broken you can replace it for a lot less than a full set of Motons costs.
__________________
Appreciate 0
      10-26-2009, 07:54 PM   #5
wea
Private
6
Rep
74
Posts

 
Drives: 2012 Porsche Cayman R
Join Date: Jan 2009
Location: Austin, TX

iTrader: (2)

Quote:
Originally Posted by Technic View Post
So no faults between Aug 9 and just today? What else has been done to the suspension?
Yes, error free since the install. I had the alignment done a few days later. Nothing has been touched since the alignment.

My first thought was it might be weather related. Today it was rainy and in the 50s. I had not driven the car since last Wednesday because I had a LeMons race in Houston over the weekend. Otherwise it has been HOT in Austin.

Quote:
Originally Posted by gthirtyfizle View Post
Ur worst case sounds like the best option to me lol. If I were u i would make belive they r forever ruined and just go ahead and get the motons lol.

HOWEVER, If u dont feel like shelling out the 5+K the I suggest just looking over the install. Pretty confident something is loose.
Hmm, I went over this thoroughly so I'm not convinced about a loose connection. Motons do seem like the only real solution...

Quote:
Originally Posted by FStop7 View Post
I really doubt you have a shock failure, especially so soon. Either one of the connectors is bad (maybe they broke it when they were installing the springs) or it's still a little loose.

Even if one of your shocks is broken you can replace it for a lot less than a full set of Motons costs.
There is no obvious physical damage so hopefully if a sensor is broken it will be covered under warranty.
__________________
Favorite Quote on Supercars: "They are designed to melt ice caps, kill the poor, poison the water table, destroy the ozone layer, decimate indigenous wildlife, recapture the Falkland islands, and turn the entire third world into a huge uninhabitable desert... but only after they nicked all the oil." Jeremy Clarkson from Top Gear 05x02 @ 48:55.
Appreciate 0
      10-26-2009, 08:35 PM   #6
doba_s
Major General
doba_s's Avatar
United_States
148
Rep
6,099
Posts

 
Drives: M3, 1M
Join Date: Sep 2006
Location: San Francisco

iTrader: (26)

Send a message via Skype™ to doba_s
I would suggest to run a quick diagnostic test to see what computer shows ... Or if you have a BT Scanning tool you can use that ...

It will be a good idea to see what is wrong before you take it to the dealer ... And your shop can always clear all the codes and it might never come back again ...
Appreciate 0
      10-26-2009, 09:54 PM   #7
vinnycg
Captain
11
Rep
710
Posts

 
Drives: 2005 Infiniti G35 Coupe
Join Date: Dec 2007
Location: New York

iTrader: (1)

I received this edc error with my h&rs and it was due to the sensors being loose..i doubt its a shock failure as well or you'd probably be feeling it in the ride.

-Vin
Appreciate 0
      10-27-2009, 08:31 AM   #8
SHADY1
Hamann M3 Fan
SHADY1's Avatar
United_States
52
Rep
2,736
Posts

 
Drives: 2008 E92 Jerez Black M3
Join Date: Feb 2008
Location: Killeen, Texas

iTrader: (6)

Garage List
Thumbs up Hey Wea you are in luck

I just had this same fault on my M3 and I have H&R springs. They had to change a sensor or something on the EDC and it was covered under warranty Just take it to Austin BMW and they will take care of you. There is nothing to worry about. I was kinda worried at first myself but your good. I live in Killeen, Texas and I take my M3 to Austin BMW.
__________________

JZB,6MT, My mods 360 Forged 20inch wheels,VF650 Supercharger,SPEC Super Twin Disk Clutch,Hamann CF roof spoiler,H&R springs,CF grills,Hamann rear trunk spoiler,Hamann Side Skirts, ARKYM full CF bumper, Gintani Race exhaust, AA X-pipe catless,RPI scoops,AA SSK, Arkym CF Double Sided Vented Hood,Arkym CF rear Diffuser
Appreciate 0
      10-27-2009, 04:04 PM   #9
wea
Private
6
Rep
74
Posts

 
Drives: 2012 Porsche Cayman R
Join Date: Jan 2009
Location: Austin, TX

iTrader: (2)

Made an appointment with BMW Austin last night and now it's not showning the EDC Malfunction. I'm going to take it in anyway and see if there is a code. I will let you guys know what happens.

And thanks Shady1 for the PM!

Cheers
__________________
Favorite Quote on Supercars: "They are designed to melt ice caps, kill the poor, poison the water table, destroy the ozone layer, decimate indigenous wildlife, recapture the Falkland islands, and turn the entire third world into a huge uninhabitable desert... but only after they nicked all the oil." Jeremy Clarkson from Top Gear 05x02 @ 48:55.
Appreciate 0
      11-08-2009, 09:31 AM   #10
disruptv
Major
28
Rep
1,144
Posts

 
Drives: 3M
Join Date: Sep 2006
Location: ny

iTrader: (10)

Garage List
09 3m  [0.00]
any updates?
Appreciate 0
      11-08-2009, 09:49 AM   #11
wea
Private
6
Rep
74
Posts

 
Drives: 2012 Porsche Cayman R
Join Date: Jan 2009
Location: Austin, TX

iTrader: (2)

Quote:
Originally Posted by disruptv View Post
any updates?
Yes, after disconnecting the battery and checking and re-checking all the connections it seems to be working just fine. One note, even after the reconnecting the battery you have to drive it to get the error to clear. BTW, my SA talked me out of coming in since the error was not presenting itself.
__________________
Favorite Quote on Supercars: "They are designed to melt ice caps, kill the poor, poison the water table, destroy the ozone layer, decimate indigenous wildlife, recapture the Falkland islands, and turn the entire third world into a huge uninhabitable desert... but only after they nicked all the oil." Jeremy Clarkson from Top Gear 05x02 @ 48:55.
Appreciate 0
      11-08-2009, 03:59 PM   #12
Bluesummer
Lieutenant General
Bluesummer's Avatar
Taiwan
179
Rep
15,410
Posts

 
Drives: slower than Ayrton Senna
Join Date: Dec 2006
Location: Nürburgring, be there once, your heart, your soul will stay there.

iTrader: (13)

Garage List
2015 M4  [0.00]
2011 E82 135  [0.00]
2011 M3  [0.00]
2007 335  [0.00]
glad things work out for you
__________________

R.I.P. Steve Noh
Appreciate 0
      11-23-2009, 12:37 AM   #13
noxredna
Captain
noxredna's Avatar
17
Rep
670
Posts

 
Drives: 2008 BMW M3 Coupe, 2012 BMW M5
Join Date: Sep 2008
Location: Philadelphia & Singapore

iTrader: (0)

Quote:
Originally Posted by wea View Post
Yes, after disconnecting the battery and checking and re-checking all the connections it seems to be working just fine. One note, even after the reconnecting the battery you have to drive it to get the error to clear. BTW, my SA talked me out of coming in since the error was not presenting itself.
I just installed Eibachs three days ago and I also got an EDC malfunction message that popped out yesterday..

Will go back to the people who installed them and will tell them to check all connections and disconnect/reconnect battery..

Where are the main connections that I need to watch out for? Are they in the engine bay on the two corners?

Thanks

Anderson
Appreciate 0
      11-23-2009, 01:05 AM   #14
Tio///M
///M South Lead
Tio///M's Avatar
United_States
14
Rep
863
Posts

 
Drives: Jerez Blk / Fox Red Ext
Join Date: Oct 2008
Location: In Miami Serving all of SoFLA

iTrader: (2)

Send a message via MSN to Tio///M Send a message via Yahoo to Tio///M
Quote:
Originally Posted by noxredna View Post
I just installed Eibachs three days ago and I also got an EDC malfunction message that popped out yesterday..

Will go back to the people who installed them and will tell them to check all connections and disconnect/reconnect battery..

Where are the main connections that I need to watch out for? Are they in the engine bay on the two corners?

Thanks

Anderson
Keep in mind the connections for the EDC on top the strut is a very very short wire...it can easily break...double check to make sure they properly seated it...if not they accidentally broke one of the connecting rods...which mine was replaced under factory thru the dealer...so I wouldn't worry about it too much...
__________________
///AA ///Challenge ///MS ///EAS ///OEM ///H&R ///

MFlight!! .......NOW
///M SOUTH
on Facebook!!
FOR SALE!!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:01 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST