BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > Canada
 
Post Reply
 
Thread Tools Search this Thread
      10-15-2009, 05:59 PM   #1
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

car died today :(

Started it, slight vibration, stalled. Couldn't start it again
Had to have it towed, man I hope you guys never have to get your car towed, the abuse!
Appreciate 0
      10-15-2009, 06:08 PM   #2
Gearhead999s
Major General
Gearhead999s's Avatar
93
Rep
6,814
Posts

 
Drives: F25 2.8d(wifes)F82 M4
Join Date: Apr 2007
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by shagkie View Post
Started it, slight vibration, stalled. Couldn't start it again
Had to have it towed, man I hope you guys never have to get your car towed, the abuse!
Did they not flatbed it?
Appreciate 0
      10-15-2009, 06:45 PM   #3
M3 vert
Lieutenant Colonel
M3 vert's Avatar
United Kingdom
22
Rep
1,793
Posts

 
Drives: E93 M3, '12 750ix, 760Li Ind.
Join Date: Dec 2008
Location: Everywhere...

iTrader: (0)

Quote:
Originally Posted by Gearhead999s View Post
Did they not flatbed it?
+1

Thats blasphemy...if they didnt
Appreciate 0
      10-15-2009, 08:49 PM   #4
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

Quote:
Originally Posted by Gearhead999s View Post
Did they not flatbed it?
Unfortunately not. The reason the tow guy told me was that my car was parked in a covered parking lot so the flatbed wouldn't be able to get in anyway. He said that they should have still sent a flatbed along with him so that he can get me out of the covered parking lot and then flatbed it. The guy kept on mumbling about they didn't pay him enough to tow this thing.
Appreciate 0
      10-15-2009, 09:58 PM   #5
ching
First Lieutenant
ching's Avatar
3
Rep
315
Posts

 
Drives: e90 m3
Join Date: Jun 2009
Location: toronto

iTrader: (0)

Any idea what's wrong?
__________________
E90 BMW M3 interlagos blue / silver novillo - vrs type ii diffuser, ape performance air filter, ind ib reflectors, RAC RG63 gunmetal, 2 car seats and a baby on board sign
Appreciate 0
      10-15-2009, 10:19 PM   #6
kmac1980
Major
16
Rep
1,025
Posts

 
Drives: '11 535xi, (former '08 M3)
Join Date: Jan 2006
Location: toronto

iTrader: (1)

sorry to hear. any check control diagnostic messages in your dash or i-drive? possibly drained battery? (the charging system on this car is a bit weak if you dont do a lot of highway driving)
Appreciate 0
      10-15-2009, 10:19 PM   #7
Gearhead999s
Major General
Gearhead999s's Avatar
93
Rep
6,814
Posts

 
Drives: F25 2.8d(wifes)F82 M4
Join Date: Apr 2007
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by shagkie View Post
Unfortunately not. The reason the tow guy told me was that my car was parked in a covered parking lot so the flatbed wouldn't be able to get in anyway. He said that they should have still sent a flatbed along with him so that he can get me out of the covered parking lot and then flatbed it. The guy kept on mumbling about they didn't pay him enough to tow this thing.
Thats crap as they should have flat towed it up to ground level where it could have been loaded on a flatbed.Even Ford paid to do that with one of my F150's when it would not start in an underground.If they can do that with a 6100 lb truck there is no reason that it should not be done on a 3700 lb fragile car!
Appreciate 0
      10-16-2009, 06:05 AM   #8
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

Dealer said they didn't have time to look at the car yesterday so I had to leave it at the dealer, they gave me an awesome Pontiac G6
When I started the car the first time it fires normally and then just stalled, no indicators of any kind. When I try to start it again it just cranks and the engine light come on while you're cranking it too long? The indicator didn't stay. The service advisor said that if you try too many times you'll flood the engine, maybe thats what the engine light came on to tell you

I'm going to give BMW roadside crap when they call me back for feedback. The tow came 1.5 hrs later than what they said. Oh the tow guy also said that maybe I have little gas in the tank that's why it does it. I have 1/4 tank left.
Appreciate 0
      10-16-2009, 12:47 PM   #9
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

Update: they called me and said one of my ignition coil is gone and something about generating alot of resistence in the wire and some of the wire around the fuse got toasted. Well one good thing is that I can give back this piece of crap pontiac today and jump into a loaner.
Appreciate 0
      10-16-2009, 02:31 PM   #10
M3 vert
Lieutenant Colonel
M3 vert's Avatar
United Kingdom
22
Rep
1,793
Posts

 
Drives: E93 M3, '12 750ix, 760Li Ind.
Join Date: Dec 2008
Location: Everywhere...

iTrader: (0)

Quote:
Originally Posted by shagkie View Post
Update: they called me and said one of my ignition coil is gone and something about generating alot of resistence in the wire and some of the wire around the fuse got toasted. Well one good thing is that I can give back this piece of crap pontiac today and jump into a loaner.
What dealer is this?

and why are they giving you a pontaic
Appreciate 0
      10-16-2009, 03:21 PM   #11
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

T&C, now they give me a 323
Appreciate 0
      10-16-2009, 10:24 PM   #12
M3 vert
Lieutenant Colonel
M3 vert's Avatar
United Kingdom
22
Rep
1,793
Posts

 
Drives: E93 M3, '12 750ix, 760Li Ind.
Join Date: Dec 2008
Location: Everywhere...

iTrader: (0)

Quote:
Originally Posted by shagkie View Post
T&C, now they give me a 323
Those SOB's now thats better

although they should give you a 335i

Sorry to hear about the issue...hopefully it gets fixed before u get used to the 323
Appreciate 0
      10-17-2009, 12:13 AM   #13
bunnn
Colonel
bunnn's Avatar
35
Rep
2,260
Posts

 
Drives: like a grandma
Join Date: May 2009
Location: Toronto

iTrader: (12)

being pretty close with one of the SA @ TC..i really dont think they have more than 1 or 2 335i ...i've had 330, 328, 128, 135, X3 ...and a handful of shitty rentals from discount, never once had I've been handed the 335

on a related note, my Audi had the same problem back then, it was a headache for me...to makes matters worst the dealer was incompetent, took 2 days to figure it out...
__________________
Cheers
Ben
Appreciate 0
      10-17-2009, 08:18 AM   #14
kmac1980
Major
16
Rep
1,025
Posts

 
Drives: '11 535xi, (former '08 M3)
Join Date: Jan 2006
Location: toronto

iTrader: (1)

Quote:
Originally Posted by bunnn View Post
being pretty close with one of the SA @ TC..i really dont think they have more than 1 or 2 335i ...i've had 330, 328, 128, 135, X3 ...and a handful of shitty rentals from discount, never once had I've been handed the 335

on a related note, my Audi had the same problem back then, it was a headache for me...to makes matters worst the dealer was incompetent, took 2 days to figure it out...
+1 ive only had 328s, 323s and x3s as loaners. you have to love t&c's valet service too.


they used to come pick up my car from downtown for service and leave me with a loaner and then return my car, picking up the loaner when it was ready.
Appreciate 0
      10-17-2009, 10:34 AM   #15
Fanta
C
Fanta's Avatar
Canada
10
Rep
578
Posts

 
Drives: 740iL, M3, Carrera & C320
Join Date: Jan 2009
Location: Ottawa

iTrader: (1)

I bought a brand new Porsche Carreara, my Porsche dealer gave me a Toyota Echo as a loaner for service. That is once of the reason why I bought BMW M3 after.
Appreciate 0
      10-17-2009, 10:56 AM   #16
ching
First Lieutenant
ching's Avatar
3
Rep
315
Posts

 
Drives: e90 m3
Join Date: Jun 2009
Location: toronto

iTrader: (0)

Quote:
Originally Posted by Fanta View Post
I bought a brand new Porsche Carreara, my Porsche dealer gave me a Toyota Echo as a loaner for service. That is once of the reason why I bought BMW M3 after.
This is why I asked for guarantees from the salesperson and manager that I would receive a BMW loaner on all service as I told them it'd be a cold day in hell before I'd step inside the shuttle bus.

I've driven 323 / 328s so far as there aren't a lot of manual cars in their service fleet. The salesman also offered to pick-up and drop-off at my house, but I've not taken him up on this offer as the dealership is on my way to/from work.
__________________
E90 BMW M3 interlagos blue / silver novillo - vrs type ii diffuser, ape performance air filter, ind ib reflectors, RAC RG63 gunmetal, 2 car seats and a baby on board sign
Appreciate 0
      10-21-2009, 02:41 PM   #17
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

Boo hoo my car won't be back for at least 2 weeks due to backorder parts
Appreciate 0
      10-21-2009, 09:44 PM   #18
kmac1980
Major
16
Rep
1,025
Posts

 
Drives: '11 535xi, (former '08 M3)
Join Date: Jan 2006
Location: toronto

iTrader: (1)

Quote:
Originally Posted by shagkie View Post
Boo hoo my car won't be back for at least 2 weeks due to backorder parts
yikes, try to get a nicer loaner out of them for that time! maybe one of their demos
Appreciate 0
      10-27-2009, 07:52 AM   #19
shagkie
Captain
shagkie's Avatar
9
Rep
628
Posts

 
Drives: a....V8
Join Date: Dec 2008
Location: GTA, Canada

iTrader: (0)

Got the car back yesterday but they also gave me a 4 inches deep scratch on the driver side skirt. Car went back this morning for repair
At least the service manager didn't try to weasel his way out this time.
Appreciate 0
      10-27-2009, 11:38 AM   #20
M3 vert
Lieutenant Colonel
M3 vert's Avatar
United Kingdom
22
Rep
1,793
Posts

 
Drives: E93 M3, '12 750ix, 760Li Ind.
Join Date: Dec 2008
Location: Everywhere...

iTrader: (0)

Quote:
Originally Posted by shagkie View Post
Got the car back yesterday but they also gave me a 4 inches deep scratch on the driver side skirt. Car went back this morning for repair
At least the service manager didn't try to weasel his way out this time.
Idiots!

these T&C people really suck eh!

make sure they do it right this time!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:38 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST