BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Cosmetic/Visual (Exterior + Interior) Modifications
 
do88 Performance
Post Reply
 
Thread Tools Search this Thread
      03-21-2012, 06:48 PM   #1
onesixeight
Lieutenant
18
Rep
485
Posts

Drives: F82 M4/i8
Join Date: May 2005
Location: Seattle, WA

iTrader: (0)

HELP! Performance Steering Wheel Rev lights not working...

Hi...

I had the dealer install my BMW Performance Steering wheel Version 2 on my 2010 E92 M3.

Everything works perfectly except for the shift lights on the wheel. When I boot up the car, the led lights self test perfectly, but when I rev the car, the shift lights don't light up.

For an example, see this youtube video



Mine does not light up.

The dealer is telling me that this wheel is designed for a 335i and I do understand this, but I've seen it work on a M3 just like the video above.

Anyone have any hints on how to make it work so that the shift LED lights on the steering wheel function?

Thank you!!!

Chris
Appreciate 0
      03-21-2012, 08:08 PM   #2
Raptor251
ESS Dreaming
Raptor251's Avatar
United_States
12
Rep
870
Posts

Drives: 2011.5 e92 m3/Ford Raptor 6.2
Join Date: Jan 2011
Location: San Diego

iTrader: (1)

Duh the steering wheel doesnt work, its on the wrong side of the car!
Appreciate 0
      03-21-2012, 08:28 PM   #3
kmarei
Major General
kmarei's Avatar
Egypt
204
Rep
6,600
Posts

Drives: 2015 Alfa Romeo 4C LE
Join Date: Jul 2008
Location: Reston, VA

iTrader: (33)

Garage List
Just my educated guess
Dealer tech is an idiot
__________________
Appreciate 0
      03-21-2012, 09:13 PM   #4
USC2000
Lieutenant Colonel
USC2000's Avatar
United_States
83
Rep
1,604
Posts

Drives: F30 328i M Sport
Join Date: Jul 2007
Location: El Paso, TX

iTrader: (10)

Perhaps a setting that you need to program.
__________________
2014 Alpine White 328i M Sport | M Performance Exhaust | M Performance Front Splitter | M Performance Carbon Fiber Spoiler | M Performance Grills | M Performance Pedals[/size]
______________________
Appreciate 0
      03-21-2012, 09:29 PM   #5
1SICKM
Major
1SICKM's Avatar
30
Rep
1,048
Posts

Drives: 2009 M3 E92
Join Date: Oct 2010
Location: Mansfield, NJ

iTrader: (5)

Do some research on this forum. It's a very common problem. In short, don't wire the wheel for power out of the jb3 module as per the instructions. Go straight to the fuse box with a fuse that has constant power
__________________
E92 M3 DCT...Powered by ESS VT2 650/DCT GTS Software/Aquamist HFS-3 50/50/Morr /Toyo R888's

ATCO RACEWAY: 10.65 @ 131.79MPH 1.725 60FT
(Stock ESS 625)
Appreciate 0
      03-21-2012, 09:32 PM   #6
THE TECH
BimmerPost Supporting Vendor
THE TECH's Avatar
United_States
182
Rep
13,111
Posts


Drives: BPMsport 2012 E92 M3
Join Date: Jun 2011
Location: Kansas

iTrader: (45)

Garage List
Send a message via AIM to THE TECH Send a message via Skype™ to THE TECH
Do you have the settings set correctly?
Appreciate 0
      01-13-2014, 10:53 AM   #7
DimitrisM3
e90 my big fat lady!
DimitrisM3's Avatar
Greece
16
Rep
242
Posts

Drives: e90
Join Date: Oct 2011
Location: Greece Naoussa

iTrader: (0)

i have the same problem with you!!!!!!!
any suggestion??
Appreciate 0
      09-06-2016, 09:37 AM   #8
Hg
New Member
2
Rep
17
Posts

Drives: e87 130i M
Join Date: Jun 2015
Location: Turkey

iTrader: (0)

hi

I have the same problem

in fact the wheel is reading the RPM 10 times less than real value

When you go into the Correction Factor settings, what does you steering wheel read when the car is idling? 500-600 or 50-60?

mine reads 50-60 so for the wheel to read 1k rpm, i need to rev it to 10k
Appreciate 0
      09-10-2016, 02:24 PM   #9
dry87
Private
dry87's Avatar
Indonesia
12
Rep
92
Posts

Drives: E92 M3
Join Date: Jul 2014
Location: DKI Jakarta

iTrader: (0)

Garage List
2010 BMW M3  [0.00]
2015 porsche macan  [0.00]
2015 bmw 435i  [0.00]
I have the same problem,

Everything works perfectly except for the shift lights on the wheel. When I boot up the car, the led lights self test perfectly, but when I rev the car, the shift lights don't light up.

When I go to settings to change the rpm threshold the indicator that normally shows the current rpm it reads 0.

It just happen to me, used to be working

Any suggestion ?
Appreciate 0
      09-15-2016, 12:32 AM   #10
Scrippy
Lord Scrip
Scrippy's Avatar
United_States
93
Rep
875
Posts

Drives: 2011 M3 Coupe
Join Date: Jan 2012
Location: LA,Ca

iTrader: (0)

Garage List
2007 BMW 335i  [0.00]
The batteries died!
__________________
Love it, clean it, maintain it and drive it like you stole it!
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:57 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST