BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      04-26-2009, 04:05 PM   #1
Manny212
Captain
 
Manny212's Avatar
 
Drives: 2008 M3
Join Date: Apr 2007
Location: NY

Posts: 627
iTrader: (3)

Send a message via AIM to Manny212
Help with weird sound after spring install.

So i got H&R's installed today and when i go over a bump, even slowly over a speed bump I hear a noise coming from the rear. It sounds like I just went over one of those steel plates they put on the streets. And sometimes even when making a turn on a non level street it makes that sound from the rear. Sounds like something moves around in the rear. Any thoughts?
__________________

2008 E92///M3 - | Alpine White/Fox Red Extended Novillo | Technology | Premium | Cold |
Mods: | 19" Avante Garde | Macht Schnell Filter | RPi Scoops | Rogue SSK | MS Spacers | ACM Test Pipes | ESS Tune | Remus Race | LUX V4 Angels | KW V3 |
Manny212 is offline   United_States
0
Reply With Quote
      04-26-2009, 05:16 PM   #2
J08M3
Major General
 
J08M3's Avatar
 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

Posts: 6,012
iTrader: (8)

hmm... that's kinda weird I wonder what it could be. I didn't have that problem. Did you install the springs yourself or have a shop do it?
__________________
J08M3 is offline   United_States
0
Reply With Quote
      04-26-2009, 05:21 PM   #3
rzm3
Moderator
 
rzm3's Avatar
 
Drives: E92 M3
Join Date: Aug 2007
Location: USA

Posts: 4,598
iTrader: (14)

Retighten the bolts. Retighten the bolts. Retighten the bolts.
__________________
E92 M3 DCT - AiM EVO4 Data Logger / AiM SmartyCam HD / KW Competition 2-Way / OMP ARS Racing Seats / Brembo GT 365 / Pagid Yellow RS-29 / Rear Seats Delete
rzm3 is offline  
0
Reply With Quote
      04-26-2009, 05:57 PM   #4
Manny212
Captain
 
Manny212's Avatar
 
Drives: 2008 M3
Join Date: Apr 2007
Location: NY

Posts: 627
iTrader: (3)

Send a message via AIM to Manny212
Quote:
Originally Posted by J08M3 View Post
hmm... that's kinda weird I wonder what it could be. I didn't have that problem. Did you install the springs yourself or have a shop do it?
had a shop do it
__________________

2008 E92///M3 - | Alpine White/Fox Red Extended Novillo | Technology | Premium | Cold |
Mods: | 19" Avante Garde | Macht Schnell Filter | RPi Scoops | Rogue SSK | MS Spacers | ACM Test Pipes | ESS Tune | Remus Race | LUX V4 Angels | KW V3 |
Manny212 is offline   United_States
0
Reply With Quote
      04-26-2009, 07:02 PM   #5
FStop7
I like cars
 
FStop7's Avatar
 
Drives: M6
Join Date: Oct 2008
Location: Newbury Park, CA

Posts: 5,059
iTrader: (3)

Did they tighten the bolts with the car on the ground or on the lift? Either way they sound like they need to be retightened.
__________________
FStop7 is offline   Vatican City State
0
Reply With Quote
      04-26-2009, 07:40 PM   #6
Manny212
Captain
 
Manny212's Avatar
 
Drives: 2008 M3
Join Date: Apr 2007
Location: NY

Posts: 627
iTrader: (3)

Send a message via AIM to Manny212
Thanks guys. I spoke to one of the guys and it's probably the sway bar end links. I only heard the noise after the 40 mile drive home.

BTW the springs ride great. Other than scraping a little more than usual, I really don't see the difference between the H&R's and stock comfort wise. I only drive in Normal mode on the EDC so maybe that's why.
__________________

2008 E92///M3 - | Alpine White/Fox Red Extended Novillo | Technology | Premium | Cold |
Mods: | 19" Avante Garde | Macht Schnell Filter | RPi Scoops | Rogue SSK | MS Spacers | ACM Test Pipes | ESS Tune | Remus Race | LUX V4 Angels | KW V3 |
Manny212 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:29 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST