BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Suspension | Brakes | Chassis
 
Post Reply
 
Thread Tools Search this Thread
      02-27-2009, 09:35 PM   #1
gnatty8
Enlisted Member
gnatty8's Avatar
1
Rep
48
Posts

 
Drives: E90 6MT
Join Date: Feb 2009
Location: Southeast

iTrader: (0)

Squeaking Brakes

New 2008 M3. Problem is loud, obnoxious squeaking brakes, I believe front driver side. Happens when the car is warm, only when coming to a slow stop, and lasts a long time, not just a sqeak when I come to a stop. Car has 1,400 miles. Took it to dealer once and they looked at it and couldn't find anything wrong. Took it again 2 weeks later and said please, fix this f*cking noise.. They out nickel on the brakes and said that should take care of it. Problem is it almost sounds worse! This is pissing me off.. The head mechanic agreed with me that the squeaking is not the normal squeak you sometimes hear with these brakes, but in the shop twice with no luck.. Anybody else have this problem? Again, its coming to a slow stop and lasts for a couple seconds, not just a squeak at the end.. Anyone?
Appreciate 0
      02-27-2009, 09:42 PM   #2
TwoSaints
Second Lieutenant
TwoSaints's Avatar
Brazil
3
Rep
227
Posts

 
Drives: E90 M3
Join Date: Jan 2009
Location: Beaumont, Texas

iTrader: (0)

mine squeaks every now and then. It doesn't really bother me though, maybe it's not the same thing you're experiencing. Kinda sounds like it though.
Appreciate 0
      02-27-2009, 09:42 PM   #3
rob612
Second Lieutenant
rob612's Avatar
United_States
4
Rep
235
Posts

 
Drives: e92 - m3
Join Date: Jul 2008
Location: California

iTrader: (1)

they told me it was some "emergency brake spring" thats what it said on the paper.. was removed / fixed.

yes, it did solve the problem for about a few weeks... then the squeeking came back -___-
Appreciate 0
      02-28-2009, 12:15 AM   #4
thai357sig
First Lieutenant
thai357sig's Avatar
8
Rep
399
Posts

 
Drives: M3
Join Date: Jan 2009
Location: Silver Spring MD

iTrader: (0)

Mine has 90 miles and it is squeaking. I thought it was because its new. I am taking the car in for a Manufacterer defect in the hood. Paint/bump to fix , will have brakes looked at also! Buy you're right only happens when letting off pressure when coming to a stop. Not at full pressure. Good luck.
__________________
09'M3 JerezB/Tech/Cold/Prem/PDC/SR/Black Leather/ANTHRACITE Sycamore/IPOD/USB/Rear Sunshade/Premium Sounnd/6MT***Just Hit The Ground! Delivery 02/25/2009***
Appreciate 0
      02-28-2009, 12:34 AM   #5
makots
First Lieutenant
makots's Avatar
Singapore
11
Rep
341
Posts

 
Drives: '08 e92 M3 AW 6MT
Join Date: Sep 2008
Location: Boston, MA

iTrader: (2)

Send a message via AIM to makots Send a message via MSN to makots Send a message via Skype™ to makots
mine squeaks too! but i'm pretty sure that it is very normal. Sometimes due to the weather, heat/moisture, and dirt, it causes dirt/objects to get in between the brake pads and the disc. causing some squeak. I'm my opinion, it does not really matter.
__________________
2008 AW/BLK M3 6MT / Eisenmann Race / H&R / HID Angels / 3D Front & Rear Lip / UUC SSK / TE37 / Turner Pulleys / 4.10FD & 2 Clutch Salisbury Diff / Escort 9500ci

Appreciate 0
      02-28-2009, 01:44 AM   #6
kmax1980
Private First Class
1
Rep
117
Posts

 
Drives: 08 E93 M3 Jerez Black/Fox Red
Join Date: Oct 2008
Location: toronto

iTrader: (0)



if you guys read the manual, you'd see where it clearly states the brakes willl squeak as part of healthy, normal operation
Appreciate 0
      02-28-2009, 02:05 AM   #7
Manny212
Captain
Manny212's Avatar
United_States
13
Rep
659
Posts

 
Drives: 2008 M3
Join Date: Apr 2007
Location: NY

iTrader: (3)

Send a message via AIM to Manny212
mine squeak sometimes when i'm going very slow and braking. i just let go and step on the brakes again. It's not too annoying as it's only when i'm braking at less than 10mph and coming to a stop and it's only if i'm braking lightly
__________________

2008 E92///M3 - | Alpine White/Fox Red Extended Novillo | Technology | Premium | Cold |
Mods: | 19" Avante Garde | Macht Schnell Filter | RPi Scoops | Rogue SSK | MS Spacers | ACM Test Pipes | ESS Tune | Remus Race | LUX V4 Angels | KW V3 |
Appreciate 0
      02-28-2009, 03:19 AM   #8
Mrgunfun
Private
Mrgunfun's Avatar
0
Rep
52
Posts

 
Drives: '08 BMW M3 M-DCT (E92)
Join Date: Jan 2009
Location: Garden State

iTrader: (0)

Read The Manual!!
Appreciate 0
      02-28-2009, 07:57 AM   #9
Splinter4784
414 little horsies
Splinter4784's Avatar
Armenia
10
Rep
407
Posts

 
Drives: 2008 M3
Join Date: Jan 2009
Location: Beverly Hills

iTrader: (2)

i dont have the squeak at all

thats because i properly broke in the breaks

Just do the following: from 5 miles an hour go to 60 miles an hour fast and break as hard as you can until 5 miles an hour then repeat 8 times

Ur Squeak will disappear
__________________
Race Precision Inc
Appreciate 0
      02-28-2009, 09:04 AM   #10
J08M3
Major General
J08M3's Avatar
United_States
102
Rep
6,012
Posts

 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

iTrader: (8)

They all squeak, mine is very loud from the front at slow speed stops. It's worse under 40 degrees. Over 50 or so I never hear the noise. Supposed to be normal though on high performance brakes at least according to the manual.
__________________
Appreciate 0
      02-28-2009, 10:03 AM   #11
gnatty8
Enlisted Member
gnatty8's Avatar
1
Rep
48
Posts

 
Drives: E90 6MT
Join Date: Feb 2009
Location: Southeast

iTrader: (0)

Quote:
Originally Posted by kmax1980 View Post


if you guys read the manual, you'd see where it clearly states the brakes willl squeak as part of healthy, normal operation
no, this is not the squeak referenced in the manual, the mechanic who drove it with me said as much, and he's been working on BMWs for over 20 years.. however, they can't seem to fix it, as the nickel they put on the brakes does not seem to be doing anything..
Appreciate 0
      03-16-2009, 05:28 PM   #12
maaicher
Captain
maaicher's Avatar
15
Rep
734
Posts

 
Drives: Jet black E92 M3
Join Date: Nov 2008
Location: Los Angeles

iTrader: (10)

mine used to squeak at very low speeds and slow stops from 1000 -2500 miles, now i have a little over 4000miles and the squeaking is gone, the dealer had told me to deal with it because nothing is wrong and it turns out nothing was wrong just requires a little time to break in which is easier to do of course after the break in period of the engine
__________________
SOLD 2008 Jet Black E92 M3 * HRE C20 19in Wheels * KW Clubsport * Huper Ceramic Tint * Stop-Tech Trophy BBK *Gintani SC & Gintani Custom Exhaust* Vertice Front Bumper*Arkym Diffuser*
Appreciate 0
      03-16-2009, 10:37 PM   #13
sayemthree
Brigadier General
sayemthree's Avatar
127
Rep
4,845
Posts

 
Drives: bmw
Join Date: Aug 2007
Location: usa

iTrader: (0)

mine dont squeek. or maybe I am just used to the Hawk hp+ pads on my e46.
Appreciate 0
      03-23-2009, 08:10 PM   #14
darkalley
Captain
United_States
17
Rep
635
Posts

 
Drives: Gone- 08 DCT SSII, 2006 SMG
Join Date: Dec 2006
Location: Current: 2014 BMW 4-Series Convert for the fiance w M Package, F150, 06 S2000, 08 911 c4s

iTrader: (0)

i just had my 19's put back on and this is the first time i noticed a squeak...... i watch the mechanic use a torque wrench to tighten the rims vs an impact gun so i don't think they are over tightened. it seems to be at slow speeds when i turn..... from the drivers side.
__________________
2008 SSII DCT M3/Peapack/Parsippany NJ
Appreciate 0
      03-23-2009, 08:50 PM   #15
BarryC
Major
United_States
42
Rep
1,160
Posts

 
Drives: '13 LRP M3
Join Date: May 2007
Location: Kernersville NC

iTrader: (10)

Mine squeal/squeek too and I'm at 7500 miles. It's the pad compound that is causing the problem. Similar to a full race pad, it squeeks. If you change the pad to one that doesn't squeek, you will lose performance in the brakes. They'll still work but probably won't have the same feel or heat tolerance.

BC
__________________
2014 M5
Appreciate 0
      04-01-2009, 12:45 PM   #16
leeor
Banned
United_States
53
Rep
2,393
Posts

 
Drives: 2010 Blue Prius III
Join Date: Mar 2009
Location: Los Angeles

iTrader: (4)

does the 5-60-5 mph thing really work? im about to tell them to replace all my pads and rotors and everything so i can do this lol

or can u do it from now even?

at 4600 squeeky miles?
Appreciate 0
      04-01-2009, 01:10 PM   #17
Canyon Junkie
Private First Class
United_States
2
Rep
110
Posts

 
Drives: 2008 M3 Sedan
Join Date: Aug 2008
Location: Boulder, CO

iTrader: (0)

Quote:
Originally Posted by Splinter4784 View Post
i dont have the squeak at all

thats because i properly broke in the breaks

Just do the following: from 5 miles an hour go to 60 miles an hour fast and break as hard as you can until 5 miles an hour then repeat 8 times

Ur Squeak will disappear

This is true but the pads are bedded before being installed at the factory.

If the OP's squeal is abnormal as described, he may have very very slightly warped a rotor, causing excessive vibration between the pads and rotors.
__________________
“Have you ever noticed that anybody driving slower than you is an idiot, and anyone going faster than you is a maniac?"
-George Carlin
Appreciate 0
      04-16-2009, 06:52 PM   #18
Howard@StopTech
Registered
0
Rep
1
Posts

 
Drives: Fast
Join Date: Apr 2009
Location: Compton

iTrader: (0)

I can't help but notice this thread. Here's a bed-in procedure you can follow.

http://www.stoptech.com/tech_info/wp_bedinstock.shtml

Typically OE pads, and rotors from the factory whether on a new car or installed from a dealer aren't bedded in. There aren't instructions on new cars to bed-in your brakes(heat up the brake pad material and transfer the material to the rotors)
Appreciate 0
      04-16-2009, 07:10 PM   #19
TayE90
Private
United_States
0
Rep
91
Posts

 
Drives: BMW 435xi '14
Join Date: Feb 2009
Location: Eastside

iTrader: (0)

Send a message via AIM to TayE90
same!

Quote:
Originally Posted by darkalley View Post
i just had my 19's put back on and this is the first time i noticed a squeak...... i watch the mechanic use a torque wrench to tighten the rims vs an impact gun so i don't think they are over tightened. it seems to be at slow speeds when i turn..... from the drivers side.

I am having the same problem. Have u fixed the sound, know how to fix the sound, or where the hell its coming from?
__________________
6MT//zpp//zsp//cold//comfortaccess//sport//KWv1//COBB Tuned//custom magnaflow cat back exhaust//DCI//OEM M3 knob//blacked out LED lights//led license plate lights//amber interior lights//amber led floor lights//black roundels//M3 Front Bumper//roof spoiler//trunk spoiler//matte black grilles//RPI Scoops//7000k Led halos//7000k hid fogs//5% tint//eyelids//10' memphis mojo sub//750watt amp//V1 Hardwired//etc
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:57 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST