BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
Velos Designwerks
Post Reply
 
Thread Tools Search this Thread
      11-05-2008, 12:49 PM   #1
DerekMD07
Private First Class
 
Drives: 2014 335xi LSB/ 2014 X5d M
Join Date: Oct 2008
Location: London, Ontario

Posts: 189
iTrader: (1)

Low coolant level warning

Hi,

My car has about 1400km on it. Ever since the 600km mark, the low engine coolant light would come on when the engine is first started in the morning or after a long rest. I brought it to service. They topped up the coolant (not sure how much was given and they didn't say that the level was low) but the problem recurred the next day. I haven't had time to bring it in since. My question is can the coolant really be consumed? Or do you think the problem lies with the sensor? Anyone with a similar experience?

Thanks, Derek
DerekMD07 is offline   Canada
0
Reply With Quote
      11-05-2008, 03:51 PM   #2
Z4M///ike
Private
 
Drives: 06 Z4 M Roadster/08 E90 M3
Join Date: Sep 2007
Location: SoCal

Posts: 58
iTrader: (0)

Derek, same experience here.

Already took into dealer twice before a tech found the problem: there is a service bulletin on the earlier production 2008 M3 sedans that says that the entire coolant tank/sensor unit is faulty. As long as there is sufficient coolant (just check the level manually), there shouldn't be too big of a problem. However, you should still have it checked out/replaced as soon as possible, as it's covered under warranty.

My scheduled date for bringing the car in and having the coolant tank/sensor entirely replaced is November 13. I'll let you know how it goes.
Z4M///ike is offline  
0
Reply With Quote
      11-05-2008, 06:05 PM   #3
DerekMD07
Private First Class
 
Drives: 2014 335xi LSB/ 2014 X5d M
Join Date: Oct 2008
Location: London, Ontario

Posts: 189
iTrader: (1)

May I ask how many km/miles you have put on your car? I hope this is the last faulty electronic that needs to be replaced. I have many BMWs in the past and never had much problem.

Anyone with the same problem wants to share their experience?

D
DerekMD07 is offline   Canada
0
Reply With Quote
      11-05-2008, 08:07 PM   #4
Z4M///ike
Private
 
Drives: 06 Z4 M Roadster/08 E90 M3
Join Date: Sep 2007
Location: SoCal

Posts: 58
iTrader: (0)

3700 miles so far
Z4M///ike is offline  
0
Reply With Quote
      11-14-2008, 07:40 PM   #5
Murphthesurf
Registered
 
Drives: 2008 M3 E90 Sedan
Join Date: Nov 2008
Location: Truckee, CA

Posts: 3
iTrader: (0)

I have the same problem, have had my 2008 M3 E90 Sedan since early July. Showed up within the first few hundred miles, took it to the dealer twice but light always cleared itself about 5 minuts of running so nothing for them to 'fix'. Coolant level was always okay, didn't even need topping off each time. Took it in again yesterday, left it overnight, and the light did trip for the dealer. They then also told me of the service bulletin, so have it scheduled to have the coolant tank/sensor light replaced next Thursday. We'll see how it works. Otherwise, about 5500 miles on the car (its been a fun summer/fall), and no other problems.
Murphthesurf is offline  
0
Reply With Quote
      11-14-2008, 11:06 PM   #6
Z4M///ike
Private
 
Drives: 06 Z4 M Roadster/08 E90 M3
Join Date: Sep 2007
Location: SoCal

Posts: 58
iTrader: (0)

just got mine back from coolant tank replacement. so far so good
Z4M///ike is offline  
0
Reply With Quote
      11-14-2008, 11:22 PM   #7
boynbeagle7
Private First Class
 
boynbeagle7's Avatar
 
Drives: SG E92 M3
Join Date: Oct 2008
Location: Oregon

Posts: 122
iTrader: (0)

my car always smells like coolant after it is driven hard - is that a symptom?
boynbeagle7 is offline  
0
Reply With Quote
      01-13-2009, 04:11 PM   #8
Murphthesurf
Registered
 
Drives: 2008 M3 E90 Sedan
Join Date: Nov 2008
Location: Truckee, CA

Posts: 3
iTrader: (0)

Quote:
Originally Posted by Murphthesurf View Post
I have the same problem, have had my 2008 M3 E90 Sedan since early July. Showed up within the first few hundred miles, took it to the dealer twice but light always cleared itself about 5 minuts of running so nothing for them to 'fix'. Coolant level was always okay, didn't even need topping off each time. Took it in again yesterday, left it overnight, and the light did trip for the dealer. They then also told me of the service bulletin, so have it scheduled to have the coolant tank/sensor light replaced next Thursday. We'll see how it works. Otherwise, about 5500 miles on the car (its been a fun summer/fall), and no other problems.

Okay, changing the tank fixed the problem. Now up to 9K with no further issues.
Murphthesurf is offline  
0
Reply With Quote
      01-13-2009, 04:12 PM   #9
Murphthesurf
Registered
 
Drives: 2008 M3 E90 Sedan
Join Date: Nov 2008
Location: Truckee, CA

Posts: 3
iTrader: (0)

Quote:
Originally Posted by boynbeagle7 View Post
my car always smells like coolant after it is driven hard - is that a symptom?
In my case, never smelt the coolant.
Murphthesurf is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:44 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST