BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
ESS Tuning
Post Reply
 
Thread Tools Search this Thread
      12-16-2008, 05:14 PM   #45
tightie
JOSH SHOKRI.
tightie's Avatar
United_States
151
Rep
5,768
Posts

 
Drives: 2015 F80 YMB M3
Join Date: Aug 2005
Location: los angeles, california.

iTrader: (7)

Garage List
2008 BMW M3  [3.95]
lemon?
__________________
15 YMB F80 M3 | iND Painted Front Reflectors, Painted Side Marker Set, Rear Painted Emblem & Front Grill Surround| KW 3 Way Clubsport | Gintani Downpipes | Macht Schnell Stud Conversion Kit | JB4 | Too many wheels to list
*Track Day: December 19 @ Willow Springs Raceway
Appreciate 0
      12-16-2008, 10:17 PM   #46
Charminar
Enlisted Member
4
Rep
34
Posts

 
Drives: 2009 M3 E90 DCT
Join Date: Aug 2008
Location: Mercer Island, WA

iTrader: (0)

Quote:
Originally Posted by BIGNTASTIE View Post
This was fixed a whiel ago guys, forgot to post the issue. It was actually the idle valve that failed, and everytime my car slowed down i guess the idle valve sent a false sensor which triggered the messages. Took a while for my dealership to realize, since my SA is a dumbass.
I took the car in this morning...

They diagnosed my problem as a failure of the 'idle actuator'. The part is in Germany and will take 7 days to get here. I'm driving a 328 XI loaner in the meantime..
Appreciate 0
      01-01-2009, 06:50 PM   #47
baarii
Major
baarii's Avatar
United_States
16
Rep
1,116
Posts

 
Drives: ..
Join Date: Sep 2008
Location: I-66

iTrader: (8)

Sad very sad,
I just went out to my car to move it
Got the
Engine Malfunction! Reduced Power
and
DSC Malfunction! Drive carefully

This sucks
Going out to take a picture! lol
Appreciate 0
      01-01-2009, 07:49 PM   #48
baarii
Major
baarii's Avatar
United_States
16
Rep
1,116
Posts

 
Drives: ..
Join Date: Sep 2008
Location: I-66

iTrader: (8)

Ok i went out again to take some pictures the screen is diff now.
This is what i got now ....




After i sat in it for a few mins this is what came up....



So i decided to let it sit for a bit, engine runing 15 mins later everything dissapeared, all the msgs including the check engine sign and athe DSC light from the cluster

Did i mention its extremely cold out side!

I am still going to the dealer in the morning.
Appreciate 0
      01-01-2009, 11:10 PM   #49
NewM3driver
Captain
14
Rep
656
Posts

 
Drives: 2008 m3 sedan
Join Date: Nov 2008
Location: CT

iTrader: (0)

No big deal. Just get the car in to the service dept asap. I'm sure they will reset something in the software and you will be on your way,

Good luck.
Appreciate 0
      01-01-2009, 11:23 PM   #50
arcsynesis
Enlisted Member
0
Rep
32
Posts

 
Drives: e92 m3
Join Date: Jun 2008
Location: las vegas, nv

iTrader: (0)

I have the same messages come up on mine. It works fine the first 5 min. or so after starting then the messages come up. Taking it in on Tuesday to see wth is going on.
Appreciate 0
      01-01-2009, 11:33 PM   #51
skierman64
Brigadier General
skierman64's Avatar
United_States
43
Rep
3,068
Posts

 
Drives: 2008 E92 Space Gray M3 & E36M3
Join Date: Dec 2006
Location: Greater St Louis Metro area

iTrader: (1)

Garage List
1998 M3 Coupe  [0.00]
2008 M3 Coupe  [0.00]
Send a message via Yahoo to skierman64
Quote:
Originally Posted by baarii View Post
I get the same warning after eating at Taco Bell.
__________________
Get a professional motorsports full featured stopwatch app for your Blackberry here: http://appworld.blackberry.com/webstore/content/19464
Invest Wisely...The best mod for your money?? BMWCCA high performance driver's school. The mod that lasts a lifetime and improves the performance of any car you drive
Appreciate 0
      01-06-2009, 10:56 PM   #52
Edman951
Second Lieutenant
Edman951's Avatar
Canada
10
Rep
285
Posts

 
Drives: F10 550xi, Alpine white
Join Date: Nov 2006
Location: Montreal, Quebec

iTrader: (1)

Quote:
By the way, have you been using the ipod connector bc I have suspicion that it was related to my ipod I know that sounds ridiculous, but it happened soon after I plugged it in the second time. I can't figure out what else could have happend and SA said they have not seen this problem in a long time. Could have also simply been a faulty part
I just installed last night my new BMW performance steering wheel and the BMW Ipod cable that i bought from Tischer.

And after 1 mile, boom DSC goes off, TPMS goes off, brake assist goes off to i think. even low washer fluid light up.
Now DSC stays off, TPMS warning come on.
I don't have idrive so it look different then you.
The funny thing is that I beleive that Canadian cars don't even have the TPMS sensors in the wheel as it as been said here before. Plus the fact that it will not reinitialise.
The car really feels funny when i drive it, almost wabbly...

Man could it really be the Ipod cable that made the car go off?????
Or just a quincidance...
Appreciate 0
      01-06-2009, 11:22 PM   #53
arcsynesis
Enlisted Member
0
Rep
32
Posts

 
Drives: e92 m3
Join Date: Jun 2008
Location: las vegas, nv

iTrader: (0)

Guys, I just took my car in this morning to the dealership for these same error messages (DSC Malfunction, Increased Emissions). The called me tonight and said that it was the throttle actuator. This is of course a part they have to order and won't be in until Thursday.

Does anyone know what the throttle actuator actually does and how would that cause all of these messages?
Appreciate 0
      01-07-2009, 12:15 AM   #54
BIGNTASTIE
Lieutenant
BIGNTASTIE's Avatar
10
Rep
589
Posts

 
Drives: white/red 08 M3, 05 Rangerover
Join Date: Jul 2008
Location: queens, NY

iTrader: (0)

Quote:
Originally Posted by arcsynesis View Post
Guys, I just took my car in this morning to the dealership for these same error messages (DSC Malfunction, Increased Emissions). The called me tonight and said that it was the throttle actuator. This is of course a part they have to order and won't be in until Thursday.

Does anyone know what the throttle actuator actually does and how would that cause all of these messages?
well, since mine is fixed, they told me it was the Idle valve that was broken?? Maybe thats the same thing as an idle valve. anyway they had to order mine too, and it was fixed two days later as well. Drove 1000 miles since that and nothing wrong *knocks on wood* . If yours is also the Idle valve , than its no problem, its just a sensor thats malfunctioning.. do these messages show up when your driving slow??
__________________
hi
Appreciate 0
      01-07-2009, 12:21 AM   #55
arcsynesis
Enlisted Member
0
Rep
32
Posts

 
Drives: e92 m3
Join Date: Jun 2008
Location: las vegas, nv

iTrader: (0)

Quote:
Originally Posted by BIGNTASTIE View Post
well, since mine is fixed, they told me it was the Idle valve that was broken?? Maybe thats the same thing as an idle valve. anyway they had to order mine too, and it was fixed two days later as well. Drove 1000 miles since that and nothing wrong *knocks on wood* . If yours is also the Idle valve , than its no problem, its just a sensor thats malfunctioning.. do these messages show up when your driving slow??
So far they have been showing up when driving slow. Is that what happened with yours?
Appreciate 0
      01-07-2009, 12:30 AM   #56
e46e92love
Brigadier General
e46e92love's Avatar
United_States
37
Rep
3,059
Posts

 
Drives: e92 ///M3; X3 (wife's)
Join Date: Nov 2007
Location: The East Side of Things

iTrader: (0)

Send a message via AIM to e46e92love
Quote:
Originally Posted by ybbiz34 View Post
When there are that many errors at once the screen should just say: "FAIL."
__________________

"...it's not about the money and not about the brand of the car, it's about handling,performance and passion......And that, no other car has all together like an M3........when you talk about the most complete car the M is invincible." --Tony Kanaan.
Appreciate 0
      01-07-2009, 01:22 AM   #57
baarii
Major
baarii's Avatar
United_States
16
Rep
1,116
Posts

 
Drives: ..
Join Date: Sep 2008
Location: I-66

iTrader: (8)

Quote:
Originally Posted by skierman64 View Post
I get the same warning after eating at Taco Bell.
LOLL

OK so i went to the dearler there was no problem msgs went away.
SA said "its just too cold..thats it, nothing to worry about." lol, i came home part happy (didnt have to leave it there and drove it) part worried...
Appreciate 0
      01-07-2009, 02:07 AM   #58
BIGNTASTIE
Lieutenant
BIGNTASTIE's Avatar
10
Rep
589
Posts

 
Drives: white/red 08 M3, 05 Rangerover
Join Date: Jul 2008
Location: queens, NY

iTrader: (0)

Quote:
Originally Posted by arcsynesis View Post
So far they have been showing up when driving slow. Is that what happened with yours?
yep, after a long drive or w/e and you slow down it pops up right?? now im 90% sure yours is the idle valve too. Idle valve basically keeps the rpms in the right spot when your "idling", so its some what of a sensor malfunction. Don't worry about it, no big deal. You'll get it fixed
__________________
hi
Appreciate 0
      01-07-2009, 02:51 AM   #59
Charminar
Enlisted Member
4
Rep
34
Posts

 
Drives: 2009 M3 E90 DCT
Join Date: Aug 2008
Location: Mercer Island, WA

iTrader: (0)

Quote:
Originally Posted by arcsynesis View Post
Guys, I just took my car in this morning to the dealership for these same error messages (DSC Malfunction, Increased Emissions). The called me tonight and said that it was the throttle actuator. This is of course a part they have to order and won't be in until Thursday.

Does anyone know what the throttle actuator actually does and how would that cause all of these messages?
Yup, I've had the same issue and same fix.. My dealer has been waiting 3 weeks to get this part in from Germany....

Good luck!!
Appreciate 0
      01-07-2009, 09:32 AM   #60
emthree4me
Private First Class
4
Rep
129
Posts

 
Drives: 09 M3 e92
Join Date: Nov 2008
Location: NoVa

iTrader: (0)

sounds likethe car is going for the Lemon Law
Appreciate 0
      01-07-2009, 10:43 PM   #61
homel01
New Member
0
Rep
25
Posts

 
Drives: E92 M3 DCT
Join Date: Sep 2008
Location: Puerto Rico

iTrader: (0)

This is bullshit my car was fully reprogramed they kept the car for like 5 hours and gave it back and the stupid thing went on again
Appreciate 0
      01-07-2009, 10:45 PM   #62
homel01
New Member
0
Rep
25
Posts

 
Drives: E92 M3 DCT
Join Date: Sep 2008
Location: Puerto Rico

iTrader: (0)

same warnings all over the place dct malfunction, increased emision, check engine on

Im really not loving the car anymore

"and there he goes..... another unhappy costumer that wont buy one of our cars anymore...."
Appreciate 0
      01-08-2009, 05:50 PM   #63
Edman951
Second Lieutenant
Edman951's Avatar
Canada
10
Rep
285
Posts

 
Drives: F10 550xi, Alpine white
Join Date: Nov 2006
Location: Montreal, Quebec

iTrader: (1)

It wasn`t the Ipod cable making the fritz, even do it was a funny coincidence that other had the same problem after using the cable.

Its seems my problem with the DSC malfunction, TPMS malfunction was do to the BMW performance streering wheel I installed myself.
The service tech told me the steering angle sensor need to be recalibrated/ reinitialized after the install. As the DSC could not see the steering angle.
Even do i followed the BMW instructions, and they don't talk about angle sensor.
Will see tomorrow if all is fine when i pick it up.
Appreciate 0
      01-09-2009, 02:30 PM   #64
tmntmn
///M
United_States
44
Rep
1,903
Posts

 
Drives: e92 M3/M-DCT
Join Date: Feb 2008
Location: Bay Area

iTrader: (6)

i have the same problem with my e92 m3 dct its still sitting at the dealership waiting for idle senor/valve from Germany to come in, its been over a month now
Appreciate 0
      01-10-2009, 01:37 PM   #65
arcsynesis
Enlisted Member
0
Rep
32
Posts

 
Drives: e92 m3
Join Date: Jun 2008
Location: las vegas, nv

iTrader: (0)

My SA called last night for me to pick up my car this morning. It has been in the shop for four days with them trying to fix the DSC Malfunction, Service Engine Soon warning etc. I just picked my car up from the dealership the "Service Engine Soon" warning is still on! Of course my SA isn't in today and I will have to wait until Monday to do anything about it.

Is there a reset for the Service Engine Soon light that they maybe forgot to turn off or is it refering to something that just has to be fixed that they didn't?
Appreciate 0
      02-10-2009, 01:34 PM   #66
MMMjjLA
New Member
United_States
0
Rep
8
Posts

 
Drives: e92 M3 I.B. MDCT
Join Date: Sep 2008
Location: LA

iTrader: (0)

Send a message via AIM to MMMjjLA
same problem

this is so annoying! i took my car to get my tints and the second startup after i left from the tint shop i got all those errors! DSC malfunction, increased battery discharged, increased emmissions, blabalbal it was weird because the message changed sometimes when i would start it back on. sometimes it would only show
increased emmissions with the engine service soon light on other times dsc malfunction as well...
i took it 10 days ago and they changed the battery but i think another problem came up and now im waiting for the part from germany, my advisors said its something about idle hose or something...might be the same problem...
i have 5000 miles on it and its an 08 what should i ask in terms of compensation?
i already ask for the 09 nav dvd...and a detail.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:06 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST