BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Wheels + Tires Sponsored by The Tire Rack
  TireRack

KEEP M3POST ALIVE BY DOING YOUR TIRERACK SHOPPING FROM THIS BANNER LINK!
Post Reply
 
Thread Tools Search this Thread
      07-08-2008, 11:29 AM   #1
Gemcoska
Sleepy Member, wishing I was on the road.
 
Gemcoska's Avatar
 
Drives: 2008 BMW M3
Join Date: Feb 2008
Location: Redondo Beach, CA

Posts: 277
iTrader: (0)

Rust in my wheels

I've got 19" OEMs and I've noticed rust IN my wheels after recent washes. It looks like the rust washes off something else and pools up in my wheels behind the spokes then dries up, not my actual wheels rusting themselves.

Anyone have this problem or have suggestions on how to fix it?

Thanks.
__________________
2003 Ducati '996
2008 M3: Sparking Graphite, Red Fox Standard, 19s, Premium pkg, Tech pkg, Premium Enhanced Sound, HD Radio, Heated Front Seats.
Gemcoska is offline  
0
Reply With Quote
      07-08-2008, 11:43 AM   #2
Gearhead999s
Major General
 
Gearhead999s's Avatar
 
Drives: F25 2.8d(wifes)F82 M4
Join Date: Apr 2007
Location: Toronto

Posts: 6,773
iTrader: (0)

I have the same thing and I beleive its wash down from the brake rotors and pads.I have cleaned the wheels once off the car when I had my track tires on and its shown up again after a few weeks and washes.I now intend to keep my wheels bathed in brake dust from enjoying the car,so I do not notice the rust runoff
Gearhead999s is offline  
0
Reply With Quote
      07-08-2008, 11:48 AM   #3
AwesomeM3
Major
 
AwesomeM3's Avatar
 
Drives: E92 M3, E70 X5, 1967 Corvette
Join Date: Oct 2007
Location: New Jersey

Posts: 1,453
iTrader: (0)

Garage List
2008 M3  [5.00]
2009 X5 48i M Sport  [5.00]
(SOLD) 2001 M3  [0.00]
I have the same problem. Never had it with my E46 M3.
__________________

2008 E92 M3 Coupe 6MT | 2009 E70 X5 xDrive 48i M Sport | 1967 Corvette Coupe
2001 E46 M3 - Sold | 1997 E36 M3 - Sold | BMW CCA member
AwesomeM3 is offline   United_States
0
Reply With Quote
      07-08-2008, 12:33 PM   #4
ben@tirerack
M3Post Supporting Vendor
 
Drives: 740i
Join Date: Mar 2008
Location: South Bend, IN

Posts: 859
iTrader: (0)

Rust off the rotors is the likely culprit. Aluminum wheels do not rust in the same way that iron or steel does. Oxidization on aluminum is more blackish, not the orange-looking rust that comes from iron/steel.
__________________
_______________________________________________



To credit the forum, click through one of the banners in my signature and the top of the page, or call me direct at 877.522.8473 ext 660. Email:ben@tirerack.com
ben@tirerack is offline  
0
Reply With Quote
      07-08-2008, 12:58 PM   #5
Gemcoska
Sleepy Member, wishing I was on the road.
 
Gemcoska's Avatar
 
Drives: 2008 BMW M3
Join Date: Feb 2008
Location: Redondo Beach, CA

Posts: 277
iTrader: (0)

Sooo... no solution?
__________________
2003 Ducati '996
2008 M3: Sparking Graphite, Red Fox Standard, 19s, Premium pkg, Tech pkg, Premium Enhanced Sound, HD Radio, Heated Front Seats.
Gemcoska is offline  
0
Reply With Quote
      07-08-2008, 01:18 PM   #6
AwesomeM3
Major
 
AwesomeM3's Avatar
 
Drives: E92 M3, E70 X5, 1967 Corvette
Join Date: Oct 2007
Location: New Jersey

Posts: 1,453
iTrader: (0)

Garage List
2008 M3  [5.00]
2009 X5 48i M Sport  [5.00]
(SOLD) 2001 M3  [0.00]
Quote:
Originally Posted by AwesomeM3 View Post
I have the same problem. Never had it with my E46 M3.
Quote:
Originally Posted by ben@tirerack View Post
Rust off the rotors is the likely culprit. Aluminum wheels do not rust in the same way that iron or steel does. Oxidization on aluminum is more blackish, not the orange-looking rust that comes from iron/steel.
I should have been more specific...the rust on my M3 is coming from the rotors, not the wheel. I notice it after I wash my car.
__________________

2008 E92 M3 Coupe 6MT | 2009 E70 X5 xDrive 48i M Sport | 1967 Corvette Coupe
2001 E46 M3 - Sold | 1997 E36 M3 - Sold | BMW CCA member
AwesomeM3 is offline   United_States
0
Reply With Quote
      07-08-2008, 06:08 PM   #7
JAJ
Captain
 
Drives: 2014 Shelby GT500
Join Date: Apr 2008
Location: Vancouver, BC

Posts: 927
iTrader: (4)

Mine had rust forming on the inside of the wheel hubs (behind the roundel hubcap) and I just put a thin smear of oil (WD 40 would have done) on it when the rims were off.

There was also a red stain on the rims at the hub - the factory puts a coat of copper-based anti-sieze on the hub so the rims don't stick - this is not rust!
JAJ is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:43 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST