BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > DIY Guides/ Discussions
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      06-24-2009, 09:38 AM   #67
schadenfreude
Lieutenant
United_States
4

 
schadenfreude's Avatar
 
Drives: '09 E90 M-DCT M3
Join Date: Jul 2008
Location: Seattle, WA


Posts: 424
iTrader: (0)

Garage List
2009 E90 M3  [0.00]
I have only installed the motion sensor for that reason (don't want the siren to go off for no reason), and the other day my flashers went off when at a meetup and an old Aston cranked up. I had locked the car to go for brunch, and came back with the hazards on. Not sure whether it was the exhaust or someone touched the car, but they turned off when I hit the comfort access.
__________________
AiB LEDs///MS Filter///Hardwired V1///VentureShield///F1 Pinnacle 35%///IND Reflectors///BMW Performance Grills
Appreciate 0
      07-04-2009, 04:25 AM   #68
MDCTFTW
Lieutenant Colonel
39

 
Drives: E92 DCT
Join Date: Apr 2008
Location: Norcal


Posts: 1,974
iTrader: (0)

I JUST my alarm coded since I wrote this up. Haha. Works like a charm.

I'm uploading a pic of the hood switch for Thinker23 who wanted to see where it's supposed to go ...
Attached Images
 
__________________


MDCT ... so you can drive and eat a hamburger at the same time.
Appreciate 0
      07-05-2009, 09:53 PM   #69
GregW / Oregon
Commander-In-Chief
United_States
136

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR


Posts: 7,614
iTrader: (2)

Garage List
Quote:
Originally Posted by MDCTFTW View Post
I'm uploading a pic of the hood switch for Thinker23 who wanted to see where it's supposed to go ...
Didn't your car come with the hood switch already installed? Mine did.
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      07-06-2009, 11:04 PM   #70
MDCTFTW
Lieutenant Colonel
39

 
Drives: E92 DCT
Join Date: Apr 2008
Location: Norcal


Posts: 1,974
iTrader: (0)

Quote:
Originally Posted by GregW / Oregon View Post
Didn't your car come with the hood switch already installed? Mine did.
Oh mine did come with it installed, but Thinker has an 09 build that doesn't come pre-wired for the oem alarm. He was wondering where it's supposed to go so he could check.
__________________


MDCT ... so you can drive and eat a hamburger at the same time.
Appreciate 0
      07-07-2009, 12:55 AM   #71
endofanera7
Major General
No_Country
118

 
endofanera7's Avatar
 
Drives: 08 JB E92 M3
Join Date: Sep 2008
Location: Bay Area, CA


Posts: 5,183
iTrader: (15)

Garage List
2008 E92 M3  [5.00]
Send a message via AIM to endofanera7 Send a message via MSN to endofanera7
My dealership wants $185 for the activation and they say it's a half day job...is that true?
Appreciate 0
      07-07-2009, 02:01 AM   #72
MDCTFTW
Lieutenant Colonel
39

 
Drives: E92 DCT
Join Date: Apr 2008
Location: Norcal


Posts: 1,974
iTrader: (0)

Quote:
Originally Posted by endofanera7 View Post
My dealership wants $185 for the activation and they say it's a half day job...is that true?
Damn that's a lot. I'm not sure, but I think it runs at least $100. I got mine hooked up while getting some work done on the car.
__________________


MDCT ... so you can drive and eat a hamburger at the same time.
Appreciate 0
      07-07-2009, 03:58 AM   #73
rbk1115
Lieutenant
United_States
7

 
rbk1115's Avatar
 
Drives: Acuras & BMWs
Join Date: Mar 2009
Location: San Diego, CA


Posts: 527
iTrader: (0)

Garage List
Quote:
Originally Posted by endofanera7 View Post
My dealership wants $185 for the activation and they say it's a half day job...is that true?
My dealership charged me 1 hour of labor which was $130. I was told it would take some time as there were other cars to be programmed so they gave me a loaner. I got a phone call about 3 hours later and the car was finished. Good luck!
__________________

2009 BMW M3 Sedan
2013 BMW 535i M Sport Sedan
2014 Mazda3 i Touring Sedan
Appreciate 0
      07-07-2009, 07:18 AM   #74
JuniorDee
Captain
15

 
JuniorDee's Avatar
 
Drives: the speed limit
Join Date: Apr 2007
Location: the land of brat and brotchen


Posts: 610
iTrader: (1)

I paid $130 also. It took all day but they work on other cars while yours is "downloading" the software. Apparently, the car uses some old fashioned ISA modem to get its updates.....or why else would it take all day?
__________________
EDC.....viagra for your car
Appreciate 0
      07-07-2009, 08:14 AM   #75
GregW / Oregon
Commander-In-Chief
United_States
136

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR


Posts: 7,614
iTrader: (2)

Garage List
Quote:
Originally Posted by JuniorDee View Post
I paid $130 also. It took all day but they work on other cars while yours is "downloading" the software. Apparently, the car uses some old fashioned ISA modem to get its updates.....or why else would it take all day?
Apparently all the modules need to be reprorammed, not just the alarm. Mine ended up taking overnight.
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      07-09-2009, 05:25 PM   #76
Georgeair
Captain
10

 
Drives: '08 Melbourne E92 M3
Join Date: Apr 2009
Location: McKinney, TX


Posts: 757
iTrader: (2)

Like Greg, mine took a while. I've got an '08 purchased 04/09, and apparently there were 2-3 hours of updates that were needed. To further complicate things, the BMW center computer they connected to went down, and apparently it doesn't error out or give any message on the dealer's end. They noticed it had showed 2.5 hours remaining for over an hour and restarted. Thank God they had shuttled me home by then.

Only settings I lost with the full software update were seats and radio presets.
Appreciate 0
      08-05-2009, 10:21 AM   #77
TOOMANYCARS
Second Lieutenant
2

 
TOOMANYCARS's Avatar
 
Drives: 2009 E92 M3
Join Date: Aug 2009
Location: V.O.W


Posts: 221
iTrader: (0)

Just installed mine, very easy. A note to the OP, it's 10mm & 8mm sockets you need, not 6mm.
Appreciate 0
      01-26-2010, 06:17 PM   #78
exssive
Enlisted Member
2

 
Drives: 08 E92 M3 M6
Join Date: Jan 2010
Location: Indy


Posts: 45
iTrader: (1)

Question, after installing the alarm and reconnecting the negative cable to the battery, are there any codes you have to re-enter for the radio..etc?
Appreciate 0
      01-26-2010, 06:49 PM   #79
GregW / Oregon
Commander-In-Chief
United_States
136

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR


Posts: 7,614
iTrader: (2)

Garage List
Quote:
Originally Posted by exssive View Post
Question, after installing the alarm and reconnecting the negative cable to the battery, are there any codes you have to re-enter for the radio..etc?
Don't know - I skipped disconnecting the battery, though that's not the right thing to do. They make a little cigarette lighter adapter that accepts a 9V battery for maintaining radio codes. Not sure if it's required to do that on our cars. Unlike the E46, I don't think I got radio codes with this car.
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      01-27-2010, 12:14 AM   #80
aus
Major General
114

 
Drives: Odysse
Join Date: Jul 2005
Location: Seal Beach, CA


Posts: 7,375
iTrader: (5)

I remember the official service bulletin saying 1.5 hours should be charged for the install and programming. Unfortunately, my dealer charged 2 hours.

It's not really worth installing yourself since you're really only saving 30 minutes labor and there have been reports of the dealer saying they couldn't program it because it wasn't installed right, so they charged for install anyway.
__________________
Let me get this straight... You are swapping out parts designed by some of the top engineers in the world because some guys sponsored by a company told you it's "better??" But when you ask the same guy about tracking, "oh no, I have a kid now" or "I just detailed my car." or "i just got new tires."
Appreciate 0
      02-17-2010, 04:32 PM   #81
exssive
Enlisted Member
2

 
Drives: 08 E92 M3 M6
Join Date: Jan 2010
Location: Indy


Posts: 45
iTrader: (1)

This DIY is great! I installed mine by memory after studying this post. My M3 was in for service and I had them code the alarm, I got a call telling me they were having a problem and was it installed on a car previously. After installing the updates it was fine and I didn't lose any of my stereo, i-drive settings.
__________________


08 Space Gray E92, 6MT, Premium, Tech, Fox Red, Style 220M wheels.
Appreciate 0
      02-21-2010, 01:57 AM   #82
aajami
Brigadier General
United_States
64

 
aajami's Avatar
 
Drives: Space Gray '09 E92 M3
Join Date: Dec 2008
Location: Manhattan Beach, CA


Posts: 4,051
iTrader: (4)

I used this DIY to install the alarm over the weekend. The whole process was straightforward, and the only hassle I ran into was removing the fender liner.

By the way, I noticed a little bit of rust on my wheel hub when I removed the driver side rear wheel. Is that normal? Did anyone else notice that?
__________________
'09 E92 M3: Space Gray, Black, Carbon Leather | ZTP 2MK ZPP 2MT 6FL | link 1 / link 2
Mods: M Performance exhaust | ZCP retrofit | Euro airbox | GTS DCT flash | 240J ECU flash | LCI Euro taillights | CRT lip | OEM alarm retrofit | Space Gray bumper plugs | BMW Performance: Mk. II spoiler / Mk. II non-electronic steering wheel / mirror caps / front grilles / side gills / intake louvers / emblem
Appreciate 0
      02-21-2010, 12:14 PM   #83
GregW / Oregon
Commander-In-Chief
United_States
136

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR


Posts: 7,614
iTrader: (2)

Garage List
Quote:
Originally Posted by aajami View Post
By the way, I noticed a little bit of rust on my wheel hub when I removed the driver side rear wheel. Is that normal? Did anyone else notice that?
Yes, rust there is pretty normal.
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      02-21-2010, 12:16 PM   #84
GregW / Oregon
Commander-In-Chief
United_States
136

 
Drives: 2015 M4 Coupe, 2012 ML350
Join Date: Nov 2005
Location: Lake Oswego, OR


Posts: 7,614
iTrader: (2)

Garage List
Quote:
Originally Posted by aajami View Post
By the way, I noticed a little bit of rust on my wheel hub when I removed the driver side rear wheel. Is that normal? Did anyone else notice that?
Yes, rust there is pretty normal. See photo #7 in the OP.
__________________

Greg Lake Oswego, Oregon, USA
2015 M4 Coupe - Silverstone/Sakhir/CF
2012 ML350
Appreciate 0
      02-21-2010, 01:47 PM   #85
aajami
Brigadier General
United_States
64

 
aajami's Avatar
 
Drives: Space Gray '09 E92 M3
Join Date: Dec 2008
Location: Manhattan Beach, CA


Posts: 4,051
iTrader: (4)

Noted. Thanks!
__________________
'09 E92 M3: Space Gray, Black, Carbon Leather | ZTP 2MK ZPP 2MT 6FL | link 1 / link 2
Mods: M Performance exhaust | ZCP retrofit | Euro airbox | GTS DCT flash | 240J ECU flash | LCI Euro taillights | CRT lip | OEM alarm retrofit | Space Gray bumper plugs | BMW Performance: Mk. II spoiler / Mk. II non-electronic steering wheel / mirror caps / front grilles / side gills / intake louvers / emblem
Appreciate 0
      02-21-2010, 03:13 PM   #86
H8cold
Enlisted Member
2

 
Drives: M3 Conv.
Join Date: Feb 2010
Location: Virginia


Posts: 41
iTrader: (0)

Installed my alarm had it activiated, but no motion sensor? why?
Appreciate 0
      02-21-2010, 06:19 PM   #87
exssive
Enlisted Member
2

 
Drives: 08 E92 M3 M6
Join Date: Jan 2010
Location: Indy


Posts: 45
iTrader: (1)

how are you trying to check that it works?
__________________


08 Space Gray E92, 6MT, Premium, Tech, Fox Red, Style 220M wheels.
Appreciate 0
      02-26-2010, 10:23 AM   #88
Georgeair
Captain
10

 
Drives: '08 Melbourne E92 M3
Join Date: Apr 2009
Location: McKinney, TX


Posts: 757
iTrader: (2)

I'm not sure it's a motion sensor. I think it may be a glass breakage detector.

That, I wouldn't test BTW!
__________________
Objects in mirror are slower than they appear.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:16 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST