BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > DIY Guides/ Discussions
 
Strasse Wheels
Post Reply
 
Thread Tools Search this Thread
      10-09-2008, 07:18 PM   #1
ChinoOrtega
Captain
ChinoOrtega's Avatar
Guatemala
15
Rep
604
Posts

 
Drives: 991 C2S
Join Date: Apr 2007
Location: Guatemala

iTrader: (0)

Help installing AFE filter...

Badfish posted this DIY, but I can't get the spring loaded black rod to hold the filter in place, it's too short, please help, I'm trying to do it right now
Attached Images
 
Appreciate 0
      10-09-2008, 07:36 PM   #2
badfish
Major
badfish's Avatar
35
Rep
1,035
Posts

 
Drives: E92 AW M3
Join Date: Feb 2008
Location: SoCal

iTrader: (0)

Garage List
2008 M3  [0.00]
The little spring loaded rod should stick out similar to the picture below. If it doesn't stick out that far, it's stuck somehow. Mine was real strong and I can't imagine it getting stuck. Make sure that the hose and plastic adapter that plug into the filter (top portion of the picture) is correctly in place.

__________________
Appreciate 0
      10-09-2008, 07:51 PM   #3
Space Ghost
Captain
Space Ghost's Avatar
United_States
6
Rep
625
Posts

 
Drives: E92 M3
Join Date: Aug 2008
Location: USA-PA

iTrader: (5)

There is a top and bottom for the filter. notice its angled shape. did you try turning it over? also check all of your other connections where the hose clamps attach.
Appreciate 0
      10-09-2008, 07:53 PM   #4
BCMPOWER
Captain
BCMPOWER's Avatar
United_States
7
Rep
626
Posts

 
Drives: 08 Silverstone II M3
Join Date: Dec 2007
Location: Silver Spring MD

iTrader: (0)

ChinoOrtega try spraying the spring loaded knob with some WD40 to free it so it comes unstuck.
__________________
Appreciate 0
      10-09-2008, 08:24 PM   #5
badfish
Major
badfish's Avatar
35
Rep
1,035
Posts

 
Drives: E92 AW M3
Join Date: Feb 2008
Location: SoCal

iTrader: (0)

Garage List
2008 M3  [0.00]
I would try to tap it loose first with a soft hammer. WD40 might end up attracting more dust and particles to make it stuck again later on.

See this thread for someone with the same problem.
__________________
Appreciate 0
      10-09-2008, 09:19 PM   #6
ChinoOrtega
Captain
ChinoOrtega's Avatar
Guatemala
15
Rep
604
Posts

 
Drives: 991 C2S
Join Date: Apr 2007
Location: Guatemala

iTrader: (0)

I took apart the whole piece, but it seems that the Euro version has a shorter rod, I took it apart and it's not stuck, it's shorter, for some reason, Here's a pic, as you can see the round portion of the rod is the one that is smaller, not the base, what I did was cut the base on the OEM filter and glued it to the AFE one so it will hold it in place, but for some reason it's the Euro spec, as e mack from Australia and I get the Euro spec, that's all I can think about, weird.
Attached Images
  
Appreciate 0
      10-10-2008, 11:28 AM   #7
scsi20191
Enlisted Member
United_States
0
Rep
35
Posts

 
Drives: 2009 E90 M3
Join Date: Sep 2008
Location: NoVa

iTrader: (0)

Hey Chapin!

Where in Guatemala do you live?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:57 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST