BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
Post Reply
 
Thread Tools Search this Thread
      07-02-2016, 03:51 PM   #1
MTM
First Lieutenant
9
Rep
326
Posts

Drives: 2009 M3
Join Date: Sep 2011
Location: Houston

iTrader: (1)

Squeaking noise with throttle

M3'ers,

Got a weird one. I noticed today there is a distinctive squeaking noise when I depress the accelerator pedal (can only hear it when car is not running and ignition is in ON position).

Am thinking I need to grease the TB actuator linkages.

Other thoughts?
Appreciate 0
      07-02-2016, 08:26 PM   #2
rocket_science
424 ASP
rocket_science's Avatar
United_States
24
Rep
215
Posts

Drives: '11 AW E92 M3 ZCP
Join Date: Apr 2011
Location: Fort Myers, FL / Pittsburgh, PA

iTrader: (6)

Quote:
Originally Posted by MTM
M3'ers,

Got a weird one. I noticed today there is a distinctive squeaking noise when I depress the accelerator pedal (can only hear it when car is not running and ignition is in ON position).

Am thinking I need to grease the TB actuator linkages.

Other thoughts?
Definitely the ICV.. they do that. I just replaced mine with a brand new OEM and it still does it. I wouldn't even worry about it if you can't even hear it with the engine on...
Appreciate 0
      08-07-2016, 10:30 PM   #3
M3amigos
HP addict
M3amigos's Avatar
United_States
10
Rep
312
Posts

Drives: 2008 Jerez Black E93 6MT
Join Date: Nov 2012
Location: Orlando, FL

iTrader: (0)

i would agree that you should lube up the throttle body linkage. when the ignition is on and you press the gas, the actuators are opening and closing. if you can, check the gears while you are in there.
Appreciate 0
      08-08-2016, 01:10 AM   #4
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
474
Rep
5,863
Posts


Drives: Harrop M3 / F10 M5 / F82 M4
Join Date: Apr 2008
Location: SoCal

iTrader: (9)

Garage List
2015 BMW M3  [0.00]
2015 BMW M5  [0.00]
2008 BMW M3  [3.50]
2004 BMW M3  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by rocket_science
Quote:
Originally Posted by MTM
M3'ers,

Got a weird one. I noticed today there is a distinctive squeaking noise when I depress the accelerator pedal (can only hear it when car is not running and ignition is in ON position).

Am thinking I need to grease the TB actuator linkages.

Other thoughts?
Definitely the ICV.. they do that. I just replaced mine with a brand new OEM and it still does it. I wouldn't even worry about it if you can't even hear it with the engine on...
This is not the ICV but the actuator linkages.

It's normal and they all do it.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      08-22-2016, 08:10 PM   #5
MTM
First Lieutenant
9
Rep
326
Posts

Drives: 2009 M3
Join Date: Sep 2011
Location: Houston

iTrader: (1)

Thanks! I appreciate the responses. Might put a little grease on them when I have the plenum cover off later.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:16 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST