BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
EXXEL Distributions
Post Reply
 
Thread Tools Search this Thread
      07-06-2014, 11:22 PM   #1
Petros
Banned
49
Rep
1,382
Posts

Drives: M3
Join Date: Jan 2014
Location: Canada

iTrader: (1)

Check engine light on the track, Vanos timing problem???

Just came home from the track where I was driving pretty good till the car threw a check engine light, something which is becoming a common occurrence with this car

When I came home I scanned the car and found 2 codes, the generic OBD code P000A, and BMW code 271A. It seems to have something to do with intake vanos timing on bank 1. What can be the cause of this? Bad camshaft position sensor? Possible oil starvation on the track? No, my oil level never went down below the minimim but the temps were quite high at over 130 Celsius. I cleared the codes and obviously I don't have a clue if the problem will happen again or not. And no, there are no unusual sights, sounds, or odors from the car.
Appreciate 0
      05-21-2017, 10:37 PM   #2
Titan_br
Private First Class
Titan_br's Avatar
Brazil
5
Rep
123
Posts

Drives: M3 E92 with AA Stage 3 SC
Join Date: Feb 2014
Location: Rio de Janeiro, Brazil

iTrader: (0)

Garage List
2011 BMW M3  [0.00]
I have this. Did not got on track but on road.

No one to help ?
Appreciate 0
      05-29-2017, 11:49 AM   #3
Olly-R
Registered
1
Rep
3
Posts

Drives: E92 M3 07
Join Date: Apr 2017
Location: UK West Sussex

iTrader: (0)

best to look at the live data for camshaft position of all 4 cams and see the real time position of these cams on a proper diagnostic computer, i bought my car with these codes, new solenoids no change, in the end 2,000 miles latter it went to limp mode and my inlet bank2 cam sprocket had failed/broke up!
Appreciate 0
      06-01-2017, 04:16 PM   #4
Titan_br
Private First Class
Titan_br's Avatar
Brazil
5
Rep
123
Posts

Drives: M3 E92 with AA Stage 3 SC
Join Date: Feb 2014
Location: Rio de Janeiro, Brazil

iTrader: (0)

Garage List
2011 BMW M3  [0.00]
I am following live and the vanos stuck on 133 degrees, it moves from 133.1 to 133.6 etc, but does not follow the nominal position for 117 for example...
it does not lose power i think (nothing I could notice - mine is Supercharged) but still very weird.
I already change vanos 1 to 2 and 2 to 1, and still error on bank 1.
Appreciate 0
      08-29-2017, 06:22 PM   #5
Titan_br
Private First Class
Titan_br's Avatar
Brazil
5
Rep
123
Posts

Drives: M3 E92 with AA Stage 3 SC
Join Date: Feb 2014
Location: Rio de Janeiro, Brazil

iTrader: (0)

Garage List
2011 BMW M3  [0.00]
Anyone can help me? I have the 271A..
Appreciate 0
      08-30-2017, 01:50 AM   #6
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
799
Rep
6,414
Posts


Drives: Harrop M3 / F10 M5 / F82 M4
Join Date: Apr 2008
Location: SoCal

iTrader: (9)

Garage List
2000 BMW M5  [0.00]
1990 BMW 735i Turbo  [0.00]
2008 BMW M3  [3.75]
2015 BMW M3  [0.00]
2015 BMW M5  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by Titan_br View Post
Anyone can help me? I have the 271A..
Have someone with the proper tools perform a VANOS system test. Probably a problem with it. If it's only moving .5 degrees while the other bank has more movement, that's indicative of a problem.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 1
      08-31-2017, 11:22 PM   #7
Titan_br
Private First Class
Titan_br's Avatar
Brazil
5
Rep
123
Posts

Drives: M3 E92 with AA Stage 3 SC
Join Date: Feb 2014
Location: Rio de Janeiro, Brazil

iTrader: (0)

Garage List
2011 BMW M3  [0.00]
Quote:
Originally Posted by Mike Benvo View Post
Have someone with the proper tools perform a VANOS system test. Probably a problem with it. If it's only moving .5 degrees while the other bank has more movement, that's indicative of a problem.
Thank you.

I will use bmw insta D to perform VANOS Testing
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:28 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST