BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
BPM
Post Reply
 
Thread Tools Search this Thread
      07-03-2014, 02:19 PM   #1
bimdo
Lieutenant
bimdo's Avatar
United_States
19
Rep
486
Posts

Drives: 2008 e90 m3
Join Date: Jan 2012
Location: usa

iTrader: (0)

Oil Level Funkiness

About 2000 miles after an oil change,the add 1 qt. message came on. I check it pretty regularly,and had seen it full after the change,and gradually going down over time.I added 1/2 qt. which the mechanic had given me,left over from the oil change. Three days and very few miles later,the add 1 qt. message came on again right before i got home,so i decided to wait until the next day and not add any more.Today the add 1 qt. warning is gone,and the oil reads full on the electronic "dipstick" (using the term loosely since i ,like many others,would much prefer the real thing.)

Any suggestions,anyone else encounter this?
Appreciate 0
      07-03-2014, 02:21 PM   #2
dparm
But doctor...I am Pagliacci.
dparm's Avatar
United_States
168
Rep
2,863
Posts

Drives: 2011.5 E90 M3
Join Date: Jun 2013
Location: Chicago, IL

iTrader: (0)

Are you checking it and topping it off consistently each time? That is, are you doing it under the same conditions? (i.e. after the same type of drive, level surface, engine at the right temp, etc)

Is this the first time you've seen it consume that quantity of oil that fast? Did you check for leaks under the car/bellypan?
__________________
2011.5 AW M3 sedan ZCP
Appreciate 0
      07-03-2014, 02:29 PM   #3
bimdo
Lieutenant
bimdo's Avatar
United_States
19
Rep
486
Posts

Drives: 2008 e90 m3
Join Date: Jan 2012
Location: usa

iTrader: (0)

i have not checked it under consistent conditions. i have had to add a quart after 2500 miles before.
Appreciate 0
      07-03-2014, 02:30 PM   #4
thekurgan
Bad Lieutenant
thekurgan's Avatar
United_States
134
Rep
3,514
Posts

Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

iTrader: (0)

Garage List
2008 BMW M3  [0.00]
I had this happen recently, the indicator showing low, then the next day, full, back and forth for a couple of weeks. Changing out the oil sensor solved the issue, and the oil was 2 ticks below max and it hasn't moved since, so I would have overfilled if I heeded the first warning to add a quart.
__________________
02 E39M5 | TiAg/Schwartz | Tubi Rumore | Ultimate Ti Pedals | E60 SSK | Jim Blanton 3.45 40/100% | Colby Alcantara | StrongStrut STB
Appreciate 0
      07-03-2014, 04:21 PM   #5
Dannys M3
Captain
Dannys M3's Avatar
United_States
28
Rep
733
Posts

Drives: Jaguar F Type R
Join Date: Sep 2006
Location: South Florida

iTrader: (3)

Garage List
2008 M3  [5.00]
Quote:
Originally Posted by thekurgan View Post
I had this happen recently, the indicator showing low, then the next day, full, back and forth for a couple of weeks. Changing out the oil sensor solved the issue, and the oil was 2 ticks below max and it hasn't moved since, so I would have overfilled if I heeded the first warning to add a quart.
Did you change it out or did you have it done? Just curious how difficult this is.
Appreciate 0
      07-03-2014, 04:24 PM   #6
thekurgan
Bad Lieutenant
thekurgan's Avatar
United_States
134
Rep
3,514
Posts

Drives: E90M3
Join Date: Aug 2007
Location: Sacramento

iTrader: (0)

Garage List
2008 BMW M3  [0.00]
It's simple. I ordered the gasket, but the actual sensor kit came with a new gasket anyway. #6 here, it's just at the bottom of the pan. Note: looks like a new part after 8/10, who knows why.
Attached Images
 
__________________
02 E39M5 | TiAg/Schwartz | Tubi Rumore | Ultimate Ti Pedals | E60 SSK | Jim Blanton 3.45 40/100% | Colby Alcantara | StrongStrut STB
Appreciate 0
      07-05-2014, 11:11 AM   #7
S65 Underdog
Banned
No_Country
2
Rep
165
Posts

Drives: a functional car.
Join Date: Mar 2014
Location: ..........

iTrader: (1)

Best of luck with this OP and thanks for the post. I was wondering what the sensor on the bottom of my pan was. Seems like a easy replace when doing your next oil change.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:58 AM.




m3post
m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST