BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > General M3 Forum (E90 + E92 + E93)
 
Lux Angel Eyes
Post Reply
 
Thread Tools Search this Thread
      07-02-2014, 01:24 PM   #1
Beamerbiggs
Enlisted Member
4

 
Drives: M3
Join Date: Oct 2013
Location: Knoxville


Posts: 38
iTrader: (0)

Has anybody had this happen?

It's just stuck on 99.9 mpg
Attached Images
 
Appreciate 0
      07-02-2014, 01:25 PM   #2
thekurgan
Bad Lieutenant
United_States
39

 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento


Posts: 2,840
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Looks like that shit's broke.
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
Appreciate 0
      07-02-2014, 02:23 PM   #3
wildwestm3
Second Lieutenant
12

 
wildwestm3's Avatar
 
Drives: 2008 M3 Convertible
Join Date: May 2014
Location: Springboro OH


Posts: 239
iTrader: (2)

Quote:
Originally Posted by thekurgan View Post
Looks like that shit's broke.
Good technical answer... LOL
__________________
Thanks,

Dave
Appreciate 0
      07-02-2014, 02:26 PM   #4
EJT86
Private First Class
4

 
EJT86's Avatar
 
Drives: 2011 M3 DCT
Join Date: Mar 2014
Location: Boston, MA


Posts: 170
iTrader: (0)

Getting almost 100mpg!! Don't touch it!
Appreciate 0
      07-02-2014, 02:31 PM   #5
thekurgan
Bad Lieutenant
United_States
39

 
thekurgan's Avatar
 
Drives: E90M3
Join Date: Aug 2007
Location: Sacramento


Posts: 2,840
iTrader: (0)

Garage List
2008 BMW M3  [0.00]
Quote:
Originally Posted by wildwestm3 View Post
Good technical answer... LOL
Hey, I get to have fun in the General area too!


What is your diagnosis?
__________________

08 E90M3 6MT Alpinweiss/Carbon/BMW Pedals/Dinan Exhaust/Rattle fixes
Appreciate 0
      07-02-2014, 02:31 PM   #6
BimmerRookie
Private First Class
United_States
3

 
Drives: 2008 E93 M3 (IB)
Join Date: Jan 2014
Location: Houston, TX


Posts: 132
iTrader: (0)

Looks like you've got 99 problems, but fuel efficiency ain't one
Appreciate 0
      07-02-2014, 02:34 PM   #7
rngrjag
Private First Class
15

 
Drives: E92 M3 ZCP 6MT
Join Date: May 2013
Location: USA


Posts: 155
iTrader: (0)

Ahhhh, you've been using the KERS M button!
Appreciate 0
      07-02-2014, 03:21 PM   #8
M3LISSA
Lieutenant
United_States
8

 
M3LISSA's Avatar
 
Drives: 2011 E90, M3
Join Date: Aug 2009
Location: New York


Posts: 435
iTrader: (0)

Wow this is funny mine says that too! But I only noticed it after I installed my tune... But honestly I never checked before for a long time. I only decided to do it cause the tune is causing my gas to drop mucho fast lol.
__________________
2011 E90 M3 // Alpine White // 20" BBS LM's, blah blah
Appreciate 0
      07-02-2014, 03:26 PM   #9
klammer
Brigadier General
59

 
Drives: 11 spc gry m3 e90, 07 X5
Join Date: Jan 2010
Location: chicago


Posts: 3,243
iTrader: (0)

Happened to me for awhile and then reset back to normal. Gremlins?
__________________
mods: akra evo, dinan 3.45 diff, ess akra tune, dinan stg.3, Alcon bbk, HRE P40
Appreciate 0
      07-02-2014, 03:34 PM   #10
Amirsm3
Major
15

 
Amirsm3's Avatar
 
Drives: 2011 Space Grey e90 M3
Join Date: Feb 2014
Location: Williams/Flagstaff, AZ


Posts: 1,438
iTrader: (2)

Is there a sending unit for that? Could be a gremlin

On the bright side, you're getting much better mileage than a Prius. Suck on that shit, hybrids.
__________________
2011 e90 M3 Space Grey DCT- black eAs gills/grilles, eAs H8 LED Corona bulbs, BMW carbon fiber mirror caps, Agency Power CF elbow, MS 12f/12r spacers, Alex@AlpineMSS DCT Flash, iND reflectors, Milltek slip-on
Appreciate 0
      07-02-2014, 03:41 PM   #11
roastbeef
Captain
United_States
25

 
roastbeef's Avatar
 
Drives: E92 M3
Join Date: Nov 2010
Location: Orange County, CA


Posts: 849
iTrader: (0)

Did you try resetting through the idrive?
__________________
Appreciate 0
      07-02-2014, 03:44 PM   #12
MrPrena
Civilian
United_States
7

 
MrPrena's Avatar
 
Drives: 99' Avalon, M3, and Other.
Join Date: Jan 2014
Location: CO


Posts: 327
iTrader: (0)

Better mileage per energy than Tesla S model.
Appreciate 0
      07-02-2014, 03:54 PM   #13
rAdzM
Smashed!
United_States
46

 
Drives: 2009 E92 M3
Join Date: Oct 2008
Location: Socal


Posts: 1,181
iTrader: (9)

Garage List
2009 BMW M3  [5.00]
2006 BMW M5  [4.50]
Quote:
Originally Posted by BimmerRookie View Post
Looks like you've got 99 problems, but fuel efficiency ain't one
__________________
est. 2008

BBS / Brembo / KW / Recaro / VARIS / Vorsteiner / BMW Performance / Oneighty / Dinan
Appreciate 0
      07-02-2014, 03:59 PM   #14
AMG_LAWL
E92 M3
United_States
29

 
AMG_LAWL's Avatar
 
Drives: 2013 BMW E92 M3 - Jerez Black
Join Date: Jun 2011
Location: Marina Del Rey, CA


Posts: 296
iTrader: (0)

Send a message via AIM to AMG_LAWL
I would just unplug the battery then plug it back, usually resets everything
Appreciate 0
      07-02-2014, 04:13 PM   #15
MikeD
Banned
5

 
Drives: E90 M3 6MT
Join Date: Apr 2014
Location: San Francisco


Posts: 445
iTrader: (0)

might I suggest this method to fix your BMW?

Appreciate 0
      07-02-2014, 04:14 PM   #16
MikeD
Banned
5

 
Drives: E90 M3 6MT
Join Date: Apr 2014
Location: San Francisco


Posts: 445
iTrader: (0)

Quote:
Originally Posted by BimmerRookie View Post
Looks like you've got 99 problems, but fuel efficiency ain't one
win
Appreciate 0
      07-02-2014, 05:00 PM   #17
SuckaGDog
Second Lieutenant
3

 
Drives: M5
Join Date: Jul 2013
Location: TX


Posts: 269
iTrader: (0)

When was the last time you reset it? That happens when it hasn't been reset for LONG time too much data to average.

Just hold down the BC button and reset it and it will go back to normal.
Appreciate 0
      07-02-2014, 05:08 PM   #18
s85e90
Colonel
34

 
Drives: black e90
Join Date: Jan 2014
Location: everywhere


Posts: 2,269
iTrader: (0)

Quote:
Originally Posted by SuckaGDog View Post
When was the last time you reset it? That happens when it hasn't been reset for LONG time too much data to average.

Just hold down the BC button and reset it and it will go back to normal.
This. Hold the stalk in and it will reset.
Appreciate 0
      07-03-2014, 07:39 AM   #19
wildwestm3
Second Lieutenant
12

 
wildwestm3's Avatar
 
Drives: 2008 M3 Convertible
Join Date: May 2014
Location: Springboro OH


Posts: 239
iTrader: (2)

Quote:
Originally Posted by thekurgan View Post
Hey, I get to have fun in the General area too!


What is your diagnosis?
Uh...definately broke! LOL
__________________
Thanks,

Dave
Appreciate 0
      07-03-2014, 11:41 AM   #20
Beamerbiggs
Enlisted Member
4

 
Drives: M3
Join Date: Oct 2013
Location: Knoxville


Posts: 38
iTrader: (0)

Quote:
Originally Posted by SuckaGDog
When was the last time you reset it? That happens when it hasn't been reset for LONG time too much data to average.

Just hold down the BC button and reset it and it will go back to normal.
I thought it may have been that because I hadn't reset since I purchased it. Still didn't work though... Guess I'll try resetting the Idrive and then the battery unplugging
Appreciate 0
      07-03-2014, 02:07 PM   #21
M3LISSA
Lieutenant
United_States
8

 
M3LISSA's Avatar
 
Drives: 2011 E90, M3
Join Date: Aug 2009
Location: New York


Posts: 435
iTrader: (0)

Quote:
Originally Posted by Beamerbiggs
Quote:
Originally Posted by SuckaGDog
When was the last time you reset it? That happens when it hasn't been reset for LONG time too much data to average.

Just hold down the BC button and reset it and it will go back to normal.
I thought it may have been that because I hadn't reset since I purchased it. Still didn't work though... Guess I'll try resetting the Idrive and then the battery unplugging
Let me know what happens I forgot to hold the stick in ill try it too when I go back to the car.
__________________
2011 E90 M3 // Alpine White // 20" BBS LM's, blah blah
Appreciate 0
      07-03-2014, 03:14 PM   #22
Sebringjetta
Colonel
United_States
87

 
Sebringjetta's Avatar
 
Drives: E46m3
Join Date: Mar 2011
Location: Sacramento


Posts: 2,973
iTrader: (30)

Quote:
Originally Posted by thekurgan View Post
Looks like that shit's broke.
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:32 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST