Bimmerpost for iPhone and Android have just been updated with a host of bug fixes. If you've ever had trouble logging into it in the past, give it a try now!
BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
European Auto Source
Post Reply
 
Thread Tools Search this Thread
      01-16-2018, 05:55 PM   #1
bb_00
Private
4
Rep
80
Posts

Drives: 2011 M3
Join Date: Mar 2016
Location: Toronto

iTrader: (0)

Warning Lights Randomly

Ok I need your expertise.

Here is the situation:

1) Secondary pump sensor warning message comes on only after the car has cooled down overnight. I use the DashCommand app to clear it each time before driving off.
2) Even when the light is on, I can hear the pump working and shutting down normally after the initial 1-2 minutes warm-up of the car
3) the battery discharging warning light also comes on when the car has cooled down overnight at random times especially when the weather is very cold
4) if I hook up the NOCO Genius (like CTEK) the night before for to charge overnight, I don't get either of the above lights to come on
5) I have never experienced both warning lights ON at the same time

So the question is, have anyone ever experience this? If so, what was the issue that you've discovered.
Appreciate 0
      01-16-2018, 08:06 PM   #2
WingZeroX5
Lieutenant Colonel
WingZeroX5's Avatar
United_States
262
Rep
1,982
Posts

Drives: 09 E90 M3
Join Date: Mar 2010
Location: New Hampshire

iTrader: (12)

Quote:
Originally Posted by bb_00 View Post
Ok I need your expertise.

Here is the situation:

1) Secondary pump sensor warning message comes on only after the car has cooled down overnight. I use the DashCommand app to clear it each time before driving off.
2) Even when the light is on, I can hear the pump working and shutting down normally after the initial 1-2 minutes warm-up of the car
3) the battery discharging warning light also comes on when the car has cooled down overnight at random times especially when the weather is very cold
4) if I hook up the NOCO Genius (like CTEK) the night before for to charge overnight, I don't get either of the above lights to come on
5) I have never experienced both warning lights ON at the same time

So the question is, have anyone ever experience this? If so, what was the issue that you've discovered.
Get your battery tested is the first logical step, esp when you're getting the discharge warning
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:36 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST