BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
EXXEL Distributions
Post Reply
 
Thread Tools Search this Thread
      06-28-2015, 07:33 PM   #1
4MULA_1
Private First Class
4MULA_1's Avatar
United_States
71
Rep
133
Posts

Drives: 550i
Join Date: May 2014
Location: TX

iTrader: (1)

iDrive screen won't turn on

Hi all, so my buddy turned on his m3 and the iDrive screen was all red, tried restarting and now it won't come back on. Anyone know what could've caused this and a possible fix?
Attached Images
 
Appreciate 0
      06-28-2015, 07:49 PM   #2
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
929
Rep
6,520
Posts


Drives: Harrop M3 / F10 M5 / F82 M4
Join Date: Apr 2008
Location: SoCal

iTrader: (9)

Garage List
2000 BMW M5  [0.00]
1990 BMW 735i Turbo  [0.00]
2008 BMW M3  [3.75]
2015 BMW M3  [0.00]
2015 BMW M5  [0.00]
Send a message via Skype™ to Mike Benvo
Either the video cable is loose (on the display side or behind the navi head unit), or the navi head unit is bad. The red screen indicates a working screen with no video signal. If the navi is bad, we carry replacement units.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
      06-28-2015, 08:39 PM   #3
aus
Major General
United_States
361
Rep
8,340
Posts

Drives: Odysse
Join Date: Jul 2005
Location: Seal Beach, CA

iTrader: (8)

I just learned about the "red screen of death" last night. If he's under warranty, dealer will replace the screen.
What year is his car?
__________________
Let me get this straight... You are swapping out parts designed by some of the top engineers in the world because some guys sponsored by a company told you it's "better??" But when you ask the same guy about tracking, "oh no, I have a kid now" or "I just detailed my car." or "i just got new tires."
Appreciate 0
      06-28-2015, 08:55 PM   #4
thugmaster
Private First Class
United_States
18
Rep
138
Posts

Drives: 2009 M3 Vert.
Join Date: Dec 2010
Location: Orange County CA

iTrader: (0)

Happened to me recently as well. Turn it off and wait 45 min. It will fire back up. This occurrence happened 2xs in the past 3 years.
Appreciate 0
      06-29-2015, 01:12 PM   #5
4MULA_1
Private First Class
4MULA_1's Avatar
United_States
71
Rep
133
Posts

Drives: 550i
Join Date: May 2014
Location: TX

iTrader: (1)

His car is a 2012, and yes after turning it off and waiting for about half an hour it came back on. Apparently there's a positive battery cable issue that causes this. He's checking with BMW if there was a recall for this.
Appreciate 0
      06-29-2015, 01:16 PM   #6
W Cole
Major
87
Rep
1,107
Posts

Drives: 2009 M3
Join Date: Dec 2010
Location: Newport Coast, CA

iTrader: (5)

This happened to me. Removed and replugged in the cables and its been fine since.
Appreciate 0
      06-29-2015, 06:03 PM   #7
Flying Ace
mdosu
Flying Ace's Avatar
United_States
2064
Rep
8,279
Posts

Drives: M6GC ZCP, X5d
Join Date: Jul 2014
Location: SF, CA

iTrader: (5)

Quote:
Originally Posted by W Cole View Post
This happened to me. Removed and replugged in the cables and its been fine since.
which cable?
__________________
14 M6GC ZCP, M-Perf (exhaust, wheel, spoiler, trim)

08 SSII E90 M3 (For Sale!)
12 AW/Cinnamon X5 Diesel Urban Assault Vehicle
Appreciate 0
      06-29-2015, 06:07 PM   #8
EJT86
Lieutenant Colonel
EJT86's Avatar
389
Rep
1,725
Posts

Drives: 2011 M3 DCT
Join Date: Mar 2014
Location: Boston, MA

iTrader: (0)

Quote:
Originally Posted by Mike Benvo View Post
Either the video cable is loose (on the display side or behind the navi head unit), or the navi head unit is bad. The red screen indicates a working screen with no video signal. If the navi is bad, we carry replacement units.
Do you have replacements for just the screen?
Appreciate 0
      06-29-2015, 08:53 PM   #9
W Cole
Major
87
Rep
1,107
Posts

Drives: 2009 M3
Join Date: Dec 2010
Location: Newport Coast, CA

iTrader: (5)

Quote:
Originally Posted by Flying Ace View Post
which cable?
The cables that lead to the idrive screen. Its a purple connector, fiber optic I believe.
Appreciate 0
      06-30-2015, 03:30 PM   #10
Mike Benvo
BimmerPost Supporting Vendor
Mike Benvo's Avatar
United_States
929
Rep
6,520
Posts


Drives: Harrop M3 / F10 M5 / F82 M4
Join Date: Apr 2008
Location: SoCal

iTrader: (9)

Garage List
2000 BMW M5  [0.00]
1990 BMW 735i Turbo  [0.00]
2008 BMW M3  [3.75]
2015 BMW M3  [0.00]
2015 BMW M5  [0.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by W Cole
Quote:
Originally Posted by Flying Ace View Post
which cable?
The cables that lead to the idrive screen. Its a purple connector, fiber optic I believe.
The purple/pink connector is the display cable and is not fiber optic, this is a separate green/black plug in the main harness.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:27 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST