BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing
 
OneEighty
Post Reply
 
Thread Tools Search this Thread
      04-01-2011, 06:52 PM   #1
jmflukeiii
Captain
9
Rep
727
Posts

 
Drives: 2011 Jet Black M3 ZCP Coupe
Join Date: Feb 2011
Location: Tampa, FL

iTrader: (0)

Checking engine oil issue....

So I get in my car and turn it on. I just had the the little electronic display on the dash showing me my Miles till empty as I was running a bit low on gas... filled it up much earlier today. Anyway, I cycle through the display to get back to the time and temp and see that my oil "electronic dipstick" says nothing but has a little clock beneath it ticking... so


so i got to idrive and look at oil and it says "checking oil level...". I drive the 5 minutes back to home sit there for about 5 minutes and its still the same, showing 0 on the "electronic dipstick" and saying "checking engine oil...."

Anybody had this happen? If so, is there a problem? I'm about 100 miles from my break-in service, not sure if that means anything.

And yes I tried searching
__________________
2011.5 E92 M3 Jet Black, DCT, Competition, Premium 2, and Convenience Packages, Black Novillo, Enhanced Premium Sound, 15% Tint, Black Kidneys/Reflectors/Gills/Roundels, DINAN Full Exhaust, DINAN Tune.
2006 Range Rover Sport Supercharged Black everything.
Appreciate 0
      04-01-2011, 07:40 PM   #2
DragonNeo
Private First Class
United_States
4
Rep
145
Posts

 
Drives: 09 M3 E93
Join Date: Jan 2011
Location: MA

iTrader: (0)

Don't worry, nothing wrong there. It could take 15-20 min of driving for the oil level to show up.
__________________
2009 M3 E93 DCT SG/FR Extended


Winter beater: 2009 M3 E93 DCT with Dunlop SP Winter Sport 3D
Appreciate 0
      04-01-2011, 08:48 PM   #3
jmflukeiii
Captain
9
Rep
727
Posts

 
Drives: 2011 Jet Black M3 ZCP Coupe
Join Date: Feb 2011
Location: Tampa, FL

iTrader: (0)

Quote:
Originally Posted by DragonNeo View Post
Don't worry, nothing wrong there. It could take 15-20 min of driving for the oil level to show up.
OKay great thank you. Maybe it does that every time I just happened to flip through the displays today and noticed it.
__________________
2011.5 E92 M3 Jet Black, DCT, Competition, Premium 2, and Convenience Packages, Black Novillo, Enhanced Premium Sound, 15% Tint, Black Kidneys/Reflectors/Gills/Roundels, DINAN Full Exhaust, DINAN Tune.
2006 Range Rover Sport Supercharged Black everything.
Appreciate 0
      04-01-2011, 09:24 PM   #4
klammer
Brigadier General
40
Rep
3,244
Posts

 
Drives: 11 spc gry m3 e90, 07 X5
Join Date: Jan 2010
Location: chicago

iTrader: (0)

Yeah, the display in the instrument cluster that you can scroll through (mpg, mph, etc.) can take forever... Don't sweat the small stuff
__________________
mods: akra evo, dinan 3.45 diff, ess akra tune, dinan stg.3, Alcon bbk, HRE P40
Appreciate 0
      04-01-2011, 09:24 PM   #5
1sikbmr
Brigadier General
1sikbmr's Avatar
46
Rep
3,283
Posts

 
Drives: E90 M3 6MT
Join Date: Mar 2010
Location: New York

iTrader: (14)

It does that all the time... I think it waits for a good temp of the oil to do the reading.
__________________

E90 ///M3 6MT Atlantis Blue - Fox red #TEAMMODE
ESS VT1-550|Volk TE37|Recaro|STOPTECH|Ohlins R/T|Mode Carbon GT4 Lip|Umnitza V4 |Agency Power/Sosi/ACM Test Pipes|BMW PSW V1|
Appreciate 0
      04-01-2011, 09:26 PM   #6
djsueno
Lieutenant
8
Rep
463
Posts

 
Drives: 2011 IB E92 M3
Join Date: Jul 2010
Location: Los Angeles CA

iTrader: (15)

+1 just warming up
Appreciate 0
      04-01-2011, 10:17 PM   #7
Money2536
Major
Money2536's Avatar
United_States
51
Rep
1,372
Posts

 
Drives: ' 15 M3 | '14 GT3
Join Date: Feb 2010
Location: The Villages, FL

iTrader: (0)

I am going to hate this so much. What a piece of crap system.
__________________
2015 Mineral White F80 M3 | Mineral White F80 M3 Journal
2014 Sapphire Blue 911 GT3 | Sapphire Blue 991 GT3 Journal
2014 911 Carrera S (sold) | White 991 C2S Journal
My Garage Journal
My YouTube Channel
Appreciate 0
      04-02-2011, 09:18 AM   #8
jmflukeiii
Captain
9
Rep
727
Posts

 
Drives: 2011 Jet Black M3 ZCP Coupe
Join Date: Feb 2011
Location: Tampa, FL

iTrader: (0)

Cool, thanks guys. Yeah it was colder than usual yesterday so maybe that's why I noticed it.
__________________
2011.5 E92 M3 Jet Black, DCT, Competition, Premium 2, and Convenience Packages, Black Novillo, Enhanced Premium Sound, 15% Tint, Black Kidneys/Reflectors/Gills/Roundels, DINAN Full Exhaust, DINAN Tune.
2006 Range Rover Sport Supercharged Black everything.
Appreciate 0
      04-02-2011, 09:56 AM   #9
Fsarc
Lieutenant
Fsarc's Avatar
United_States
12
Rep
418
Posts

 
Drives: 2011.5 E92 M3 LMB
Join Date: Nov 2007
Location: BC-Northern NJ

iTrader: (3)

Quote:
Originally Posted by SehrSchnell View Post
Totally normal... BTW, if you do only a quick check it will take only a "snap-shot", for a more accurate reading have the car parked on a flat surface and do a manual reset.

That's the way I do it (manual reset from the stalk) and the other day I couldn't get a reading. Gave up after 10 minutes of idling in my driveway. Car was fully warmed up after 40 minutes of driving with the oil gauge at 210. This is the second time it happened. First time I finally got a reading once I started driving around, but I prefer the method you mentioned. I'll see what happens today when I drive around. It is a PITA system just to check the oil. Not sure why I can't get a reading parked on a level surface with the manual reset. I've done it before plenty of times and the reading always came up pretty quickly.
Appreciate 0
      04-02-2011, 10:07 AM   #10
bobbyd1961
Banned
26
Rep
2,411
Posts

 
Drives: 2009 M3 sedan LeMans Blue
Join Date: Jun 2009
Location: new jersey

iTrader: (0)

it is frustrating. takes quite a while for it to register
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:07 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST