BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      02-13-2011, 05:38 PM   #23
shamoo
Captain
17
Rep
744
Posts

 
Drives: 2008 E92 M3
Join Date: May 2010
Location: SoCal (Irvine & LA)

iTrader: (1)

I've had the Fabspeed resonated xpipe w/Fabspeed high flow cats now for almost 8-9K miles and I'm using the supplied O2 extenders. Driven in temperatures ranging from 10F to 90F at loads from a track day to normal day-to-day driving and the CEL has not come on at all. I have a Powerchip stage I tune (which does NOT remove the CEL, stage II does).

Everyone keeps saying it will come on eventually, but I doubt it at this point.
__________________
2008 E92 M3 | 2007 Honda S2000 | 2001 Honda S2000 | 1997 Turbo Integra
Appreciate 0
      02-13-2011, 07:55 PM   #24
TRY...M3
Major
TRY...M3's Avatar
United_States
23
Rep
1,432
Posts

 
Drives: Depends on the day
Join Date: Nov 2010
Location: PA

iTrader: (2)

I hope you do not get the check engine light, I'm speaking from experience. It was a real pain in the ass. My car wouldn't rev passed 2k and it wouldn't go passed 10 mph. I had to have it towed to a garage. :/
__________________
e92///M3
TT Lamborghini Gallardo
INSTAGRAM: CHRISTIANPERLES
Lamborghini-Talk.com: Christian.
Appreciate 0
      02-14-2011, 04:53 PM   #25
jimmy ny
Second Lieutenant
jimmy ny's Avatar
4
Rep
248
Posts

 
Drives: 2011 bmw m3
Join Date: Jun 2010
Location: new york

iTrader: (0)

Dinan assured me that it will pass. If not they said that the dealer will flash to stock,inspect then re0flash for free. is this true?
Appreciate 0
      02-15-2011, 09:54 AM   #26
Ben335
Captain
Ben335's Avatar
12
Rep
891
Posts

 
Drives: 09 M3 Finally here
Join Date: Jul 2008
Location: Virginia

iTrader: (2)

Quote:
Originally Posted by shamoo View Post
I've had the Fabspeed resonated xpipe w/Fabspeed high flow cats now for almost 8-9K miles and I'm using the supplied O2 extenders. Driven in temperatures ranging from 10F to 90F at loads from a track day to normal day-to-day driving and the CEL has not come on at all. I have a Powerchip stage I tune (which does NOT remove the CEL, stage II does).

Everyone keeps saying it will come on eventually, but I doubt it at this point.
Make sure your CEL is still working. Powerchip had some problems and were turning off the CEL completely on cars regardless of wether it was stage I or II. Quick test, when you start your car the SES light should come one for 1-2 seconds, then turn off. If you don't see the SES light, then your SES light is off.
__________________
09 SG E90, Black on Carbon Leather, Tech, Premium, Cold, iPod, Premium Sound, 19s, OEM Alarm, PDC, Moonroof, Sirius
Eisenmann Sport / Eibach Springs / 35% F1 Pinnacle Tint / Macht Schnell Air Filter / LUX Angel Eyes / Black Grill / AA Pulley / Powerchip Stage II Tune / Fabspeed X-Pipe & HFC / RAC Monolites RG63
Appreciate 0
      02-15-2011, 10:55 AM   #27
J08M3
Major General
J08M3's Avatar
United_States
102
Rep
6,012
Posts

 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

iTrader: (8)

Quote:
Originally Posted by TRY...M3 View Post
I hope you do not get the check engine light, I'm speaking from experience. It was a real pain in the ass. My car wouldn't rev passed 2k and it wouldn't go passed 10 mph. I had to have it towed to a garage. :/
This does not happen if the CEL is from the rear 02

Quote:
Originally Posted by jimmy ny View Post
Dinan assured me that it will pass. If not they said that the dealer will flash to stock,inspect then re0flash for free. is this true?
Sounds false to me. Especially since it would take hours of time to complete this operation.
__________________
Appreciate 0
      02-16-2011, 12:17 AM   #28
shamoo
Captain
17
Rep
744
Posts

 
Drives: 2008 E92 M3
Join Date: May 2010
Location: SoCal (Irvine & LA)

iTrader: (1)

Quote:
Originally Posted by Ben335 View Post
Make sure your CEL is still working. Powerchip had some problems and were turning off the CEL completely on cars regardless of wether it was stage I or II. Quick test, when you start your car the SES light should come one for 1-2 seconds, then turn off. If you don't see the SES light, then your SES light is off.
I will check tomorrow morning when I leave for work, but I am able to see the CELs for other "alerts" when I scroll through the menus. Does that count? In any case, I'll take a look.

When I did bring up that concern with Powerchip, they did confirm that a prior employee used to do that, but they are no longer employed. Something about how someone from Powerchip left the company to make his own company or something and "hacking" the flash to just turn off the light. I'm not exactly sure, I don't remember. Maybe someone from Powerchip can chime in.
__________________
2008 E92 M3 | 2007 Honda S2000 | 2001 Honda S2000 | 1997 Turbo Integra
Appreciate 0
      02-16-2011, 12:38 AM   #29
kitw
Colonel
kitw's Avatar
60
Rep
2,627
Posts

 
Drives: 2015 MW M3/2014 Boxster S
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (14)

Quote:
Originally Posted by jimmy ny View Post
Dinan assured me that it will pass. If not they said that the dealer will flash to stock,inspect then re0flash for free. is this true?
Pass smog? only if your state doesn't require OBD-2 readiness checks to complete. they apparently won't.
Appreciate 0
Post Reply

Bookmarks

Tags
cel, hfc, test pipe, x-pipe

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:27 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST