BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
GetBMWParts
Post Reply
 
Thread Tools Search this Thread
      05-22-2010, 01:40 AM   #1
asheesh88
0
Private
 
Drives: 2010 Space Gray E90 M3
Join Date: Dec 2009
Location: Chicago, IL

Posts: 51
iTrader: (0)

IPhone snap in adaptor creating weird issues

Hi all,

I have had my 2010 M3 for about 3 months, with factory installed smartphone integration and usb. At first I was using the iPhone cable that came with the car. However I reccently got the iPhone snap in adaptor for my 3GS (the correct one that charges, plays MP3s, etc.) and have been having some strange intermittant issues:

- Sometimes the bluetooth gets disconnected.
- Sometimes the phone is in the snap in adaptor, yet the phone does not charge.
- Sometimes the phone is connected and I can answer phone calls through the iDrive, but I cannot hear the other person at all, and the voice dos not come through the iPhone either. In this case, I have to turn off bluetooth on the phone and turn it back on, then all seems fine.

None of these things happened with the cable....I am wondering if anyone else is having similar issues, and if there is a resolution to the problems.

Thanks,

Asheesh
asheesh88 is offline  
Appreciate 0
Reply With Quote
      05-22-2010, 04:03 AM   #2
quality_sound
0
8 tracks of madness
 
Drives: Slowly
Join Date: Jun 2009
Location: At home

Posts: 2,731
iTrader: (1)

It's gotta be a phone issue since charging is the only issue you have that has anything to do with the cradle. The answering/BT issues aren't an issue with the adapter since those are still done over BT even when snapped into the adapter.
quality_sound is offline   United_States
Appreciate 0
Reply With Quote
      05-28-2010, 09:36 PM   #3
asheesh88
0
Private
 
Drives: 2010 Space Gray E90 M3
Join Date: Dec 2009
Location: Chicago, IL

Posts: 51
iTrader: (0)

HI all,

another problem that I just noticed today:

My iphone 3GS was down to 5% battery. I put in the cradle to charge it....the battery icon in the corner of the iPhone turned into a battery with a plug in it......I believe that means that the iPhone is fully charged (clearly it wasnt.

I tried to undock and redock it but the plug icon kept coming.

Finally I switched to the USB port and the cradle and it began charging fine (lightning bolt).

I have charged the iPhone with the cradle many times before....it seems to intermittantly think the iPhone is fully charged when it is not...

Any ideas?

Asheesh
asheesh88 is offline  
Appreciate 0
Reply With Quote
      06-07-2010, 01:55 AM   #4
JIO
0
Captain
 
Drives: '09 Space Gray E92 M3 w/DCT
Join Date: Aug 2005
Location: Eugene, Oregon

Posts: 627
iTrader: (0)

Are you sure you have the 3GS cradle? There is one for the 3G phone and one for the 3GS phone. Perhaps you have the older cradle? I'd double check the numbers.
JIO is offline  
Appreciate 0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:22 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST