BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      04-28-2010, 04:58 PM   #23
drft92
Giggity
 
drft92's Avatar
 
Drives: e92m
Join Date: Aug 2007
Location: North Jersey

Posts: 289
iTrader: (3)

Quote:
Originally Posted by Ben335 View Post
The extenders don't work 100%. I know of several people that have tried them and eventually they still get a CEL. It is supposed to move the O2 sensors out of the stream of the exhaust and thereby tricking the ECU into not throwing a CEL. Doesn't work though. I wish Fabspeed and everyone else would just be honest about the CEL. I have their full setup and like the gains, it just rubs me that they promote it as not setting off a CEL.
Really?? Wow I didn't know other people got them yet still got a CEL. Oh I would surely demand a refund or some sort of compensation, that is completely unacceptable! I peronally have had no issues at all since they were put on, only ran the PC tune for about a month and have been on a stock file up untill last week. I have no personal gain by lying about my experience, I have no affiliation with Fabspeed or anyone in the automotive industry for that matter, but ofcourse you have the right to believe what you want. For all those people who are still having an issue, I hope you get it resolved.

Ash

Last edited by drft92; 04-28-2010 at 05:52 PM.
drft92 is offline   United_States
0
Reply With Quote
      04-28-2010, 05:42 PM   #24
MaxL
Captain
 
Drives: E90 M3, Cayenne T, 991 GT3
Join Date: Jun 2007
Location: Bay Area

Posts: 940
iTrader: (0)

Quote:
Originally Posted by J08M3 View Post

Talk about bad luck..... Had to happen on way to inspection appointment.
Lol. Luck is a lady with a sense of humor, but sometimes it's too dry.

I had a similar incident with my 335 - absolutely nothing on the car ever broke in 3 years, but the fuel pump had to crap out at 11pm on Friday - just 9 hours before the new owner was coming to pick up the car. All was fine in the end.

By the way, are there any performance x-pipes that do not cause CEL (without tune that it)?
MaxL is offline   Canada
0
Reply With Quote
      04-28-2010, 05:48 PM   #25
Singletrack
4th down; 4th quarter? Renegade.
 
Singletrack's Avatar
 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

Posts: 3,805
iTrader: (3)

Quote:
Originally Posted by FStop7 View Post
Yeah, that's a matter of ethics in their advertising, I'm with you there. I was just suggesting the OP get a scanner to avoid the CEL issue from causing him more problems. Either that, do a reflash, or go back to stock. The scanner's the cheapest and quickest workaround.
Yah but the scanner won't pass the readiness tests, it will just clear the code. If you get the CEL/SES frequently (like I do), the chances of passing all those tests before inspection is slim.

I was just at my shop for tires and forgot to have them try the extenders...damn.
Singletrack is offline   United_States
0
Reply With Quote
      04-28-2010, 05:55 PM   #26
MMMorish
Just call me J.J. McClure
 
MMMorish's Avatar
 
Drives: E92 M3 & C4 Corvette
Join Date: Sep 2008
Location: Toronto

Posts: 2,836
iTrader: (5)

Quote:
Originally Posted by Bob MG View Post
You've heard of cousin Murphy!
Always coming to shit on your head when you can least afford the smell of shit on you.
Oh Borat! Man, you make me laugh!
__________________
MODS: Meisterschaft GT Racing Exhaust / BMC Air Filter / UUC SSK & DSSR (Modded)/ RPI Scoops / Passport SRX Hardwired / Custom Wrap 3M Clearbra / 20% Tint / 50% Windshield Tint / Key Hole Delete / Matted Out Accessories / VRS Type II Diffuser / Smoked Reflectors / Euphoria 6K LED Interior Lights / Rear Fog Light Mod / 6000K HID's / 6500K LUX H8 Angel Eyes / RDash License Plate LED Kit / LED Xenon Reverse Lights
"M3 drivers have no friends"
MMMorish is offline   Canada
0
Reply With Quote
      04-28-2010, 05:59 PM   #27
Singletrack
4th down; 4th quarter? Renegade.
 
Singletrack's Avatar
 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

Posts: 3,805
iTrader: (3)

Quote:
Originally Posted by MaxL View Post
By the way, are there any performance x-pipes that do not cause CEL (without tune that it)?
Technically, no xpipe will cause a CEL since it is after the primary cats. But I think you are asking about the full setup -including primary cats and xpipe. Active Autowerke claims that their system does not cause a CEL. However, I asked them what testing they did to make that conclusion (in their thread), and never received a response. The system just came out, so it will take a while for experiences to start rolling in...
Singletrack is offline   United_States
0
Reply With Quote
      04-28-2010, 07:43 PM   #28
J08M3
Major General
 
J08M3's Avatar
 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

Posts: 6,012
iTrader: (8)

Quote:
Originally Posted by FStop7 View Post
Just get an actron scanner for 50 bucks and clear the code.
It's not that easy.... I cleared the codes, but didn't have enough time to drive the car enough to get all 6 sensors involved with emissions to pass a readiness test. As soon as you clear the codes all 6 monitors read not ready. You have to drive the car (for however many drive cycles I'm not sure) to get all monitors to be ready for test. They tried to hook me up and drive the car for 20 miles, which got 3 up, then shut the car off and started it again and got a 4th up. They even tried to hook it up to their computer to get the last two up, but it was a no go. No one at the dealership was sure why, they thought maybe it needs a cold start, meaning it would have to sit over night to get the last two emissions monitors ready for the readiness test which will get me by inspection.
__________________
J08M3 is offline   United_States
0
Reply With Quote
      04-28-2010, 10:48 PM   #29
disruptv
Major
 
Drives: 3M
Join Date: Sep 2006
Location: ny

Posts: 1,145
iTrader: (10)

Garage List
09 3m  [0.00]
question...

will a pc tune that clears the code allow you to pass nys inspection, or will the car still fail the inspection?

thanks
disruptv is offline  
0
Reply With Quote
      04-29-2010, 12:21 AM   #30
noxredna
Captain
 
noxredna's Avatar
 
Drives: 2008 BMW M3 Coupe, 2012 BMW M5
Join Date: Sep 2008
Location: Philadelphia & Singapore

Posts: 669
iTrader: (0)

The car will fail inspection the moment you remove your 2nd cats, let alone primary cats regardless of any tune.. the tune basically turns off the cell light but NY inspection has sniff test.
noxredna is offline  
0
Reply With Quote
      04-29-2010, 06:08 AM   #31
J08M3
Major General
 
J08M3's Avatar
 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

Posts: 6,012
iTrader: (8)

Quote:
Originally Posted by noxredna View Post
The car will fail inspection the moment you remove your 2nd cats, let alone primary cats regardless of any tune.. the tune basically turns off the cell light but NY inspection has sniff test.
well that depends where and who does it. Technically it should fail, but it's only a visual inspection for secondary cats. It will not give you a CEL so most places will never know the secondaries are gone, and when they hook it up to the computer it will pass emissions and that's really all they care about.
__________________
J08M3 is offline   United_States
0
Reply With Quote
      04-29-2010, 08:10 AM   #32
Kyoshi71
Colonel
 
Kyoshi71's Avatar
 
Drives: 2010 M3 Coupe
Join Date: Jul 2006
Location: New York

Posts: 2,528
iTrader: (0)

Quote:
Originally Posted by FStop7 View Post
Yeah, that's a matter of ethics in their advertising, I'm with you there. I was just suggesting the OP get a scanner to avoid the CEL issue from causing him more problems. Either that, do a reflash, or go back to stock. The scanner's the cheapest and quickest workaround.
They also wanted to charge my friend $225 for a "cold air kit" for his 997. The kit was nothing more than a silicon charge pipe and plastic cap to block the warm exhaust air coming from the air box. Air filter not included.
Kyoshi71 is offline  
0
Reply With Quote
      04-29-2010, 01:40 PM   #33
FStop7
I like cars
 
FStop7's Avatar
 
Drives: M6
Join Date: Oct 2008
Location: Newbury Park, CA

Posts: 5,059
iTrader: (3)

Quote:
Originally Posted by J08M3 View Post
It's not that easy.... I cleared the codes, but didn't have enough time to drive the car enough to get all 6 sensors involved with emissions to pass a readiness test. As soon as you clear the codes all 6 monitors read not ready. You have to drive the car (for however many drive cycles I'm not sure) to get all monitors to be ready for test. They tried to hook me up and drive the car for 20 miles, which got 3 up, then shut the car off and started it again and got a 4th up. They even tried to hook it up to their computer to get the last two up, but it was a no go. No one at the dealership was sure why, they thought maybe it needs a cold start, meaning it would have to sit over night to get the last two emissions monitors ready for the readiness test which will get me by inspection.
OK, I didn't realize there was anything beyond clearing the codes. This stuff is so big brother.
FStop7 is offline   Vatican City State
0
Reply With Quote
      04-30-2010, 09:13 AM   #34
J08M3
Major General
 
J08M3's Avatar
 
Drives: 2011 M3 COUPE
Join Date: May 2008
Location: NEW YORK

Posts: 6,012
iTrader: (8)

Well got a cold start and a bunch of miles put on so all sensors were up for readiness test. Took 5 minutes to get that done so I'm good to go for another year

Let's hope next year the damn cats don't throw a code on my ride to get inspection
__________________
J08M3 is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:05 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST