BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
OneEighty
Post Reply
 
Thread Tools Search this Thread
      01-28-2010, 09:55 AM   #1
E90M3CDFR
First Lieutenant
United_States
21
Rep
303
Posts

 
Drives: E91 Sportwagon
Join Date: Sep 2008
Location: NoVA

iTrader: (1)

Seals on bottom of engine/radiator passage

FYI: there are two rubber strips that seal the cavity that flows air through the bottom cooler, passing it down under the car. One of these pieces came loose and almost fell off my car while driving in Germany (ie higher than normal speeds). Fortunately, I saw it hanging under the front. The other was working its way loose. Here are two photos; second one shows where the piece was missing and after I replaced it. On another posting I found the part number and it isn't expensive, but if you can catch it before you lose it, you'll save a few bucks.

I don't know what the downside of losing this seal may be: I'm guessing aerodynamics under car are slightly disturbed, maybe heat from the engine is then being ducted back into the undertray; perhaps the undertray will work its ways loose over time as air is channeled between it and the engine. At any rate, something to check on periodically and in my case I used some glue to fix the rubber seals on more permanntly.

Oh...and when I first noted this issue to my dealer...they put the piece back on the small lip that is part of the bumper cover! Fortunately, it came off easily and is now where it should be.
Attached Images
  
__________________

Last edited by E90M3CDFR; 01-28-2010 at 10:01 AM.
Appreciate 0
      01-28-2010, 11:24 AM   #2
Singletrack
4th down; 4th quarter? Renegade.
Singletrack's Avatar
United_States
43
Rep
3,820
Posts

 
Drives: 09 SSII E92 M3; 12 AW X5d
Join Date: Aug 2008
Location: Pittsburgh, PA

iTrader: (3)

I had an issue where one of these guys was working iself off as well. Although in my case, it was caused by hitting road debris - ice block to be precise.

Good informative post - I bet others will have this issue.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:58 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST