BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > Australia
 
GTB Performance
Post Reply
 
Thread Tools Search this Thread
      10-08-2009, 12:07 PM   #1
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Engine malfunction, reduced power, DSC, DBC, FTM deactivated!

Jumped in the car this morning, pushed the start button....engine makes a feeble attempt at starting before dying. Suddenly a plethora of warning lights light up the instrument cluster and the messages mentioned displayed on the iDrive screen.

I then turned the car off and tried again. Same story three more times. On the next try the car started up normally. I searched the Check Control for error messages but there were none...it was as though nothing had happened.

The car is going into the service dept in the morning for diagnosis.

I did a search on M3Post and this has affected a number of cars. There is a service bulletin out on the issue and it seems to point towards a clogged idle control valve.

Have any Australian E9x M3 owners experienced this fault?
amk2912 is offline   Australia
0
Reply With Quote
      10-08-2009, 05:08 PM   #2
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,510
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Not so far ... touch wood! Hope nothing serious. Keep us posted with what they find. Good luck and don't worry anything gone wrong will be fixed under warranty.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      10-09-2009, 05:21 AM   #3
zenderm3
Lieutenant Colonel
 
zenderm3's Avatar
 
Drives: E36 M3 DY/2010 E92 M3
Join Date: Jun 2009
Location: Brisbane

Posts: 1,961
iTrader: (0)

Good luck Andre! Keep us informed! I would have thought that they fixed the idle control valve in the '09s!
__________________
________________
My ///M is in my garage .... and it is a beast!
2010 E92 M3 Space Grey | Fully Loaded
1996 E36 M3 Dakar Yellow - No Longer With Me
2004 Honda Accord Euro - SOLD
zenderm3 is offline   Australia
0
Reply With Quote
      10-09-2009, 06:21 AM   #4
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Well the diagnosis has come back....idle control valve. There was an error code stored and now we are waiting on the replacement parts so I'm hoping the dodgy ICV will get fixed late next week or early the next week.

On a good note they did fix my squeaky windows today...the door rubbers were dry and needed a coating of dry lube. Also the 8000km visual inspection was done.
amk2912 is offline   Australia
0
Reply With Quote
      10-09-2009, 06:23 AM   #5
zenderm3
Lieutenant Colonel
 
zenderm3's Avatar
 
Drives: E36 M3 DY/2010 E92 M3
Join Date: Jun 2009
Location: Brisbane

Posts: 1,961
iTrader: (0)

nice one... otherwise all in order?
__________________
________________
My ///M is in my garage .... and it is a beast!
2010 E92 M3 Space Grey | Fully Loaded
1996 E36 M3 Dakar Yellow - No Longer With Me
2004 Honda Accord Euro - SOLD
zenderm3 is offline   Australia
0
Reply With Quote
      10-09-2009, 06:32 AM   #6
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

All is good so far.....(touches wood)
amk2912 is offline   Australia
0
Reply With Quote
      10-12-2009, 04:22 PM   #7
Aussie F10M
Captain
 
Aussie F10M's Avatar
 
Drives: F10 M5
Join Date: Sep 2008
Location: Sydney, Australia

Posts: 617
iTrader: (0)

Just had exactly the same thing happen this morning - its almost like I wrote your post. Taking it to the dealer this morning !

At least I can tell them it is the idle control valve !

Thanks
Aussie F10M is offline   Australia
0
Reply With Quote
      10-12-2009, 07:35 PM   #8
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Quote:
Originally Posted by SS14 View Post
Just had exactly the same thing happen this morning - its almost like I wrote your post. Taking it to the dealer this morning !

At least I can tell them it is the idle control valve !

Thanks
Sorry to hear that but glad my post helped. There is a thread on the main M3Post forum regarding this issue - I found it quite helpful.

BTW mention to the service people that there is a service bulletin on the issue - it may help them if they haven't encountered the problem before.
amk2912 is offline   Australia
0
Reply With Quote
      10-13-2009, 08:59 AM   #9
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,510
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Andre, when are you getting the car back? I was at the dealership today and enquired about your car. Who is your service advisor?
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      10-13-2009, 11:24 AM   #10
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Quote:
Originally Posted by aussiem3 View Post
Andre, when are you getting the car back? I was at the dealership today and enquired about your car. Who is your service advisor?
I've still got the car as they have to order the ICV parts. Hopefully the problem won't happen again soon as I have to head down to Bunbury today. The parts should come next week and they'll call me when they do. I'm being looked after by Andy, who has been very helpful.
amk2912 is offline   Australia
0
Reply With Quote
      10-14-2009, 09:03 AM   #11
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,510
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Must be one of the new advisors. Parts like that should be air freighted and should have been here this week and car getting fixed. That's not good enough. Speak with Marty and tell him that you're not happy with the service.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      10-14-2009, 09:30 AM   #12
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Quote:
Originally Posted by aussiem3 View Post
Must be one of the new advisors. Parts like that should be air freighted and should have been here this week and car getting fixed. That's not good enough. Speak with Marty and tell him that you're not happy with the service.
I always dealt with Marco who has unfortunately moved on. I guess if it was a major catastrophic issue that prevented the car from being driven I'd be jumping up and down. As it is there hasn't been a re-occurence (touchwood).

On a side note - had a good run to Bunbury down the Perth-Bunbury Highway. Only one Multanova on the way back. Karrinyup to Bunbury took just under two hours - considering there are roadworks near Myalup. Averaged 9.8 L/100km but found the 110kmh limit very frustrating.
amk2912 is offline   Australia
0
Reply With Quote
      10-14-2009, 04:57 PM   #13
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,510
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
That's very and shows how economical the car can be when cruising. The Perth drivers have driven like idiots and have brought about the unwanted attention since theForrest Hwy was opened. Hope you had a good run.

Yes Marco has moved on unfortunately and there are no experienced heads any longer. I dealt with Marco too. I don't know what I am going to do now. I have to take the car in for break fluid change ... two years since the cr was built and bought!

I live in Noranda, I guess you're in Karriniyup? We try and catch up for a coffee may be some time... I'll send you a pm with my mobile no.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      10-14-2009, 10:07 PM   #14
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Quote:
Originally Posted by aussiem3 View Post
That's very and shows how economical the car can be when cruising. The Perth drivers have driven like idiots and have brought about the unwanted attention since theForrest Hwy was opened. Hope you had a good run.

Yes Marco has moved on unfortunately and there are no experienced heads any longer. I dealt with Marco too. I don't know what I am going to do now. I have to take the car in for break fluid change ... two years since the cr was built and bought!

I live in Noranda, I guess you're in Karriniyup? We try and catch up for a coffee may be some time... I'll send you a pm with my mobile no.
No prob - that would be great. My kids go to school in Karrinyup but I live much further north in Iluka, so I used K as a reference as that is where I effectively started the trip to Bunbury.

I guess now that Marco has gone we just have to take a "leap of faith" and wait until someone builds up a rapport. I'm good as long as they're straight down the line.

I haven't forgotten about the dyno and will organise soon as this ICV issue is fixed. Last thing I guess I want is the car packing in on the dyno!
amk2912 is offline   Australia
0
Reply With Quote
      10-23-2009, 10:18 PM   #15
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Damn stupid problem happened again this morning! Still waiting for the ICV problem to be fixed. Parts are in but apparently it takes a whole day if not two to replace the ICV, hose and clamps and update the software! I've had quicker Commodore 64 tape drives! Anyway, for the benefit of everyone I have taken screenshots so you can ID the problem should it happen to you........

Note how revs are limited to 5000 rpm
Attached Images
  
amk2912 is offline   Australia
0
Reply With Quote
      10-25-2009, 09:43 AM   #16
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,510
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
So what's the delay? They should make it a priority and fix it. Don't leave it for too long ... who knows what else might get damaged. I would demand a free loan car and if service refuses to give one, go and see your sales rep or Darren Brandon.
Good luck and keep us updated.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
      10-25-2009, 04:57 PM   #17
zenderm3
Lieutenant Colonel
 
zenderm3's Avatar
 
Drives: E36 M3 DY/2010 E92 M3
Join Date: Jun 2009
Location: Brisbane

Posts: 1,961
iTrader: (0)

Quote:
Originally Posted by aussiem3 View Post
So what's the delay? They should make it a priority and fix it. Don't leave it for too long ... who knows what else might get damaged. I would demand a free loan car and if service refuses to give one, go and see your sales rep or Darren Brandon.
Good luck and keep us updated.
+100
__________________
________________
My ///M is in my garage .... and it is a beast!
2010 E92 M3 Space Grey | Fully Loaded
1996 E36 M3 Dakar Yellow - No Longer With Me
2004 Honda Accord Euro - SOLD
zenderm3 is offline   Australia
0
Reply With Quote
      10-25-2009, 06:18 PM   #18
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Quote:
Originally Posted by aussiem3 View Post
So what's the delay? They should make it a priority and fix it. Don't leave it for too long ... who knows what else might get damaged. I would demand a free loan car and if service refuses to give one, go and see your sales rep or Darren Brandon.
Good luck and keep us updated.
The car is going in today. The parts arrived last Wednesday and the car was originally booked in for last Friday but when I arrived I was told the car would be needed for at least the whole day as software updates needed to be done which would take a few hours (!!!) I then cancelled for a later date but the problem re-occurred on Saturday morning so I managed to get the car in for today though too late for a loan car. My wife has to rearrange her day to shuttle me around - which is a bit of a pain.
amk2912 is offline   Australia
0
Reply With Quote
      10-26-2009, 02:58 AM   #19
amk2912
Lieutenant Colonel
 
amk2912's Avatar
 
Drives: '10 X5 40d & '12 F10 520d
Join Date: Dec 2007
Location: Perth

Posts: 1,663
iTrader: (0)

Well....I've just got my car back and so far so good. Guess time will tell whether the problem happens again. No software updates needed.
amk2912 is offline   Australia
0
Reply With Quote
      10-26-2009, 03:27 AM   #20
Alpine*
Brigadier General
 
Alpine*'s Avatar
 
Drives: CLK63 Black
Join Date: May 2008
Location: Australia

Posts: 3,306
iTrader: (0)

Quote:
Originally Posted by amk2912 View Post
Well....I've just got my car back and so far so good. Guess time will tell whether the problem happens again. No software updates needed.
Frustrating to say the least.

I had similar "all lights on" once, didn't help that the car had been on the dyno for half an hour. Freaked me out a bit, took a couple of hours befor she returned to normal, I was worried for a while though!

Hope all is good now and thanks for the updates, I have added it to my small memory bank.
Alpine* is offline   Australia
0
Reply With Quote
      05-25-2014, 11:48 PM   #21
harpoon
Lieutenant
 
Drives: e92 M3
Join Date: May 2008
Location: Syd

Posts: 441
iTrader: (1)

Hi guys. Sorry to dig up such an old thread, but it was the only reference to the issue I could find in the aussie forum.

I have a manual '08 e92 M3 with 30,000kms on it.

I was driving this morning and got a Tyre monitor malfunction message, and then DSC deactivated message. No loss of power message or limp mode. I have had intermittent issues with cold starts - long cranks and rough idle. I asked the dealer to look into this but they could find no issues.

Just wanted to know if anyone has any recent experience with any of these issues?

From the searches I've done it sounds like it could be Idle control valve or Throttle Valve Actuator. Both of these sound like quite expensive fixes which I'm not all that keen on!

cheers
__________________
E92 M3
harpoon is offline  
0
Reply With Quote
      05-25-2014, 11:58 PM   #22
aussiem3
Lieutenant Colonel
 
aussiem3's Avatar
 
Drives: Goggomobil
Join Date: Jul 2007
Location: Kangaroo land

Posts: 1,510
iTrader: (1)

Garage List
2014 BMW X5 30d  [0.00]
2007 E92 M3  [0.00]
Quote:
Originally Posted by harpoon View Post
Hi guys. Sorry to dig up such an old thread, but it was the only reference to the issue I could find in the aussie forum.

I have a manual '08 e92 M3 with 30,000kms on it.

I was driving this morning and got a Tyre monitor malfunction message, and then DSC deactivated message. No loss of power message or limp mode. I have had intermittent issues with cold starts - long cranks and rough idle. I asked the dealer to look into this but they could find no issues.

Just wanted to know if anyone has any recent experience with any of these issues?

From the searches I've done it sounds like it could be Idle control valve or Throttle Valve Actuator. Both of these sound like quite expensive fixes which I'm not all that keen on!

cheers
Long cranks are characterics of the car as it ages. I have it too when the car hasn't been started for a couple of days. I have not experienced rough idle, unless I am missing something.

I think the DSC warning is related to the loss of air and once you have the puncture repaired and reset the TPM, you should be fine. I have experienced this when the car has been on the dyno, but when you drive off, both switch-off.

Hope I have answered you concerns. Good luck.
__________________

2007 E92 6MT - Silverstone II with /// Performance Exhaust with ACM Test Pipes and BPM Sport Stage II Dev-Tune - Proper engine warm up, 12-monthly oil change, Castrol TWS 10w-60
2014 F15 X5 3.0d
aussiem3 is offline   Australia
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:36 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST