BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > M3 (E90 / E92 / E93) > Regional Forums > USA - Mid-Atlantic
 
BPM Sport
Post Reply
 
Thread Tools Search this Thread
      01-13-2009, 04:43 PM   #1
MTrizzy
Lieutenant
MTrizzy's Avatar
United_States
5
Rep
448
Posts

 
Drives: 2008 AW M3 Coupe
Join Date: Mar 2008
Location: Potomac, MD

iTrader: (1)

Exclamation Local service question...

So I am driving on the way home from work the other day and the Service engine light comes on....the car is indicating "Increased Emissions" anyone had experience with this?

The dealer is saying they are investigating a faulty thermostat, but I'm not sure that jives with me....anyone got any clues as to what this could be.
__________________

AW E92 M3|E92 LuX|Piaa GTX H3| Rear Fog Light Mod | Ventureshield (Raja)
|Eisenmann Race Exhaust |Macht Schnell Filter | Black Grills | Black Sides | H&R Springs | Fabspeed X-Pipe & High Flow Cats| CF VRS II rep diffuser|Most powerful Scoops in the world|
Appreciate 0
      01-13-2009, 09:07 PM   #2
BCMPOWER
Captain
BCMPOWER's Avatar
United_States
7
Rep
626
Posts

 
Drives: 08 Silverstone II M3
Join Date: Dec 2007
Location: Silver Spring MD

iTrader: (0)

Sorry to hear that man, I just got my car back from VOB today for the left brake lights. I don't know what to say I've never heard that issue. Good Luck and I hope it's a quick fix.
__________________
Appreciate 0
      01-13-2009, 11:09 PM   #3
DoNDoN
Colonel
DoNDoN's Avatar
Thailand
28
Rep
2,038
Posts

 
Drives: 2008 E92 M3 AW
Join Date: Jun 2008
Location: NoVA

iTrader: (1)

It means you need to lower that car immediately.
__________________
Appreciate 0
      01-14-2009, 12:57 PM   #4
ase2dais
//Mdicted
ase2dais's Avatar
United_States
126
Rep
9,874
Posts

 
Drives: a Cop Magnet
Join Date: Sep 2005
Location: 495 Ring

iTrader: (17)

Garage List
lol
Quote:
Originally Posted by MTrizzy View Post
So I am driving on the way home from work the other day and the Service engine light comes on....the car is indicating "Increased Emissions" anyone had experience with this?

The dealer is saying they are investigating a faulty thermostat, but I'm not sure that jives with me....anyone got any clues as to what this could be.
nope! mine runs ok so far, Knock on Wood

... but I only have 1800 miles
Appreciate 0
      01-15-2009, 12:39 PM   #5
bogdan
First Lieutenant
bogdan's Avatar
6
Rep
371
Posts

 
Drives: Z06
Join Date: Jan 2009
Location: Rockville, MD

iTrader: (0)

Quote:
Originally Posted by MTrizzy View Post
So I am driving on the way home from work the other day and the Service engine light comes on....the car is indicating "Increased Emissions" anyone had experience with this?

The dealer is saying they are investigating a faulty thermostat, but I'm not sure that jives with me....anyone got any clues as to what this could be.
The fault can appear for any multitude of things. It is possible that a stuck open thermostat could cause this, since it would affect the way that the car comes up to operating temperature.

Did you have a Service Engine Soon light, or Reduced power warning?
__________________
E90 M3-gone|E92 335i-gone
Quote:
Originally Posted by Mjolnir View Post
My dog swallowed my FOB. Luckily it was Comfort Access so I could still drive the car. Of course I had to take him with me everywhere and every time he rolled over the windows went down.
Appreciate 0
      01-16-2009, 05:31 PM   #6
MTrizzy
Lieutenant
MTrizzy's Avatar
United_States
5
Rep
448
Posts

 
Drives: 2008 AW M3 Coupe
Join Date: Mar 2008
Location: Potomac, MD

iTrader: (1)

Hit it right on the head.... dealer diagnosed it as a thermostat that was stuck open. Replaced thermostat and am back up and running.

btw. pushing 11.5K miles, you guys need to catch up ! haha
__________________

AW E92 M3|E92 LuX|Piaa GTX H3| Rear Fog Light Mod | Ventureshield (Raja)
|Eisenmann Race Exhaust |Macht Schnell Filter | Black Grills | Black Sides | H&R Springs | Fabspeed X-Pipe & High Flow Cats| CF VRS II rep diffuser|Most powerful Scoops in the world|
Appreciate 0
      01-16-2009, 06:38 PM   #7
ase2dais
//Mdicted
ase2dais's Avatar
United_States
126
Rep
9,874
Posts

 
Drives: a Cop Magnet
Join Date: Sep 2005
Location: 495 Ring

iTrader: (17)

Garage List
so does that mean you're joining for a cruise with the M3post boys tomorrow
Appreciate 0
      01-17-2009, 12:13 AM   #8
BCMPOWER
Captain
BCMPOWER's Avatar
United_States
7
Rep
626
Posts

 
Drives: 08 Silverstone II M3
Join Date: Dec 2007
Location: Silver Spring MD

iTrader: (0)

Quote:
Originally Posted by MTrizzy View Post
Hit it right on the head.... dealer diagnosed it as a thermostat that was stuck open. Replaced thermostat and am back up and running.

btw. pushing 11.5K miles, you guys need to catch up ! haha
You need to catch up with me I am almost at the 12k mark. I am glad your problem was a relatively minor one, who's your service manager? Mine is Stephane Grabina platinum team.
__________________
Appreciate 0
      01-19-2009, 09:05 PM   #9
ase2dais
//Mdicted
ase2dais's Avatar
United_States
126
Rep
9,874
Posts

 
Drives: a Cop Magnet
Join Date: Sep 2005
Location: 495 Ring

iTrader: (17)

Garage List
I just broke 2k mark last wkend
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:19 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST