BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Engine, Transmission, Exhaust, Drivetrain, ECU Software Modifications
 
BPM Sport
Post Reply
 
Thread Tools Search this Thread
      11-20-2008, 12:41 AM   #1
bimmergoat
Private First Class
 
Drives: M3 E90 Jerez Black
Join Date: Feb 2008
Location: charlotte

Posts: 161
iTrader: (0)

AFE Dry Filter

I installed it last night in 15 minutes and I was not expecting much more than a cool sound but I noticed more power the minute I floored it. My tires now spin a lot easier and the car sounds louder at any speed. Can't wait to install the RAM Air scoops tomorrow. It's easily the best low cost mod I've had on any car.
bimmergoat is offline  
0
Reply With Quote
      11-20-2008, 01:09 PM   #2
BMW F22
Major General
 
BMW F22's Avatar
 
Drives: ///M235i
Join Date: Nov 2005
Location: Around the Bay

Posts: 8,280
iTrader: (8)

Glad you like it! Those filters have been getting very good reviews.
BMW F22 is offline   United_States
0
Reply With Quote
      11-20-2008, 01:25 PM   #3
doba_s
Major General
 
doba_s's Avatar
 
Drives: M3, 1M
Join Date: Sep 2006
Location: San Francisco

Posts: 6,101
iTrader: (26)

Send a message via Skype™ to doba_s
how can you notice power increase just by driving it? ...i mean it adds 1-2whp at the best, and i don't think that human can notice that difference on 414hp car ...

i don't see how air filter can help your wheels to spin better ...
doba_s is offline   United_States
0
Reply With Quote
      11-20-2008, 05:03 PM   #4
bimmergoat
Private First Class
 
Drives: M3 E90 Jerez Black
Join Date: Feb 2008
Location: charlotte

Posts: 161
iTrader: (0)

Not sure about the power gains but it responds quicker when I press the gas.
bimmergoat is offline  
0
Reply With Quote
      11-20-2008, 05:22 PM   #5
Socale92
DCT Test Pilot
 
Drives: ????
Join Date: Apr 2008
Location: los angeles

Posts: 558
iTrader: (1)

Quote:
Originally Posted by bimmergoat View Post
Not sure about the power gains but it responds quicker when I press the gas.
same thing when i added sport filter to my e46 m3...
Socale92 is offline  
0
Reply With Quote
      11-20-2008, 05:40 PM   #6
eagletangogreen
Got Track!!!!!!
 
eagletangogreen's Avatar
 
Drives: 08 M3 coupe
Join Date: Aug 2008
Location: Fayetteville..NC

Posts: 383
iTrader: (0)

Send a message via AIM to eagletangogreen Send a message via Yahoo to eagletangogreen
Quote:
Originally Posted by doba_s View Post
how can you notice power increase just by driving it? ...i mean it adds 1-2whp at the best, and i don't think that human can notice that difference on 414hp car ...

i don't see how air filter can help your wheels to spin better ...
Thats becuase its been freaking cold here in NC the last few days>>> A farm tractor could burn out in these conditions>>>
eagletangogreen is offline   United_States
0
Reply With Quote
      11-20-2008, 06:07 PM   #7
bimmergoat
Private First Class
 
Drives: M3 E90 Jerez Black
Join Date: Feb 2008
Location: charlotte

Posts: 161
iTrader: (0)

Good point about it being cold, it's not that bad right now so I will see after I put the AFE Ram air scoops on tonight.
bimmergoat is offline  
0
Reply With Quote
      11-29-2008, 02:54 AM   #8
jdmish
Second Lieutenant
 
jdmish's Avatar
 
Drives: e92
Join Date: Sep 2008
Location: Southern California

Posts: 203
iTrader: (2)

i just installed the dry filter today, anyone else running these notice a rattling type sound during hard acceleration?
jdmish is offline  
0
Reply With Quote
      11-29-2008, 11:25 AM   #9
eagletangogreen
Got Track!!!!!!
 
eagletangogreen's Avatar
 
Drives: 08 M3 coupe
Join Date: Aug 2008
Location: Fayetteville..NC

Posts: 383
iTrader: (0)

Send a message via AIM to eagletangogreen Send a message via Yahoo to eagletangogreen
Quote:
Originally Posted by jdmish View Post
i just installed the dry filter today, anyone else running these notice a rattling type sound during hard acceleration?
I get from 2500 thru 3000 ish...

My built 350Z with forged internal does the same thing>>>> So I am not sweating it, not to mention i ran my best time knowing the car does it>> so no loss in power..
eagletangogreen is offline   United_States
0
Reply With Quote
      11-29-2008, 05:11 PM   #10
jdmish
Second Lieutenant
 
jdmish's Avatar
 
Drives: e92
Join Date: Sep 2008
Location: Southern California

Posts: 203
iTrader: (2)

Quote:
Originally Posted by eagletangogreen View Post
I get from 2500 thru 3000 ish...

My built 350Z with forged internal does the same thing>>>> So I am not sweating it, not to mention i ran my best time knowing the car does it>> so no loss in power..
i reinstalled the filter again, the noise seems to be gone
jdmish is offline  
0
Reply With Quote
      11-29-2008, 05:34 PM   #11
bimmergoat
Private First Class
 
Drives: M3 E90 Jerez Black
Join Date: Feb 2008
Location: charlotte

Posts: 161
iTrader: (0)

i get the same rattling sound. When you reinstalled it did you notice any areas that were not seated properly? Just curious how the noise went away.
bimmergoat is offline  
0
Reply With Quote
      11-29-2008, 05:41 PM   #12
jdmish
Second Lieutenant
 
jdmish's Avatar
 
Drives: e92
Join Date: Sep 2008
Location: Southern California

Posts: 203
iTrader: (2)

Quote:
Originally Posted by bimmergoat View Post
i get the same rattling sound. When you reinstalled it did you notice any areas that were not seated properly? Just curious how the noise went away.
it took 3 re-installs. Everytimei wiggled things around so it fits differently. You may be hearing a fluttering type sound, i believe its just the air being sucked in thats making that noise
jdmish is offline  
0
Reply With Quote
      12-12-2008, 05:07 AM   #13
MrHarris
yodog
 
MrHarris's Avatar
 
Drives: '86 Corolla
Join Date: Jun 2007
Location: Diamond Bar, Ca

Posts: 5,037
iTrader: (5)

Garage List
2009 BMW  [5.00]
Send a message via AIM to MrHarris
I hear a fluttering sound 3-4k rpm in like 2nd/3rd/4th gear. Not sure if something's rattling or if this is just how it's supposed to sound. Everyone else having the same "flutter" sound?
__________________

2009 E92 M3 | Alpine White | Black Extended | Advan RS | Turner Test Pipes | Dinan Axle-Back | OETuning | Eibach Springs | UUC SSK | VRS Front Lip | VRS Type I Diffuser | Matte Black | RPi Scoops | MS Filter | Yokohama AD08 | F1 Pinnacle
Special Thanks: Gintani | OETuning | eAs
MrHarris is offline   United_States
0
Reply With Quote
      12-12-2008, 12:19 PM   #14
doba_s
Major General
 
doba_s's Avatar
 
Drives: M3, 1M
Join Date: Sep 2006
Location: San Francisco

Posts: 6,101
iTrader: (26)

Send a message via Skype™ to doba_s
Quote:
Originally Posted by eagletangogreen View Post
Thats becuase its been freaking cold here in NC the last few days>>> A farm tractor could burn out in these conditions>>>
haha ... in that case you can spin your tires even without filter
doba_s is offline   United_States
0
Reply With Quote
      12-12-2008, 01:15 PM   #15
tom @ eas
BimmerPost Supporting Vendor

 
tom @ eas's Avatar
 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

Posts: 10,112
iTrader: (13)

Garage List
Quote:
Originally Posted by jdmish View Post
it took 3 re-installs. Everytimei wiggled things around so it fits differently. You may be hearing a fluttering type sound, i believe its just the air being sucked in thats making that noise
Quote:
Originally Posted by MrHarris View Post
I hear a fluttering sound 3-4k rpm in like 2nd/3rd/4th gear. Not sure if something's rattling or if this is just how it's supposed to sound. Everyone else having the same "flutter" sound?
Same noise experienced with installation of the new filter.
__________________
tom @ eas is offline   United_States
0
Reply With Quote
      12-12-2008, 08:20 PM   #16
MrHarris
yodog
 
MrHarris's Avatar
 
Drives: '86 Corolla
Join Date: Jun 2007
Location: Diamond Bar, Ca

Posts: 5,037
iTrader: (5)

Garage List
2009 BMW  [5.00]
Send a message via AIM to MrHarris
Quote:
Originally Posted by tom @ eas View Post
Same noise experienced with installation of the new filter.
So it's normal?
__________________

2009 E92 M3 | Alpine White | Black Extended | Advan RS | Turner Test Pipes | Dinan Axle-Back | OETuning | Eibach Springs | UUC SSK | VRS Front Lip | VRS Type I Diffuser | Matte Black | RPi Scoops | MS Filter | Yokohama AD08 | F1 Pinnacle
Special Thanks: Gintani | OETuning | eAs
MrHarris is offline   United_States
0
Reply With Quote
      12-12-2008, 08:40 PM   #17
tom @ eas
BimmerPost Supporting Vendor

 
tom @ eas's Avatar
 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

Posts: 10,112
iTrader: (13)

Garage List
Quote:
Originally Posted by MrHarris View Post
So it's normal?
Yes, it's normal.
__________________
tom @ eas is offline   United_States
0
Reply With Quote
      12-12-2008, 08:42 PM   #18
boostedtwin
Sheriff
 
boostedtwin's Avatar
 
Drives: 2012 1M // 2008 GT3
Join Date: Mar 2007
Location: Brazil/Miami

Posts: 1,457
iTrader: (10)

Garage List
07 335i  [0.00]
07 335i  [0.00]
Did mine today, no noises...
__________________
2012 1M / TechTec Custom Map Tune / AA FMIC / Agency Power Charge Pipe & BOV / Agency Power Downpipes & Mid Pipe / Custom Race Open Exhaust / Clutchmasters FX300 Racing Clutch / AFE Dual Intake System / H&R Spacers / CDV Delete / Black Grills / CF Performance Spoiler & Mirrors / Sprint Booster / Feuer Orange Calipers
boostedtwin is offline  
0
Reply With Quote
      12-12-2008, 10:58 PM   #19
eagletangogreen
Got Track!!!!!!
 
eagletangogreen's Avatar
 
Drives: 08 M3 coupe
Join Date: Aug 2008
Location: Fayetteville..NC

Posts: 383
iTrader: (0)

Send a message via AIM to eagletangogreen Send a message via Yahoo to eagletangogreen
I adjusted mine!

I threw it in the Microwave for 20sec to warm it up (the rubber ends) and re installed it, and NO more noise.

Warning!!! DO NOT use your daily use Microwave to do this, you might get some sparks..
eagletangogreen is offline   United_States
0
Reply With Quote
      12-13-2008, 12:13 AM   #20
jdmish
Second Lieutenant
 
jdmish's Avatar
 
Drives: e92
Join Date: Sep 2008
Location: Southern California

Posts: 203
iTrader: (2)

Quote:
Originally Posted by eagletangogreen View Post
I adjusted mine!

I threw it in the Microwave for 20sec to warm it up (the rubber ends) and re installed it, and NO more noise.

Warning!!! DO NOT use your daily use Microwave to do this, you might get some sparks..
so you think the noise is due to poor fitment of where the rubber meets? if so this means there is gap where unfiltered air is getting through
jdmish is offline  
0
Reply With Quote
      12-13-2008, 01:36 AM   #21
OC ///M
Dr. Octagon
 
OC ///M's Avatar
 
Drives: Moonstone e92 M3
Join Date: Feb 2007
Location: So Cal

Posts: 1,813
iTrader: (0)

Quote:
Originally Posted by jdmish View Post
so you think the noise is due to poor fitment of where the rubber meets? if so this means there is gap where unfiltered air is getting through
Hhhm...after reading all this, I may have to go investigate mine as well. I experience the same bitchin' rattle sound, but until reading this thread, attributed it to the extra air causing a different tone within the box. It's seems pretty consistant among a lot of the members, myself included-under heavy load, ~3k rpm, 2-3 sec. duration.

FWIW- mine is not the dry version either.
__________________
OC ///M

2013 E92 M3 Individual
Sold: 2011 E92 M3 SSII | Sold: 2008 E92 M3 SSII | Into a Wall: 2008 E92 M3 SSII | Sold: 2007 E92 335i JB
OC ///M is offline   United_States
0
Reply With Quote
      12-13-2008, 10:27 AM   #22
eagletangogreen
Got Track!!!!!!
 
eagletangogreen's Avatar
 
Drives: 08 M3 coupe
Join Date: Aug 2008
Location: Fayetteville..NC

Posts: 383
iTrader: (0)

Send a message via AIM to eagletangogreen Send a message via Yahoo to eagletangogreen
Quote:
Originally Posted by jdmish View Post
so you think the noise is due to poor fitment of where the rubber meets? if so this means there is gap where unfiltered air is getting through
I am going to say your right, but it may be a bunch of things that could cause the rattling noise..

I just one upped my adjustment, I used some silicone seal (easy to take off) to help seal the edges. Did a 7 runs in diffrent gears at low rpms and NO noise!
eagletangogreen is offline   United_States
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:48 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST