BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Track / Autocross / Dragstrip / Driving Techniques
 
PYSPEED
Post Reply
 
Thread Tools Search this Thread
      07-13-2014, 07:56 PM   #1
Kunman
Second Lieutenant
3
Rep
275
Posts

Drives: m3
Join Date: Jun 2013
Location: Canada

iTrader: (0)

is this nomal? Race pads

I recently installed the Club Racer RC08 pads by Project Mu. Apart from the standard absentee cold initial bite and the dump truck brake squeak, it seems like I am experience some problems that I've never read about track pads before:

1. after my first full lock left turn, the brakes started to make faint squeaks, perhaps making contact with the rotor.

2. the rear quarter of the vehicle makes a slight but noticeable rumble sound during braking.

3. the car on a lift light is on ( but i suspect this is because i broke the rear pad sensor)

Is this normal? I haven't got the chance to bed-in the rear brake pads yet. But i would like to resolve these two problems before taking the car to the faster speeds required for bed-in.

thank you

Last edited by Kunman; 07-13-2014 at 08:42 PM.
Appreciate 0
      07-13-2014, 09:49 PM   #2
bigjae1976
That's what she said...
bigjae1976's Avatar
91
Rep
5,778
Posts

Drives: 11 E90 M3 Individual
Join Date: Mar 2006
Location: Milwaukee, WI

iTrader: (12)

Garage List
2004 BMW M3  [4.50]
2011 BMW E90 M3  [5.00]
2013 BMW 328i  [5.00]
If I had to guess...you smoked a pad sensor and your rear pads are rattling.
__________________


Sponsored by Momentum BMW #593...We Bleed BMW BLUE!
Appreciate 0
      07-17-2014, 04:39 AM   #3
pkimM3r
Banned
pkimM3r's Avatar
98
Rep
7,321
Posts

Drives: m3 saloon in granny mode.
Join Date: Dec 2009
Location: lost angeles

iTrader: (0)

these dont have the clips on the outer pad right? its just touching on rotor even when not on brakes. your brake sensor is done too.
Appreciate 0
      07-17-2014, 10:14 AM   #4
Kunman
Second Lieutenant
3
Rep
275
Posts

Drives: m3
Join Date: Jun 2013
Location: Canada

iTrader: (0)

Quote:
Originally Posted by SlowSaloonM3 View Post
these dont have the clips on the outer pad right? its just touching on rotor even when not on brakes. your brake sensor is done too.
yep, problem fixed. I installed one of the back anti rattle spring wrong.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:12 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST