BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > Coding / ConnectedDrive / Audio-Video / Electronics / Bluetooth / I-Drive & Nav
 
OneEighty
Post Reply
 
Thread Tools Search this Thread
      10-16-2013, 10:04 AM   #1
bklynbimmer
Private First Class
1
Rep
145
Posts

 
Drives: E90 M3
Join Date: Oct 2008
Location: NYC

iTrader: (2)

iPhone 5s Not Working with 2011 M3

Just got the new iphone 5s and when i plug it in to play music (via the lightning usb cable) it says "this accessory is not supported" on my iphone!

I upgraded from a 4s running iOS 7 and had 0 issues!!

I'm dying having to listen to the radio

As per Apple's recommendation I used a different lightning cable, but still the same issue.
Is this a BMW software issue?!
Appreciate 0
      10-16-2013, 11:36 AM   #2
ILSMKU
BMW FTW
ILSMKU's Avatar
No_Country
37
Rep
1,927
Posts

 
Drives: E92 M3
Join Date: Jul 2011
Location: ///OC

iTrader: (5)

Garage List
That sucks!
__________________
///2013 AW 6MT E92 ZCP M3/// Black 359M Wheels/BMW Performance Carbon Fiber Spoiler and Mirror Caps/Arkym AeroSport Front Lip/Turner 15MM Spacers/LUX 8 LED Halo/IND Gloss Black Grills, Gills and M3 Emblem/30% 3M Tint/BMW Interior LED/MusicCar Subwoofer Enclosure/JL Audio 12" W6 Sub and XD600:1 Amp/Euro Sunglasses Tray/Ceramic Coated Megan Racing Exhaust/AFe Dry Air Filter/RPI Intake Scoops/Euro MDM/Feature Coded.
Appreciate 0
      10-16-2013, 01:09 PM   #3
dparm
Major
dparm's Avatar
United_States
14
Rep
1,447
Posts

 
Drives: 2011.5 E90 M3
Join Date: Jun 2013
Location: Chicago, IL

iTrader: (0)

I've had no problems with my 5s. It may help if you tell us a bit more about your car and the phone...

Did you download the latest BMW software? (bmw.com/update)

Do you have iOS 7.0.2?
__________________
2011.5 AW M3 sedan ZCP
Appreciate 0
      10-16-2013, 01:37 PM   #4
bmwretrofit
Captain
bmwretrofit's Avatar
Canada
40
Rep
626
Posts

 
Drives: BMW
Join Date: Nov 2010
Location: Canada

iTrader: (0)

Quote:
Originally Posted by bklynbimmer View Post
Just got the new iphone 5s and when i plug it in to play music (via the lightning usb cable) it says "this accessory is not supported" on my iphone!

I upgraded from a 4s running iOS 7 and had 0 issues!!

I'm dying having to listen to the radio

As per Apple's recommendation I used a different lightning cable, but still the same issue.
Is this a BMW software issue?!
Hello.

Try to update your Combox firmware via USB.
__________________
_________________
Bimmer Retrofit Inc.
Tel: +1.450.844.4655 | email: info@bimmerretrofit.com | www.bimmerretrofit.com | Bimmer Retrofit Support Forums
CIC and NBT retrofit kits, Safety and Security Systems Retrofits, Multimedia Retrofits, etc.

Appreciate 0
      10-17-2013, 11:36 AM   #5
bklynbimmer
Private First Class
1
Rep
145
Posts

 
Drives: E90 M3
Join Date: Oct 2008
Location: NYC

iTrader: (2)

Thanks for the help, sadly I'm still music-less

The iPhone 5s is running iOS 7.0.2, I have the latest combox software versions:
Multimedia: MX 3.5.4
Telephone: TX 3.5.6

The car one of the last e90 M3's so late 2011 production
Appreciate 0
      10-17-2013, 12:30 PM   #6
skypx
Veteran U.S. Army
skypx's Avatar
United_States
11
Rep
671
Posts

 
Drives: ///M
Join Date: Nov 2011
Location: USA

iTrader: (0)

Press and hold the home button + power button (at the same time) until the phone restarts. This may fix the issue. Also delete the Bluetooth connection from the car and phone and recreate it. Good luck!
Appreciate 0
      10-17-2013, 03:10 PM   #7
Kris@Modmynav
Kris@Modmynav's Avatar
United_States
35
Rep
1,311
Posts

 
Drives: 11 E90 M3
Join Date: Dec 2007
Location: Chicago

iTrader: (12)

Send a message via MSN to Kris@Modmynav
OP, are you using aftermarket lightning cable?

iOS 7+ won't support 3rd party cables, try with genuine Apple cable.
Appreciate 0
      10-17-2013, 04:16 PM   #8
andeee05
Private First Class
andeee05's Avatar
United_States
2
Rep
138
Posts

 
Drives: e92 m3
Join Date: Mar 2012
Location: los angeles

iTrader: (5)

i'm having the same problem. i'm not using the usb lightning cord that came with the phone and my phone is charging but on idrive it says that it is not supported. i have 2009 so i can't update via usb it says you need a 2010 or later to update i think.
__________________
AngeliBright-Swift-Arkym-Macht Schnell-Ind-Volks-Arqray
Appreciate 0
      10-20-2013, 12:30 PM   #9
edwinm3
Colonel
edwinm3's Avatar
United_States
38
Rep
2,130
Posts

 
Drives: E92 MELBOURNE RED M3
Join Date: Nov 2011
Location: Doral

iTrader: (10)

I just got the iphone 5 craddle for my 2010 M3, all it's doing is charging, no music or anything. Not sure what I'm doing wrong but this sucks
__________________
Appreciate 0
      10-20-2013, 06:11 PM   #10
bklynbimmer
Private First Class
1
Rep
145
Posts

 
Drives: E90 M3
Join Date: Oct 2008
Location: NYC

iTrader: (2)

Quote:
Originally Posted by Kris@Modmynav View Post
OP, are you using aftermarket lightning cable?

iOS 7+ won't support 3rd party cables, try with genuine Apple cable.
I am using a genuine Apple lightning cable... I even tried another genuine Apple cable, but still the same deal!

Apple doesn't know anything about it and BMW doesn't know anything about it!
Appreciate 0
      12-19-2013, 08:04 PM   #11
SoTempted
Captain
SoTempted's Avatar
8
Rep
758
Posts

 
Drives: Incompetently
Join Date: Jan 2011
Location: Clovis, NM

iTrader: (2)

Help!
Appreciate 0
      12-21-2013, 05:35 PM   #12
dparm
Major
dparm's Avatar
United_States
14
Rep
1,447
Posts

 
Drives: 2011.5 E90 M3
Join Date: Jun 2013
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by SoTempted View Post
Help!
Help with what? Your post gives us ZERO information.
__________________
2011.5 AW M3 sedan ZCP
Appreciate 0
      12-21-2013, 05:58 PM   #13
SoTempted
Captain
SoTempted's Avatar
8
Rep
758
Posts

 
Drives: Incompetently
Join Date: Jan 2011
Location: Clovis, NM

iTrader: (2)

Quote:
Originally Posted by dparm View Post
Help with what? Your post gives us ZERO information.
Same issue as OP was implied.
Appreciate 0
      12-22-2013, 03:12 AM   #14
dparm
Major
dparm's Avatar
United_States
14
Rep
1,447
Posts

 
Drives: 2011.5 E90 M3
Join Date: Jun 2013
Location: Chicago, IL

iTrader: (0)

It would help if you told us the iOS version of your phone and the year of your car, along with the specific software versions and options you have.
__________________
2011.5 AW M3 sedan ZCP
Appreciate 0
      12-22-2013, 08:14 AM   #15
vastano
Lieutenant
9
Rep
595
Posts

 
Drives: E90 M3
Join Date: Nov 2012
Location: Kansas City, MO

iTrader: (3)

No problems with my iPhone 5s either
__________________
Appreciate 0
      01-31-2014, 07:22 PM   #16
Richy Rich
#FRZNM3
Richy Rich's Avatar
United_States
18
Rep
211
Posts

 
Drives: 2015 MG F80
Join Date: Jan 2014
Location: Los Angeles

iTrader: (0)

I have a 2011 Frozen Grey edition and had to have Mike from BPM Sport retrofit combox for me to use my 5S and have bluetooth audio -- probably the same issue you're seeing. Something that needs to be done if your car went into production before September 2010.
Appreciate 0
      02-13-2014, 05:16 PM   #17
lsmkr01
Lieutenant Colonel
lsmkr01's Avatar
United_States
17
Rep
1,646
Posts

 
Drives: E92 M3
Join Date: Feb 2007
Location: SC

iTrader: (0)

Quote:
Originally Posted by Richy Rich View Post
I have a 2011 Frozen Grey edition and had to have Mike from BPM Sport retrofit combox for me to use my 5S and have bluetooth audio -- probably the same issue you're seeing. Something that needs to be done if your car went into production before September 2010.
How much was that? I'm going to have to find someone near Carolina to do this same thing.
Appreciate 0
      02-18-2014, 02:06 AM   #18
R2K
New Member
0
Rep
23
Posts

 
Drives: 2011 335i Sedan
Join Date: Dec 2013
Location: California

iTrader: (0)

if you have option 6FL (iPod adapter), you'll need the Y Cable. The cradle does us no good unless you got the later 2011 models with BMW connect.
Appreciate 0
      02-18-2014, 08:08 PM   #19
dparm
Major
dparm's Avatar
United_States
14
Rep
1,447
Posts

 
Drives: 2011.5 E90 M3
Join Date: Jun 2013
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by R2K View Post
if you have option 6FL (iPod adapter), you'll need the Y Cable. The cradle does us no good unless you got the later 2011 models with BMW connect.

No you don't. Just use the USB-Lightning cable. I've been doing it this way since the 5s came out. Bluetooth audio also works fine, but the quality is not what I want.
__________________
2011.5 AW M3 sedan ZCP
Appreciate 0
      02-19-2014, 01:51 AM   #20
R2K
New Member
0
Rep
23
Posts

 
Drives: 2011 335i Sedan
Join Date: Dec 2013
Location: California

iTrader: (0)

Dparm - didn't read the post thoroughly - just saw he said late 2011. If so, must be a firmware issue.

Bklynbimmer - in any case, try checking out the thread and vin decoder site below. Sorry this newbie isn't of much help.

Thread on usb adapter:
http://www.e90post.com/forums/showthread.php?t=758527

Vin lookup:
http://www.bmwarchiv.de/vin/bmw-vin-decoder.html
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:30 PM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST