BMW M3 Forum (E90 E92)

BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   M3Post - BMW M3 Forum > E90/E92 M3 Technical Topics > DIY Guides/ Discussions
 
Steve Thomas BMW
Post Reply
 
Thread Tools Search this Thread
      12-27-2012, 12:06 PM   #111
wjesco
Engineer
 
wjesco's Avatar
 
Drives: 2011 IB M3 Sedan
Join Date: May 2011
Location: Orlando, FL

Posts: 41
iTrader: (0)

Hello all,

I am getting a right turn signal malfunction after installing my WeissLicht Amber Turn Signal bulbs . Has anyone here experienced the same problem. I am at the dealership for an Auto Butler service and Oil Change and I asked the SA and he told me that it could be because I replaced a halogen bulb with an LED bulb that has less resistance.

I thought these things were supposed to be error free? I am only getting the error against the right side turn signal even though they both seem to work just fine.

Any ideas?

Thanks,
__________________
2011 E90 M3 M-Individual Fox Red/Black Two Tone Interior/Steering wheel,3D Design front lip,Type II Diffuser,IND reflectors,Cyber Scoops,Performance front grills/side grilles w/LED light, Macht Schnell Spacers, ZCP,ZCV,ZP3,6MT,Split rear seat, BMW Apps, EPS
1995 325is, 1991 735iL
wjesco is offline   United_States
0
Reply With Quote
      12-27-2012, 12:27 PM   #112
Kris@Modmynav
 
Kris@Modmynav's Avatar
 
Drives: 11 E90 M3
Join Date: Dec 2007
Location: Chicago

Posts: 1,311
iTrader: (12)

Send a message via MSN to Kris@Modmynav
Quote:
Originally Posted by wjesco View Post
Hello all,

I am getting a right turn signal malfunction after installing my WeissLicht Amber Turn Signal bulbs . Has anyone here experienced the same problem. I am at the dealership for an Auto Butler service and Oil Change and I asked the SA and he told me that it could be because I replaced a halogen bulb with an LED bulb that has less resistance.

I thought these things were supposed to be error free? I am only getting the error against the right side turn signal even though they both seem to work just fine.

Any ideas?

Thanks,
Same here, mine throw the same error - right turn signal malfunction.

However it goes away after few blinks, it seems like I am getting this after I turn on/off the hazard lights.

I am going to code out bulb checks..
Kris@Modmynav is offline   United_States
0
Reply With Quote
      12-27-2012, 11:45 PM   #113
wjesco
Engineer
 
wjesco's Avatar
 
Drives: 2011 IB M3 Sedan
Join Date: May 2011
Location: Orlando, FL

Posts: 41
iTrader: (0)

Quote:
Originally Posted by Kris@Modmynav
Quote:
Originally Posted by wjesco View Post
Hello all,

I am getting a right turn signal malfunction after installing my WeissLicht Amber Turn Signal bulbs . Has anyone here experienced the same problem. I am at the dealership for an Auto Butler service and Oil Change and I asked the SA and he told me that it could be because I replaced a halogen bulb with an LED bulb that has less resistance.

I thought these things were supposed to be error free? I am only getting the error against the right side turn signal even though they both seem to work just fine.

Any ideas?

Thanks,
Same here, mine throw the same error - right turn signal malfunction.

However it goes away after few blinks, it seems like I am getting this after I turn on/off the hazard lights.

I am going to code out bulb checks..
How do you code out the bulb check?
__________________
2011 E90 M3 M-Individual Fox Red/Black Two Tone Interior/Steering wheel,3D Design front lip,Type II Diffuser,IND reflectors,Cyber Scoops,Performance front grills/side grilles w/LED light, Macht Schnell Spacers, ZCP,ZCV,ZP3,6MT,Split rear seat, BMW Apps, EPS
1995 325is, 1991 735iL
wjesco is offline   United_States
0
Reply With Quote
      12-28-2012, 12:29 AM   #114
Kris@Modmynav
 
Kris@Modmynav's Avatar
 
Drives: 11 E90 M3
Join Date: Dec 2007
Location: Chicago

Posts: 1,311
iTrader: (12)

Send a message via MSN to Kris@Modmynav
Quote:
Originally Posted by wjesco View Post
How do you code out the bulb check?
Custom coding..
Kris@Modmynav is offline   United_States
0
Reply With Quote
      01-02-2013, 11:18 AM   #115
wjesco
Engineer
 
wjesco's Avatar
 
Drives: 2011 IB M3 Sedan
Join Date: May 2011
Location: Orlando, FL

Posts: 41
iTrader: (0)

Quote:
Originally Posted by Kris@Modmynav
Quote:
Originally Posted by wjesco View Post
How do you code out the bulb check?
Custom coding..
I have decided to return the bulbs and re-install my egg yolks
I don't feel comfortable coding off bulb checks on a relatively new car. If this was my 1995 325is I wouldn't think twice about it.
I guess I will wait till someone makes stealth bulbs that are actually error free.
__________________
2011 E90 M3 M-Individual Fox Red/Black Two Tone Interior/Steering wheel,3D Design front lip,Type II Diffuser,IND reflectors,Cyber Scoops,Performance front grills/side grilles w/LED light, Macht Schnell Spacers, ZCP,ZCV,ZP3,6MT,Split rear seat, BMW Apps, EPS
1995 325is, 1991 735iL
wjesco is offline   United_States
0
Reply With Quote
      02-05-2013, 06:05 PM   #116
cntgetm3
Private First Class
 
cntgetm3's Avatar
 
Drives: E92 M3
Join Date: Feb 2012
Location: Jville, NC

Posts: 160
iTrader: (0)

Just installed mine ($22 ebay) they look good. havent taken her out yet so no coding issues over here. Ill post a Video once im done editing. *myediting skills leave much to be desired*
__________________
Lux v3, IND, V1 Hardwire, ZHP lighted shift knob, Megan Racing Axel Back, Custom race x-pipe, MS filter, Arkym Diffuser, OEM Carbon Lip Spoiler, and still more to come.
cntgetm3 is offline  
0
Reply With Quote
      06-03-2013, 04:42 PM   #117
ms2bmw
New Member
 
Drives: M3
Join Date: Apr 2013
Location: NorCal

Posts: 15
iTrader: (0)

Installed this last month and started getting the turn signal malfunction message. Initially it was on the left but now its also happening on the right. Bimmian is suggesting I set the headlamps to "off" and not "Auto". Anyone else have a solution other than "coding"?

I also asked bimmian why we have to shave the base of the bulb to make it fit the holder. Shouldn't this be part of the design of the bulb so we don't have to do any shaving?
ms2bmw is offline  
0
Reply With Quote
      06-10-2013, 10:58 AM   #118
Mr. M3
Enlisted Member
 
Drives: 2013 M3
Join Date: Jun 2013
Location: Walnut, CA

Posts: 34
iTrader: (0)

Anyone in socal area willing to help me install? I cant seem to get the damn lights out after removing the front panel!!!
Mr. M3 is offline  
0
Reply With Quote
      06-21-2013, 06:21 PM   #119
squidmark
Registered
 
Drives: 2012 E92 M3
Join Date: Apr 2013
Location: NorCal

Posts: 3
iTrader: (0)

Quote:
Originally Posted by DavidZ View Post
Success! After a disastrous first attempt where I thought I had bent one of the prongs inside the headlight beyond repair, I decided to try again (after bending the prong back again). Biggest tips I can give, probably been mentioned earlier but I'll reiterate:

1) Remove the wheel! Makes it much easier when you can stick your head and there and see things.
2) Once the bulb is removed, look inside to see the prongs in the housing; they are at 9 and 3 o'clock.
3) Sand the LED bulb as described earlier so they twist all the way in the base - or at least within 0.5 mm from full-twist which is what I did.
4) Orient the bulb/base so it's contacts are at 9 and 3 o'clock to line up with the prongs and slowly and firmly push into headlight until it's completely seated.
5) The most important step: check to make sure it works by switching on your hazard flashers before twisting the base to lock. If they don't work you've either missed or bent a prong. Without studying the contact mechanism before, I though you had to twist the base to make them work.
6) Once they're working, only then twist clockwise to lock and then test once more with the hazards for good measure before putting cover and wheel back.
I did exactly what David ran into (before reading his comments). Spent an hour cursing and spitting when I couldn't get the LED or old bulb back into the driver's side. Finally took off the wheel, unbent the pins and got the damn thing installed.

Like he said: take the wheels off and use the hazards to check pin contact before turning the carrier into place.

It took me 1hr + to do the driver side and repair bent pins. 5 minutes to do passenger with the wheel off knowing what to look for.
squidmark is offline  
0
Reply With Quote
      07-09-2013, 12:19 AM   #120
Bleen
Mmmmmmmm 3
 
Bleen's Avatar
 
Drives: 2010 E93 M3
Join Date: Jun 2013
Location: Los Angeles, CA

Posts: 28
iTrader: (0)

Quote:
Originally Posted by Mr. M3 View Post
Anyone in socal area willing to help me install? I cant seem to get the damn lights out after removing the front panel!!!
I JUST got these in the mail, and I'm in LA... but I'm probably in the same spot as you. Have you managed to do it?
__________________
2005 SLK350 - Gone!
2010 E93 M3 - Gone!
2009 V8 Vantage
Bleen is offline   United_States
0
Reply With Quote
      07-09-2013, 05:03 PM   #121
Mr. M3
Enlisted Member
 
Drives: 2013 M3
Join Date: Jun 2013
Location: Walnut, CA

Posts: 34
iTrader: (0)

I took it to EAS to get it installed since I didn't have a carjack, but have to go back since my driver side bulb went out completely.

Quote:
Originally Posted by Bleen View Post
I JUST got these in the mail, and I'm in LA... but I'm probably in the same spot as you. Have you managed to do it?
Mr. M3 is offline  
0
Reply With Quote
      07-09-2013, 05:46 PM   #122
Bleen
Mmmmmmmm 3
 
Bleen's Avatar
 
Drives: 2010 E93 M3
Join Date: Jun 2013
Location: Los Angeles, CA

Posts: 28
iTrader: (0)

Quote:
Originally Posted by Mr. M3 View Post
I took it to EAS to get it installed since I didn't have a carjack, but have to go back since my driver side bulb went out completely.
Who's EAS?
__________________
2005 SLK350 - Gone!
2010 E93 M3 - Gone!
2009 V8 Vantage
Bleen is offline   United_States
0
Reply With Quote
      07-09-2013, 05:59 PM   #123
tom @ eas
BimmerPost Supporting Vendor

 
tom @ eas's Avatar
 
Drives: BMW
Join Date: Nov 2005
Location: Anaheim, CA

Posts: 10,214
iTrader: (13)

Garage List
Quote:
Originally Posted by Bleen View Post
Who's EAS?
__________________
tom @ eas is offline   United_States
0
Reply With Quote
      08-07-2013, 08:36 PM   #124
wonton1017
Bit by Modbug
 
Drives: E92 335i M-sport
Join Date: Mar 2013
Location: here

Posts: 778
iTrader: (8)

The $10 pair I bought off ebay required shaving as well, I had to shave it at a different spot though, look below:


The one off ebay has different wiring as well, looks "cheaper".

But they work, they are bright and white and no errors.


Anyways thank you for the picture, thought I bought the wrong bulbs.
wonton1017 is offline   Canada
0
Reply With Quote
      09-10-2013, 01:00 PM   #125
TX_M3
Second Lieutenant
 
Drives: 08' e92 M3
Join Date: Jul 2013
Location: Houston Tx

Posts: 291
iTrader: (11)

looks like jlevi is now selling these bulbs. is anyone using this having any fitment problems?


http://www.jlevisw.com/accessories/B...for-92-BMW.htm
TX_M3 is offline   United_States
0
Reply With Quote
      09-19-2013, 12:16 PM   #126
Andy_H_E92_M3
Private First Class
 
Andy_H_E92_M3's Avatar
 
Drives: 2008 E92 ///M3
Join Date: Dec 2011
Location: NC

Posts: 157
iTrader: (10)

Quote:
Originally Posted by TX_M3 View Post
looks like jlevi is now selling these bulbs. is anyone using this having any fitment problems?
No fitment problems here.
Andy_H_E92_M3 is offline  
0
Reply With Quote
      10-26-2013, 09:33 PM   #127
imdrax
New Member
 
Drives: E92 M3
Join Date: Oct 2013
Location: United States

Posts: 11
iTrader: (0)

is everyone really having this much trouble installing them? I ordered mine from ebay for $15 shipped, no errors and installed pretty easy. Only thing i did was open the prongs up a little so it would be easier install and bam, slipped right in.
imdrax is offline  
0
Reply With Quote
      12-04-2013, 06:16 PM   #128
sachaja
New Member
 
Drives: 2008 BMW E92 M3
Join Date: Oct 2013
Location: USA

Posts: 23
iTrader: (0)

Quote:
Originally Posted by TX_M3 View Post
looks like jlevi is now selling these bulbs. is anyone using this having any fitment problems?


http://www.jlevisw.com/accessories/B...for-92-BMW.htm



I couldn't get these to attach firmly to the bulb holders . Every time I tried to install them into the light housing they became loose
sachaja is offline  
0
Reply With Quote
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:13 AM.




m3post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST